# XtraBackup | Replication | Table 'mysql.slave\_master\_info' cannot be opened.

**URL:** <https://forums.percona.com/t/xtrabackup-replication-table-mysql-slave-master-info-cannot-be-opened/4303>\
**Category:** Percona XtraBackup\
**Created:** [July 14, 2015, 9:34am UTC](https://forums.percona.com/t/xtrabackup-replication-table-mysql-slave-master-info-cannot-be-opened/4303 "2015-07-14T09:34:43Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![dchambers](https://avatars.discourse-cdn.com/v4/letter/d/d2c977/32.png) [@dchambers](https://forums.percona.com/u/dchambers)\
**Post date:** [July 14, 2015, 9:34am UTC](https://forums.percona.com/t/xtrabackup-replication-table-mysql-slave-master-info-cannot-be-opened/4303/1 "2015-07-14T09:34:43Z")

</div>

Hello - I am looking for some advise, I used Xtrabackup with no issues, fantastic bit of kit.  
I took a backup of my database from the master and then moved the files over to the slave without issue

It’s running but I am unable to get replication working now, it had worked before but the DB was fluffed!

2015-07-13 00:29:02 57003 [Warning] InnoDB: Cannot open table mysql/slave\_master\_info from the internal data dictionary of InnoDB though the .frm file for the table exists. See [url][http://dev.mysql.com/doc/refman/5.6/en/innodb-troubleshooting.html[/url]](http://dev.mysql.com/doc/refman/5.6/en/innodb-troubleshooting.html%5B/url%5D) for how you can resolve the problem.  
2015-07-13 00:29:02 57003 [Warning] Info table is not ready to be used. Table ‘mysql.slave\_master\_info’ cannot be opened.  
2015-07-13 00:29:02 57003 [ERROR] Error in checking mysql.slave\_master\_info repository info type of TABLE.  
2015-07-13 00:29:02 57003 [ERROR] Error creating master info: Error checking repositories.  
2015-07-13 00:29:02 57003 [ERROR] Failed to create or recover replication info repository.  
2015-07-13 00:29:02 57003 [Note] Check error log for additional messages. You will not be able to start replication until the issue is resolved.

It can not read the following tables for some reason:

| slave\_master\_info |  
| slave\_relay\_log\_info |  
| slave\_worker\_info |

mysql\> SELECT \* from slave\_worker\_info;  
ERROR 1146 (42S02): Table ‘mysql.slave\_worker\_info’ doesn’t exist  
mysql\>

The issue is extremely similar to to:  
[url][innodb - Cannot open table mysql/innodb\_index\_stats - Database Administrators Stack Exchange](http://dba.stackexchange.com/questions/48166/cannot-open-table-mysql-innodb-index-stats/48189#48189%5B/url%5D)

I have tried to drop these and re-create them but it keeps saying it exists.  
I have dropped the tables, deleted the files from /var/lib/mysql/mysql and then ran the mysql\_install\_db

rm -rf slave\_master\_info.ibd slave\_relay\_log\_info.frm slave\_relay\_log\_info.ibd slave\_worker\_info.frm slave\_worker\_info.ibd slave\_master\_info.frm

I have also tried the above steps, minus the install\_db and tried to create the tables however MySQL says the tables already exist?

They are no longer showing below but I cant create them?! as it says they exist ☹

mysql\> use mysql;  
Database changed  
mysql\> show tables;  
±--------------------------+  
| Tables\_in\_mysql |  
±--------------------------+  
| columns\_priv |  
| db |  
| event |  
| func |  
| general\_log |  
| help\_category |  
| help\_keyword |  
| help\_relation |  
| help\_topic |  
| host |  
| ndb\_binlog\_index |  
| plugin |  
| proc |  
| procs\_priv |  
| proxies\_priv |  
| servers |  
| slow\_log |  
| tables\_priv |  
| time\_zone |  
| time\_zone\_leap\_second |  
| time\_zone\_name |  
| time\_zone\_transition |  
| time\_zone\_transition\_type |  
| user |  
±--------------------------+  
24 rows in set (0.00 sec)

mysql\> CREATE TABLE `innodb_index_stats` ( `database_name` varchar(64) COLLATE utf8\_bin NOT NULL, `table_name` varchar(64) COLLATE utf8\_bin NOT NULL, `index_name` varchar(64) COLLATE utf8\_bin NOT NULL, `last_update` timestamp NOT NULL DEFAULT CURRENT\_TIMESTAMP ON UPDATE CURRENT\_TIMESTAMP, `stat_name` varchar(64) COLLATE utf8\_bin NOT NULL, `stat_value` bigint(20) unsigned NOT NULL, `sample_size` bigint(20) unsigned DEFAULT NULL, `stat_description` varchar(1024) COLLATE utf8\_bin NOT NULL, PRIMARY KEY (`database_name`,`table_name`,`index_name`,`stat_name`) ) ENGINE=InnoDB DEFAULT CHARSET=utf8 COLLATE=utf8\_bin STATS\_PERSISTENT=0;  
ERROR 1050 (42S01): Table ‘`mysql`.`innodb_index_stats`’ already exists

Can anyone help me?

---

<div class="post-metadata">

**Author:** ![dchambers](https://avatars.discourse-cdn.com/v4/letter/d/d2c977/32.png) [@dchambers](https://forums.percona.com/u/dchambers)\
**Post date:** [July 14, 2015, 9:36am UTC](https://forums.percona.com/t/xtrabackup-replication-table-mysql-slave-master-info-cannot-be-opened/4303/2 "2015-07-14T09:36:26Z")

</div>

2015-04-09 13:05:09 24242 [ERROR] Error in checking mysql.slave\_master\_info repository info type of TABLE.  
2015-04-09 13:05:09 24242 [ERROR] Error creating master info: Error checking repositories.  
2015-04-09 13:05:09 24242 [ERROR] Failed to create or recover replication info repository.  
2015-04-09 13:05:09 24242 [Note] Check error log for additional messages. You will not be able to start replication until the issue is resolved and the server restarted.

---

<div class="post-metadata">

**Author:** ![dchambers](https://avatars.discourse-cdn.com/v4/letter/d/d2c977/32.png) [@dchambers](https://forums.percona.com/u/dchambers)\
**Post date:** [July 14, 2015, 9:39am UTC](https://forums.percona.com/t/xtrabackup-replication-table-mysql-slave-master-info-cannot-be-opened/4303/3 "2015-07-14T09:39:54Z")

</div>

All files are owned by mysql:mysql

drwx------ 2 mysql mysql 4.0K Apr 8 04:50 common\_schema  
drwx------ 2 mysql mysql 2.9M Jul 12 22:49 database  
-rw-r----- 1 mysql mysql 1.2G Jul 14 16:03 ibdata1  
-rw-r–r-- 1 mysql mysql 256M Jul 14 16:03 ib\_logfile0  
-rw-r–r-- 1 mysql mysql 256M Jul 12 22:50 ib\_logfile1  
-rw-rw---- 1 mysql mysql 256M Jul 13 00:17 ib\_logfile101  
drwx------ 2 mysql mysql 4.0K Jul 14 16:03 mysql  
-rw-rw---- 1 mysql mysql 6 Jul 13 02:32 mysql.pid  
-rw-rw---- 1 mysql mysql 685M Sep 17 2014 mysql-slow.log  
srwxrwxrwx 1 mysql mysql 0 Jul 13 02:32 mysql.sock  
-rw-r–r-- 1 mysql mysql 11 Sep 30 2014 mysql\_upgrade\_info  
drwx------ 2 mysql mysql 4.0K Sep 30 2014 performance\_schema  
-rw-rw---- 1 mysql mysql 162 Jul 13 00:08 relaylog.000005  
-rw-rw---- 1 mysql mysql 69M Jul 13 00:11 relaylog.000006  
-rw-rw---- 1 mysql mysql 139 Jul 13 00:12 relaylog.000007  
-rw-rw---- 1 mysql mysql 54 Jul 13 00:11 relaylog.index  
-rw-r–r-- 1 mysql mysql 388 Sep 30 2014 RPM\_UPGRADE\_HISTORY  
-rw-r–r-- 1 mysql mysql 112 Sep 30 2014 RPM\_UPGRADE\_MARKER-LAST  
drwx------ 2 mysql mysql 4.0K Jul 13 01:35 test  
drwx------ 2 mysql mysql 4.0K Apr 8 04:50 time\_survey  
-rw-r–r-- 1 root root 24 Jul 12 22:48 xtrabackup\_binlog\_info  
-rw-r–r-- 1 root root 24 Jul 12 22:50 xtrabackup\_binlog\_pos\_innodb  
-rw-r----- 1 root root 101 Jul 12 22:50 xtrabackup\_checkpoints  
-rw-r–r-- 1 root root 573 Jul 12 22:48 xtrabackup\_info  
-rw-r----- 1 root root 18M Jul 12 22:50 xtrabackup\_logfile

-rw-rw---- 1 mysql mysql 8.7K Apr 8 04:50 columns\_priv.frm  
-rw-rw---- 1 mysql mysql 0 Apr 8 04:50 columns\_priv.MYD  
-rw-rw---- 1 mysql mysql 4.0K Apr 8 04:50 columns\_priv.MYI  
-rw-rw---- 1 mysql mysql 9.4K Apr 8 04:50 db.frm  
-rw-rw---- 1 mysql mysql 13K May 20 12:13 db.MYD  
-rw-rw---- 1 mysql mysql 5.0K May 21 14:06 db.MYI  
-rw-rw---- 1 mysql mysql 10K Apr 8 04:50 event.frm  
-rw-rw---- 1 mysql mysql 0 Apr 8 04:50 event.MYD  
-rw-rw---- 1 mysql mysql 2.0K Apr 8 04:50 event.MYI  
-rw-rw---- 1 mysql mysql 8.5K Apr 8 04:50 func.frm  
-rw-rw---- 1 mysql mysql 0 Apr 8 04:50 func.MYD  
-rw-rw---- 1 mysql mysql 1.0K Apr 8 04:50 func.MYI  
-rw-rw---- 1 mysql mysql 35 Jul 13 01:42 general\_log.CSM  
-rw-rw---- 1 mysql mysql 0 Sep 30 2014 general\_log.CSV  
-rw-rw---- 1 mysql mysql 8.6K Sep 30 2014 general\_log.frm  
-rw-rw---- 1 mysql mysql 8.5K Apr 8 04:50 help\_category.frm  
-rw-rw---- 1 mysql mysql 23K Apr 8 04:50 help\_category.MYD  
-rw-rw---- 1 mysql mysql 3.0K Apr 8 04:50 help\_category.MYI  
-rw-rw---- 1 mysql mysql 8.5K Apr 8 04:50 help\_keyword.frm  
-rw-rw---- 1 mysql mysql 88K Apr 8 04:50 help\_keyword.MYD  
-rw-rw---- 1 mysql mysql 16K Apr 8 04:50 help\_keyword.MYI  
-rw-rw---- 1 mysql mysql 8.5K Apr 8 04:50 help\_relation.frm  
-rw-rw---- 1 mysql mysql 8.9K Apr 8 04:50 help\_relation.MYD  
-rw-rw---- 1 mysql mysql 16K Apr 8 04:50 help\_relation.MYI  
-rw-rw---- 1 mysql mysql 8.6K Apr 8 04:50 help\_topic.frm  
-rw-rw---- 1 mysql mysql 446K Apr 8 04:50 help\_topic.MYD  
-rw-rw---- 1 mysql mysql 19K Apr 8 04:50 help\_topic.MYI  
-rw-rw---- 1 mysql mysql 9.3K Apr 8 04:50 host.frm  
-rw-rw---- 1 mysql mysql 0 Apr 8 04:50 host.MYD  
-rw-rw---- 1 mysql mysql 2.0K Apr 8 04:50 host.MYI  
-rw-rw---- 1 mysql mysql 8.6K Apr 8 04:50 ndb\_binlog\_index.frm  
-rw-rw---- 1 mysql mysql 0 Apr 8 04:50 ndb\_binlog\_index.MYD  
-rw-rw---- 1 mysql mysql 1.0K Apr 8 04:50 ndb\_binlog\_index.MYI  
-rw-rw---- 1 mysql mysql 8.4K Apr 8 04:50 plugin.frm  
-rw-rw---- 1 mysql mysql 0 Apr 8 04:50 plugin.MYD  
-rw-rw---- 1 mysql mysql 1.0K Apr 8 04:50 plugin.MYI  
-rw-rw---- 1 mysql mysql 9.8K Apr 8 04:50 proc.frm  
-rw-rw---- 1 mysql mysql 518K Apr 8 04:50 proc.MYD  
-rw-rw---- 1 mysql mysql 12K Apr 8 04:50 proc.MYI  
-rw-rw---- 1 mysql mysql 8.7K Apr 8 04:50 procs\_priv.frm  
-rw-rw---- 1 mysql mysql 0 Apr 8 04:50 procs\_priv.MYD  
-rw-rw---- 1 mysql mysql 4.0K Apr 8 04:50 procs\_priv.MYI  
-rw-rw---- 1 mysql mysql 8.6K Apr 8 04:50 proxies\_priv.frm  
-rw-rw---- 1 mysql mysql 693 Apr 8 04:50 proxies\_priv.MYD  
-rw-rw---- 1 mysql mysql 5.0K Apr 8 04:50 proxies\_priv.MYI  
-rw-rw---- 1 mysql mysql 8.7K Apr 8 04:50 servers.frm  
-rw-rw---- 1 mysql mysql 0 Apr 8 04:50 servers.MYD  
-rw-rw---- 1 mysql mysql 1.0K Apr 8 04:50 servers.MYI  
-rw-rw---- 1 mysql mysql 35 Jul 13 01:42 slow\_log.CSM  
-rw-rw---- 1 mysql mysql 0 Sep 30 2014 slow\_log.CSV  
-rw-rw---- 1 mysql mysql 8.9K Sep 30 2014 slow\_log.frm  
-rw-rw---- 1 mysql mysql 8.8K Apr 8 04:50 tables\_priv.frm  
-rw-rw---- 1 mysql mysql 21K Apr 8 04:50 tables\_priv.MYD  
-rw-rw---- 1 mysql mysql 8.0K Apr 8 04:50 tables\_priv.MYI  
-rw-rw---- 1 mysql mysql 8.5K Apr 8 04:50 time\_zone.frm  
-rw-rw---- 1 mysql mysql 8.5K Apr 8 04:50 time\_zone\_leap\_second.frm  
-rw-rw---- 1 mysql mysql 0 Apr 8 04:50 time\_zone\_leap\_second.MYD  
-rw-rw---- 1 mysql mysql 1.0K Apr 8 04:50 time\_zone\_leap\_second.MYI  
-rw-rw---- 1 mysql mysql 0 Apr 8 04:50 time\_zone.MYD  
-rw-rw---- 1 mysql mysql 1.0K Apr 8 04:50 time\_zone.MYI  
-rw-rw---- 1 mysql mysql 8.5K Apr 8 04:50 time\_zone\_name.frm  
-rw-rw---- 1 mysql mysql 0 Apr 8 04:50 time\_zone\_name.MYD  
-rw-rw---- 1 mysql mysql 1.0K Apr 8 04:50 time\_zone\_name.MYI  
-rw-rw---- 1 mysql mysql 8.5K Apr 8 04:50 time\_zone\_transition.frm  
-rw-rw---- 1 mysql mysql 0 Apr 8 04:50 time\_zone\_transition.MYD  
-rw-rw---- 1 mysql mysql 1.0K Apr 8 04:50 time\_zone\_transition.MYI  
-rw-rw---- 1 mysql mysql 8.6K Apr 8 04:50 time\_zone\_transition\_type.frm  
-rw-rw---- 1 mysql mysql 0 Apr 8 04:50 time\_zone\_transition\_type.MYD  
-rw-rw---- 1 mysql mysql 1.0K Apr 8 04:50 time\_zone\_transition\_type.MYI  
-rw-rw---- 1 mysql mysql 11K Apr 8 04:50 user.frm  
-rw-rw---- 1 mysql mysql 5.9K Jul 2 12:14 user.MYD  
-rw-rw---- 1 mysql mysql 4.0K Jul 2 20:45 user.MYI

---

<div class="post-metadata">

**Author:** ![dchambers](https://avatars.discourse-cdn.com/v4/letter/d/d2c977/32.png) [@dchambers](https://forums.percona.com/u/dchambers)\
**Post date:** [July 14, 2015, 10:59am UTC](https://forums.percona.com/t/xtrabackup-replication-table-mysql-slave-master-info-cannot-be-opened/4303/4 "2015-07-14T10:59:43Z")

</div>

Even those all this throws errors… This fixed it!

drop table slave\_master\_info;  
ALTER TABLE slave\_master\_info DISCARD TABLESPACE;

drop table slave\_relay\_log\_info;  
ALTER TABLE slave\_relay\_log\_info DISCARD TABLESPACE;

drop table slave\_worker\_info;  
ALTER TABLE slave\_worker\_info DISCARD TABLESPACE;

rm slave\_master\_info  
rm slave\_relay\_log\_info  
rm slave\_worker\_info

mysql mysql \< /root/pulsant/broken-tables.sql

The import is just a dump from a working DB of the above tables… 6 hours boom!
