# Xtrabackup --prepare fails: xtrabackup\_info file missing in streaming backup directory

**URL:** <https://forums.percona.com/t/xtrabackup-prepare-fails-xtrabackup-info-file-missing-in-streaming-backup-directory/40790>\
**Category:** Percona XtraBackup\
**Created:** [May 12, 2026, 8:25pm UTC](https://forums.percona.com/t/xtrabackup-prepare-fails-xtrabackup-info-file-missing-in-streaming-backup-directory/40790 "2026-05-12T20:25:45Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Justin\_Swanhart](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/justin_swanhart/32/20643_2.png) [@Justin\_Swanhart](https://forums.percona.com/u/Justin_Swanhart)\
**Post date:** [May 12, 2026, 8:25pm UTC](https://forums.percona.com/t/xtrabackup-prepare-fails-xtrabackup-info-file-missing-in-streaming-backup-directory/40790/1 "2026-05-12T20:25:45Z")

</div>

I’ve tested this twice now. i am using xtrabackup to stream a backup over netcat to another host:  
$ xtrabackup --backup --stream=xbstream | pigz | nc REDACTED 9999  
and  
$ nc -l -p 9999 | gzip -d | xbstream -x -C /var/lib/mysql

At the end of the backup, 'COMPLETED OK" is printed. However, there is no xtrabackup\_info file produced by the xbstream process. The prepare fails to find the file and exits accordingly.

Any idea why the file isn’t being created?

---

<div class="post-metadata">

**Author:** ![hai.nguyen](https://avatars.discourse-cdn.com/v4/letter/h/41988e/32.png) [@hai.nguyen](https://forums.percona.com/u/hai.nguyen)\
**Post date:** [May 13, 2026, 5:12am UTC](https://forums.percona.com/t/xtrabackup-prepare-fails-xtrabackup-info-file-missing-in-streaming-backup-directory/40790/2 "2026-05-13T05:12:12Z")

</div>

Hi @Justin_Swanhart

I just tried the same commands, and didn’t encounter the issue (using xtrabackup 8.0.35-35).

What version of xtrabackup are you using?

Try again with the verbose option for xbstream and see if the output shows the xtrabackup\_info file:

```auto
nc -l -p 9999 | gzip -d | xbstream -xv -C /var/lib/mysql

```

Also, does backup locally on the source server have the same issue? or the issue only happens when you stream the backup?
