# Xtrabackup in Percona for MySQL 8.0.34

**URL:** <https://forums.percona.com/t/xtrabackup-in-percona-for-mysql-8-0-34/34030>\
**Category:** Percona XtraBackup\
**Tags:** percona\
**Created:** [September 30, 2024, 9:43am UTC](https://forums.percona.com/t/xtrabackup-in-percona-for-mysql-8-0-34/34030 "2024-09-30T09:43:32Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![virin\_t](https://avatars.discourse-cdn.com/v4/letter/v/b38774/32.png) [@virin\_t](https://forums.percona.com/u/virin_t)\
**Post date:** [September 30, 2024, 9:43am UTC](https://forums.percona.com/t/xtrabackup-in-percona-for-mysql-8-0-34/34030/1 "2024-09-30T09:43:32Z")

</div>

Hi

I am using encryption and below option to take backup and stream to cloud bucket directly

```auto
XTRABACKUP_OPTIONS="--backup --stream=xbstream --read-buffer-size=1G --parallel=4 --compress --compress-threads=4 --slave-info --no-lock --safe-slave-backup --extra-lsndir=${target_dir} --target-dir=${target_dir} ${extra_backup_option}"

```

When I trying to run backup, using below option , it is failing

```auto
 /backup/xtrabackup_gcs/fullbackup.sh "db-server-XX" "--host=127.0.0.1 --encrypt=AES256 --encrypt-key-file=/backup/xtrabackup_gcs/keyfile --encrypt-=2"eads

```

It is failing with below error in log

```auto
2024-09-30T00:01:10.194649-07:00 2 [Note] [MY-011825] [Xtrabackup] Done: Compressing, encrypting and streaming ./percona/stock_log.ibd
encryption: unable to set libgcrypt cipher key - User defined source 1 : Invalid key length

Fatal error: gcry_cipher_close: already closed/invalid handle
2024-09-30T07:01:10Z UTC - mysqld got signal 6 ;
Most likely, you have hit a bug, but this error can also be caused by malfunctioning hardware.
BuildID[sha1]=
Thread pointer: 0x7fb1c80008c0
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
stack_bottom = 7fb1ef7fd8b0 thread_stack 0x100000
2024-09-30T00:01:10.201514-07:00 4 [Note] [MY-011825] [Xtrabackup] Done: Compressing, encrypting and streaming ./recover_data/orXX_XXX_XX.ibd
encryption: unable to set libgcrypt cipher key - User defined source 1 : Invalid key length

Fatal error: gcry_cipher_close: already closed/invalid handle

```

I used below to generate the keyfile, please suggest on further option to overcome

```auto
openssl rand -base64 32 | tr -d '\n' > /backup/xtrabackup_gcs/keyfile

```

---

<div class="post-metadata">

**Author:** ![yunus.uyanik](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/yunus.uyanik/32/19250_2.png) [@yunus.uyanik](https://forums.percona.com/u/yunus.uyanik)\
**Post date:** [September 30, 2024, 10:23am UTC](https://forums.percona.com/t/xtrabackup-in-percona-for-mysql-8-0-34/34030/2 "2024-09-30T10:23:22Z")

</div>

Hi @virin_t,  
It seems you’re hitting a bug that is explained here: [[PXB-3051] - Percona JIRA](https://perconadev.atlassian.net/browse/PXB-3051)  
I could not see any workaround yet, but if you don’t need to `compress` option, you might remove it.

---

<div class="post-metadata">

**Author:** ![virin\_t](https://avatars.discourse-cdn.com/v4/letter/v/b38774/32.png) [@virin\_t](https://forums.percona.com/u/virin_t)\
**Post date:** [September 30, 2024, 10:30am UTC](https://forums.percona.com/t/xtrabackup-in-percona-for-mysql-8-0-34/34030/3 "2024-09-30T10:30:37Z")

</div>

Thank you for thr update @yunus.uyanik

Is there a wrok around for this? or do you suggest any other ways to encrypt the backups while uploading to buckets.

---

<div class="post-metadata">

**Author:** ![virin\_t](https://avatars.discourse-cdn.com/v4/letter/v/b38774/32.png) [@virin\_t](https://forums.percona.com/u/virin_t)\
**Post date:** [September 30, 2024, 10:31am UTC](https://forums.percona.com/t/xtrabackup-in-percona-for-mysql-8-0-34/34030/4 "2024-09-30T10:31:51Z")

</div>

are there any specific versions which are affected?

---

<div class="post-metadata">

**Author:** ![yunus.uyanik](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/yunus.uyanik/32/19250_2.png) [@yunus.uyanik](https://forums.percona.com/u/yunus.uyanik)\
**Post date:** [September 30, 2024, 12:28pm UTC](https://forums.percona.com/t/xtrabackup-in-percona-for-mysql-8-0-34/34030/5 "2024-09-30T12:28:56Z")

</div>

> are there any specific versions which are affected?

Even the latest version has the same issue.

As a workaround, you can use the below to generate a key file; it works for me.

`openssl rand -base64 24 | tr -d '\n' > /backup/xtrabackup_gcs/keyfile2`

See the doc: [Encrypt backups - Percona XtraBackup](https://docs.percona.com/percona-xtrabackup/8.0/encrypt-backups.html?h=openssl#create-encrypted-backups)

---

<div class="post-metadata">

**Author:** ![virin\_t](https://avatars.discourse-cdn.com/v4/letter/v/b38774/32.png) [@virin\_t](https://forums.percona.com/u/virin_t)\
**Post date:** [October 3, 2024, 11:09am UTC](https://forums.percona.com/t/xtrabackup-in-percona-for-mysql-8-0-34/34030/6 "2024-10-03T11:09:40Z")

</div>

You mean , keyfile is being helpful to encrypt backups if generated as above?
