# Xtrabackup failure - xbcloud upload failure

**URL:** <https://forums.percona.com/t/xtrabackup-failure-xbcloud-upload-failure/37675>\
**Category:** Percona XtraBackup\
**Created:** [April 21, 2025, 9:50am UTC](https://forums.percona.com/t/xtrabackup-failure-xbcloud-upload-failure/37675 "2025-04-21T09:50:42Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![bklk](https://avatars.discourse-cdn.com/v4/letter/b/e68b1a/32.png) [@bklk](https://forums.percona.com/u/bklk)\
**Post date:** [April 21, 2025, 9:50am UTC](https://forums.percona.com/t/xtrabackup-failure-xbcloud-upload-failure/37675/1 "2025-04-21T09:50:42Z")

</div>

Hello,  
I’m looking for help with xtrabackup problem.

the xtrabackup command:

```auto
xtrabackup --user=... --password=... --backup --datadir=/data/mysql/data --stream=xbstream --read-buffer-size=500M --extra-lsndir=/tmp --target-dir=/tmp | xbcloud put --storage=s3 --s3-access-key=... --s3-secret-key=... --s3-bucket=s3://... --s3-region=us-east-2 --parallel=4 s3://.../mysql-backup-26310-qa-oltp-percona01-a01-20250415_114601

```

With the following environment:

OS: AlmaLinux release 9.5  
MySQL: Ver 8.0.36-28 for Linux on x86\_64 (Percona Server (GPL)  
xtrabackup: xtrabackup version 8.0.35-32 based on MySQL server 8.0.35  
xbcloud: xbcloud Ver 8.0.35-32

I’m running the xtrabackup, which results in error:

```auto
....
250421 09:24:17 xbcloud: [0] successfully uploaded chunk: mysql-backup-26310-qa-oltp-percona01-a01-20250415_114601/ib_buffer_pool.00000000000000000000, size: 1255605
250421 09:24:18 xbcloud: Upload failed: backup is incomplete.
Backup doesn't contain last file with prefix xtrabackup_tablespaces in the cloud storage
$

```

If executed with verbose mode:

```auto
* Mark bundle as not supporting multiuse
< HTTP/1.1 200 OK
< x-amz-id-2: tN2j4YOoXoMNhUaGv7q++WadqGO938SGDJk2Oi1E5EypPx+0wno0ZH0MUaL6/9vmnrrhOw5LJHwe0OLyULduz0ojKRsH+kPG6bpNkXUeNmg=
< x-amz-request-id: .....
< Date: Mon, 21 Apr 2025 09:32:24 GMT
< x-amz-bucket-region: us-east-2
< Content-Type: application/xml
< Transfer-Encoding: chunked
< Server: AmazonS3
<
* Connection #1 to host .....us-east-2.amazonaws.com left intact
250421 09:32:23 xbcloud: Upload failed: backup is incomplete.
Backup doesn't contain last file with prefix xtrabackup_tablespaces in the cloud storage
$

```

Does anybody know what could be the problem? Or give some advise on troubleshooting?

Regards

lk

---

<div class="post-metadata">

**Author:** ![Yunus](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/yunus/32/6430_2.png) [@Yunus](https://forums.percona.com/u/Yunus)\
**Post date:** [April 22, 2025, 1:51am UTC](https://forums.percona.com/t/xtrabackup-failure-xbcloud-upload-failure/37675/2 "2025-04-22T01:51:38Z")

</div>

> [@bklk](#):
>
> `Backup doesn't contain last file with prefix xtrabackup_tablespaces`

Could you try taking a backup separately and see if that completes, and upload it separately?

---

<div class="post-metadata">

**Author:** ![bklk](https://avatars.discourse-cdn.com/v4/letter/b/e68b1a/32.png) [@bklk](https://forums.percona.com/u/bklk)\
**Post date:** [April 22, 2025, 5:02am UTC](https://forums.percona.com/t/xtrabackup-failure-xbcloud-upload-failure/37675/3 "2025-04-22T05:02:43Z")

</div>

Hello Yunus,

Yes, the execution of backup completes fine:

```auto
2025-04-22T04:41:38.224731-00:00 0 [Note] [MY-011825] [Xtrabackup] Transaction log of lsn (192742418103) to (192801743311) was copied.
2025-04-22T04:41:38.432894-00:00 0 [Note] [MY-011825] [Xtrabackup] completed OK!

```

---

<div class="post-metadata">

**Author:** ![bklk](https://avatars.discourse-cdn.com/v4/letter/b/e68b1a/32.png) [@bklk](https://forums.percona.com/u/bklk)\
**Post date:** [April 22, 2025, 5:20am UTC](https://forums.percona.com/t/xtrabackup-failure-xbcloud-upload-failure/37675/4 "2025-04-22T05:20:14Z")

</div>

Thank you again Yanus.  
After running the backup, it appeared also that there is not enough disk space at /tmp.  
With more disk space, the original xtrabackup with xbcloud started to work.

---

<div class="post-metadata">

**Author:** ![Yunus](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/yunus/32/6430_2.png) [@Yunus](https://forums.percona.com/u/Yunus)\
**Post date:** [April 22, 2025, 5:49am UTC](https://forums.percona.com/t/xtrabackup-failure-xbcloud-upload-failure/37675/5 "2025-04-22T05:49:45Z")

</div>

That’s good to hear that the issue was identified.

---

<div class="post-metadata">

**Author:** ![matthewb](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/matthewb/32/34_2.png) [@matthewb](https://forums.percona.com/u/matthewb)\
**Post date:** [April 22, 2025, 4:06pm UTC](https://forums.percona.com/t/xtrabackup-failure-xbcloud-upload-failure/37675/6 "2025-04-22T16:06:19Z")

</div>

Just want to add that you might want to consider adding `--compress` to your xtrabackup. This compresses the files with zstd before streaming to cloud/writing to tmp.
