# xtrabackup child process has died at /usr/bin/innobackupex line 2622.

**URL:** https://forums.percona.com/t/xtrabackup-child-process-has-died-at-usr-bin-innobackupex-line-2622/3404
**Category:** Percona XtraBackup
**Created:** [April 15, 2014, 7:01am UTC](https://forums.percona.com/t/xtrabackup-child-process-has-died-at-usr-bin-innobackupex-line-2622/3404 "2014-04-15T07:01:51Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![crepetl](https://avatars.discourse-cdn.com/v4/letter/c/b4bc9f/32.png) [@crepetl](https://forums.percona.com/u/crepetl)
#### Post date: [April 15, 2014, 7:01am UTC](https://forums.percona.com/t/xtrabackup-child-process-has-died-at-usr-bin-innobackupex-line-2622/3404/1 "2014-04-15T07:01:51Z")

</div>

Hi,

I’m using XtraBackup 2.1.8 installed using Percona RPMs on RHEL 6.5 x86\_64 to stream a backup to another server through ssh using tar method. Previous backups run with the same script were successfull, but the last backup crashed with the following error:

innobackupex: Error: The xtrabackup child process has died at /usr/bin/innobackupex line 2622.

Line 2622 of /usr/bin/innobackupex is:  
die “The xtrabackup child process has died”;

How can I get the logs from xtrabackup ? Is there a way to determine why the backup failed ?

Regards,  
Laurent.

---

<div class="post-metadata">

### Author: ![niljoshi](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/niljoshi/32/16889_2.png) [@niljoshi](https://forums.percona.com/u/niljoshi)
#### Post date: [April 22, 2014, 12:58am UTC](https://forums.percona.com/t/xtrabackup-child-process-has-died-at-usr-bin-innobackupex-line-2622/3404/2 "2014-04-22T00:58:02Z")

</div>

Hi,

Without log its really difficult to find out the root cause. If you are taking backup through script, why don’t you collect the log in separate file for each backup. You can remove it if backup is successful otherwise it can be helpful to find out the cause of backup failure.

---

<div class="post-metadata">

### Author: ![bhblack](https://avatars.discourse-cdn.com/v4/letter/b/c77e96/32.png) [@bhblack](https://forums.percona.com/u/bhblack)
#### Post date: [April 28, 2014, 4:07pm UTC](https://forums.percona.com/t/xtrabackup-child-process-has-died-at-usr-bin-innobackupex-line-2622/3404/3 "2014-04-28T16:07:31Z")

</div>

I have the same issue. here’s the log entry:

xtrabackup: error: log block numbers mismatch:  
xtrabackup: error: expected log block no. 940838868, but got no. 949227472 from the log file.  
xtrabackup: Error: xtrabackup\_copy\_logfile() failed.  
innobackupex: Error: The xtrabackup child process has died at /home/mysql/xtrabackup/bin/innobackupex line 2622.

The system is under load while the backup is taken

---

<div class="post-metadata">

### Author: ![bhblack](https://avatars.discourse-cdn.com/v4/letter/b/c77e96/32.png) [@bhblack](https://forums.percona.com/u/bhblack)
#### Post date: [April 28, 2014, 4:09pm UTC](https://forums.percona.com/t/xtrabackup-child-process-has-died-at-usr-bin-innobackupex-line-2622/3404/4 "2014-04-28T16:09:20Z")

</div>

Mysql version 5.6.17. xtrabackup version is 2.1.8

---

<div class="post-metadata">

### Author: ![niljoshi](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/niljoshi/32/16889_2.png) [@niljoshi](https://forums.percona.com/u/niljoshi)
#### Post date: [May 6, 2014, 4:18am UTC](https://forums.percona.com/t/xtrabackup-child-process-has-died-at-usr-bin-innobackupex-line-2622/3404/5 "2014-05-06T04:18:05Z")

</div>

Hi bhblack,

There were some bugs related to this issue. “xtrabackup: error: log block numbers mismatch” i.e  
[url][https://bugs.launchpad.net/percona-xtrabackup/+bug/917823[/url]](https://bugs.launchpad.net/percona-xtrabackup/+bug/917823%5B/url%5D)  
[url][https://bugs.launchpad.net/percona-xtrabackup/+bug/1206309[/url]](https://bugs.launchpad.net/percona-xtrabackup/+bug/1206309%5B/url%5D)

This is generally happening with heavy load on the server means log copying being too slow, or log files being too small. Can you try to increase log file size and check?  
Have you tried to use latest version of Xtrabackup (2.2) ?  
If you still facing the same issue then you should rather re-open that bug with all required details.
