# Xtrabackup 8.0 is not working with MySQL 8.0.23?

**URL:** <https://forums.percona.com/t/xtrabackup-8-0-is-not-working-with-mysql-8-0-23/9286>\
**Category:** Percona XtraBackup\
**Tags:** percona\
**Created:** [February 16, 2021, 6:49am UTC](https://forums.percona.com/t/xtrabackup-8-0-is-not-working-with-mysql-8-0-23/9286 "2021-02-16T06:49:40Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![lokesh123](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/lokesh123/32/5519_2.png) [@lokesh123](https://forums.percona.com/u/lokesh123)\
**Post date:** [February 16, 2021, 6:49am UTC](https://forums.percona.com/t/xtrabackup-8-0-is-not-working-with-mysql-8-0-23/9286/1 "2021-02-16T06:49:40Z")

</div>

Can you suggest Xtrabackup(8.0.) having issue with MySQL (8.0.23) with Backup prepare?

---

<div class="post-metadata">

**Author:** ![lokesh123](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/lokesh123/32/5519_2.png) [@lokesh123](https://forums.percona.com/u/lokesh123)\
**Post date:** [February 16, 2021, 6:57am UTC](https://forums.percona.com/t/xtrabackup-8-0-is-not-working-with-mysql-8-0-23/9286/2 "2021-02-16T06:57:53Z")

</div>

**Logs:**

```auto
xtrabackup: [Warning] World-writable config file '/mysql_backup/xtrabackup/Daily/FULL/backup-my.cnf' is ignored.

xtrabackup: [Warning] World-writable config file '/mysql_backup/xtrabackup/Daily/FULL/backup-my.cnf' is ignored.

xtrabackup: recognized client arguments: --user=monitor --password=* --prepare=1 --apply-log-only=1 --target-dir=/mysql_backup/xtrabackup/Daily/FULL

xtrabackup version 8.0.22-15 based on MySQL server 8.0.22 Linux (x86_64) (revision id: fea8a0e)

xtrabackup: cd to /mysql_backup/xtrabackup/Daily/FULL/

xtrabackup: This target seems to be not prepared yet.

Number of pools: 1

xtrabackup: xtrabackup_logfile detected: size=8388608, start_lsn=(6691162815)

xtrabackup: using the following InnoDB configuration for recovery:

xtrabackup: innodb_data_home_dir = .

xtrabackup: innodb_data_file_path = ibdata1:10M:autoextend

xtrabackup: innodb_log_group_home_dir = .

xtrabackup: innodb_log_files_in_group = 1

xtrabackup: innodb_log_file_size = 8388608

xtrabackup: [Warning] World-writable config file './backup-my.cnf' is ignored.

xtrabackup: using the following InnoDB configuration for recovery:

xtrabackup: innodb_data_home_dir = .

xtrabackup: innodb_data_file_path = ibdata1:10M:autoextend

xtrabackup: innodb_log_group_home_dir = .

xtrabackup: innodb_log_files_in_group = 1

xtrabackup: innodb_log_file_size = 8388608

xtrabackup: Starting InnoDB instance for recovery.

xtrabackup: Using 104857600 bytes for buffer pool (set by --use-memory parameter) PUNCH HOLE support available Mutexes and rw_locks use GCC atomic builtins Uses event mutexes GCC builtin __atomic_thread_fence() is used for memory barrier Compressed tables use zlib 1.2.11 Number of pools: 1 Using CPU crc32 instructions Directories to scan './'

```

Scanning ‘./’

Completed space ID check of 369 files.

Initializing buffer pool, total size = 128.000000M, instances = 1, chunk size =128.000000M Completed initialization of buffer pool page\_cleaner coordinator priority: -20 page\_cleaner worker priority: -20 page\_cleaner worker priority: -20 page\_cleaner worker priority: -20 The log sequence number 5516409101 in the system tablespace does not match the log sequence number 6691162815 in the ib\_logfiles!

Database was not shutdown normally!

Starting crash recovery.

Starting to parse redo log at lsn = 6691162692, whereas checkpoint\_lsn = 6691162815 Doing recovery: scanned up to log sequence number 6691163715 Log background threads are being started…

Applying a batch of 7 redo log records …

100%

Apply batch completed!

Using undo tablespace ‘./undo\_001’.

Using undo tablespace ‘./undo\_002’.

Opened 2 existing undo tablespaces.

GTID recovery trx\_no: 914983

Creating shared tablespace for temporary tables Setting file ‘./ibtmp1’ size to 12 MB. Physically writing the file full; Please wait …

File ‘./ibtmp1’ size is now 12 MB.

Scanning temp tablespace dir:‘./#innodb\_temp/’

Created 128 and tracked 128 new rollback segment(s) in the temporary tablespace. 128 are now active.

8.0.22 started; log sequence number 6691163715 Allocated tablespace ID 75 for client\_db/transaction\_type, old maximum was 0 Cannot read first page of ‘./mysql.ibd’ I/O error Cannot read first page in datafile: ./mysql.ibd, Space ID:4294967295, Flags: 0. Please refer to [MySQL :: MySQL 8.0 Reference Manual :: 15.21.4 Troubleshooting InnoDB Data Dictionary Operations](http://dev.mysql.com/doc/refman/8.0/en/innodb-troubleshooting-datadict.html) for how to resolve the issue.

Cannot read first page of ‘./payee\_db/crm\_api\_running\_status.ibd’ I/O error Cannot read first page in datafile: ./payee\_db/crm\_api\_running\_status.ibd, Space ID:4294967295, Flags: 0. Please refer to [MySQL :: MySQL 8.0 Reference Manual :: 15.21.4 Troubleshooting InnoDB Data Dictionary Operations](http://dev.mysql.com/doc/refman/8.0/en/innodb-troubleshooting-datadict.html) for how to resolve the issue.

```auto
xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

xtrabackup: Unknown error 3611

```

```auto
06:53:42 UTC - mysqld got signal 11 ;

```

Most likely, you have hit a bug, but this error can also be caused by malfunctioning hardware.

Thread pointer: 0x0

Attempting backtrace. You can use the following information to find out where mysqld died. If you see no messages after this, something went terribly wrong…

```auto
stack_bottom = 0 thread_stack 0x46000

xtrabackup(my_print_stacktrace(unsigned char const*, unsigned long)+0x3d) [0x55ea3d7f7cfd]

xtrabackup(handle_fatal_signal+0x2fb) [0x55ea3c62c7db]

/lib/x86_64-linux-gnu/libpthread.so.0(+0x12980) [0x7f47db46b980]

xtrabackup(dd::get_dd_client(THD*)+0x1) [0x55ea3cb74e01] xtrabackup(dd_table_open_on_name(THD*, MDL_ticket**, char const*, bool, unsigned long, int*)+0x5ae) [0x55ea3c7fa40e]

xtrabackup(+0xdc6f33) [0x55ea3c0f2f33]

xtrabackup(+0xdcad70) [0x55ea3c0f6d70]

xtrabackup(main+0xd37) [0x55ea3c0b68b7]

/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xe7) [0x7f47d96c8bf7]

xtrabackup(_start+0x2a) [0x55ea3c0e4caa]

```

Please report a bug at [https://jira.percona.com/projects/PXB](https://jira.percona.com/projects/PXB)

---

<div class="post-metadata">

**Author:** ![George\_Lorch](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/george_lorch/32/1108_2.png) [@George\_Lorch](https://forums.percona.com/u/George_Lorch)\
**Post date:** [February 16, 2021, 7:07am UTC](https://forums.percona.com/t/xtrabackup-8-0-is-not-working-with-mysql-8-0-23/9286/3 "2021-02-16T07:07:24Z")

</div>

> **[Aligning Percona XtraBackup Versions with Percona Server for MySQL - Percona...](https://www.percona.com/blog/2020/08/18/aligning-percona-xtrabackup-versions-with-percona-server-for-mysql/)**
>
> We are excited to let you know about two upcoming changes to Percona XtraBackup which will align Percona XtraBackup Versions with Percona Server for MySQL. 

TL;DR if you are relying on Percona XtraBackup, you should not upgrade your server version until you have first upgraded Percona XtraBackup, which typically will lag Oracle MySQL 8.x releases by 4-6 weeks.

– George O. Lorch III  
Director of Server Engineering, Percona Server for MySQL, Percona XtraDB Cluster, and Percona XtraBackup

---

<div class="post-metadata">

**Author:** ![Gonzalo\_Pereira](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/gonzalo_pereira/32/3085_2.png) [@Gonzalo\_Pereira](https://forums.percona.com/u/Gonzalo_Pereira)\
**Post date:** [March 8, 2021, 7:16pm UTC](https://forums.percona.com/t/xtrabackup-8-0-is-not-working-with-mysql-8-0-23/9286/4 "2021-03-08T19:16:09Z")

</div>

I have the same scenario, and there is a bug created in jira as well, so i feel that the “don’t upgrade before updating Xtra… is out of the discussion:[[PXB-2406] PXB crashes during backup prepare with MS8.0.23 - Percona JIRA](https://jira.percona.com/browse/PXB-2406)”

Did you fixed this?

---

<div class="post-metadata">

**Author:** ![George\_Lorch](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/george_lorch/32/1108_2.png) [@George\_Lorch](https://forums.percona.com/u/George_Lorch)\
**Post date:** [March 8, 2021, 7:53pm UTC](https://forums.percona.com/t/xtrabackup-8-0-is-not-working-with-mysql-8-0-23/9286/5 "2021-03-08T19:53:18Z")

</div>

Unfortunately, there is nothing we can do when Oracle makes changes to MySQL 8.x series that breaks Percona XtraBackup. We have no warning nor preview of what they do until the day they release. As a result, our guidance is that if you rely on Percona XtraBackup 8.x, you should not upgrade to a newer version or Percona Server/Oracle MySQL 8.x until the equivalent version of Percona XtraBackup 8.x has been released. We begin our testing and merging of Oracle MySQL to Percona XtraBackup on the day that Oracle releases and publishes their changes to github.

–  
George O. Lorch III  
Director of Server Engineering, Percona Server for MySQL, Percona XtraDB Cluster, and Percona XtraBackup

---

<div class="post-metadata">

**Author:** ![tpgpfkwkem](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/tpgpfkwkem/32/3260_2.png) [@tpgpfkwkem](https://forums.percona.com/u/tpgpfkwkem)\
**Post date:** [April 5, 2021, 6:44am UTC](https://forums.percona.com/t/xtrabackup-8-0-is-not-working-with-mysql-8-0-23/9286/6 "2021-04-05T06:44:03Z")

</div>

Hello. George,  
I confirmed that percona-xtrabackup-8.0.23-16 came out.  
Is that version compatible with mysql 8.0.23?  
Where can I check xtrabackup and mysql version compatibility?

---

<div class="post-metadata">

**Author:** ![George\_Lorch](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/george_lorch/32/1108_2.png) [@George\_Lorch](https://forums.percona.com/u/George_Lorch)\
**Post date:** [April 5, 2021, 12:42pm UTC](https://forums.percona.com/t/xtrabackup-8-0-is-not-working-with-mysql-8-0-23/9286/7 "2021-04-05T12:42:38Z")

</div>

The fact that the XtraBackup base version (8.0.23) is the same as the MySQL version is enough to indicate that we have merged MySQL down in to XtraBackup and confirmed compatibility.  
–  
George O. Lorch III  
Director of Server Engineering, Percona Server for MySQL, Percona XtraDB Cluster, and Percona XtraBackup

---

<div class="post-metadata">

**Author:** ![Alok\_Singh](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/alok_singh/32/3320_2.png) [@Alok\_Singh](https://forums.percona.com/u/Alok_Singh)\
**Post date:** [April 13, 2021, 1:07pm UTC](https://forums.percona.com/t/xtrabackup-8-0-is-not-working-with-mysql-8-0-23/9286/8 "2021-04-13T13:07:00Z")

</div>

@George_Lorch  
using : percona-xtrabackup-8.0.23-16 and mysql 8.0.23 .

I’m getting some error while running prepare command . Not working with prepare for incremental backup. Kindly Suggest.

Log as Below…  
xtrabackup: [Warning] World-writable config file ‘/mysql\_backup/xtrabackup/Daily/FULL/backup-my.cnf’ is ignored.  
xtrabackup: [Warning] World-writable config file ‘/mysql\_backup/xtrabackup/Daily/FULL/backup-my.cnf’ is ignored.  
xtrabackup: recognized client arguments: --prepare=1 --user=monitor --password=\* --apply-log-only=1 --target-dir=/mysql\_backup/xtrabackup/Daily/FULL  
xtrabackup version 8.0.23-16 based on MySQL server 8.0.23 Linux (x86\_64) (revision id: 934bc8f)  
xtrabackup: cd to /mysql\_backup/xtrabackup/Daily/FULL/  
xtrabackup: This target seems to be not prepared yet.  
Number of pools: 1  
xtrabackup: xtrabackup\_logfile detected: size=8388608, start\_lsn=(12126781940)  
xtrabackup: using the following InnoDB configuration for recovery:  
xtrabackup: innodb\_data\_home\_dir = .  
xtrabackup: innodb\_data\_file\_path = ibdata1:10M:autoextend  
xtrabackup: innodb\_log\_group\_home\_dir = .  
xtrabackup: innodb\_log\_files\_in\_group = 1  
xtrabackup: innodb\_log\_file\_size = 8388608  
xtrabackup: [Warning] World-writable config file ‘./backup-my.cnf’ is ignored.  
xtrabackup: using the following InnoDB configuration for recovery:  
xtrabackup: innodb\_data\_home\_dir = .  
xtrabackup: innodb\_data\_file\_path = ibdata1:10M:autoextend  
xtrabackup: innodb\_log\_group\_home\_dir = .  
xtrabackup: innodb\_log\_files\_in\_group = 1  
xtrabackup: innodb\_log\_file\_size = 8388608  
xtrabackup: Starting InnoDB instance for recovery.  
xtrabackup: Using 104857600 bytes for buffer pool (set by --use-memory parameter)  
PUNCH HOLE support available  
Uses event mutexes  
GCC builtin \_\_atomic\_thread\_fence() is used for memory barrier  
Compressed tables use zlib 1.2.11  
Number of pools: 1  
Using CPU crc32 instructions  
Directories to scan ‘./’  
Scanning ‘./’  
Completed space ID check of 408 files.  
Initializing buffer pool, total size = 128.000000M, instances = 1, chunk size =128.000000M  
Completed initialization of buffer pool  
page\_cleaner coordinator priority: -20  
page\_cleaner worker priority: -20  
page\_cleaner worker priority: -20  
page\_cleaner worker priority: -20  
The log sequence number 5516409101 in the system tablespace does not match the log sequence number 12126781940 in the ib\_logfiles!  
Database was not shutdown normally!  
Starting crash recovery.  
Starting to parse redo log at lsn = 12126781536, whereas checkpoint\_lsn = 12126781940 and start\_lsn = 12126781440  
Doing recovery: scanned up to log sequence number 12126795963  
Log background threads are being started…  
Applying a batch of 68 redo log records …  
100%  
Apply batch completed!  
Using undo tablespace ‘./undo\_001’.  
Using undo tablespace ‘./undo\_002’.  
Opened 2 existing undo tablespaces.  
GTID recovery trx\_no: 4046721  
Creating shared tablespace for temporary tables  
Setting file ‘./ibtmp1’ size to 12 MB. Physically writing the file full; Please wait …  
File ‘./ibtmp1’ size is now 12 MB.  
Scanning temp tablespace dir:‘./#innodb\_temp/’  
Created 128 and tracked 128 new rollback segment(s) in the temporary tablespace. 128 are now active.  
8.0.23 started; log sequence number 12126795963  
Allocated tablespace ID 440 for auditlog\_db/audit\_2021\_apr, old maximum was 0  
Cannot read first page of ‘./transactiondb/returnfilestatushistory.ibd’ I/O error  
Cannot read first page in datafile: ./transactiondb/returnfilestatushistory.ibd, Space ID:4294967295, Flags: 0. Please refer to mysql\_site\_link for how to resolve the issue.  
Cannot read first page of ‘./transactiondb/returnfiles.ibd’ I/O error  
Cannot read first page in datafile: ./transactiondb/returnfiles.ibd, Space ID:4294967295, Flags: 0. Please refer to mysql\_site\_link for how to resolve the issue.  
Cannot read first page of ‘./mysql.ibd’ I/O error  
Cannot read first page in datafile: ./mysql.ibd, Space ID:4294967295, Flags: 0. Please refer to mysql\_site\_link for how to resolve the issue.  
Cannot read first page of ‘./user\_db/user\_password\_history.ibd’ I/O error  
Cannot read first page in datafile: ./user\_db/user\_password\_history.ibd, Space ID:4294967295, Flags: 0. Please refer to mysql\_site\_link for how to resolve the issue.  
Cannot read first page of ‘./user\_db/users.ibd’ I/O error  
Cannot read first page in datafile: ./user\_db/users.ibd, Space ID:4294967295, Flags: 0. Please refer to mysql\_site\_link for how to resolve the issue.  
Cannot read first page of ‘./payee\_db/crm\_api\_running\_status.ibd’ I/O error  
Cannot read first page in datafile: ./payee\_db/crm\_api\_running\_status.ibd, Space ID:4294967295, Flags: 0. Please refer to mysql\_site\_link for how to resolve the issue.  
Cannot read first page of ‘./notification\_db/email\_notification\_log.ibd’ I/O error  
Cannot read first page in datafile: ./notification\_db/email\_notification\_log.ibd, Space ID:4294967295, Flags: 0. Please refer to mysql\_site\_link for how to resolve the issue.  
Cannot read first page of ‘./notification\_db/send\_grid\_responses.ibd’ I/O error  
Cannot read first page in datafile: ./notification\_db/send\_grid\_responses.ibd, Space ID:4294967295, Flags: 0. Please refer to mysql\_site\_link for how to resolve the issue.  
xtrabackup: starting shutdown with innodb\_fast\_shutdown = 1  
FTS optimize thread exiting.  
Starting shutdown…  
Log background threads are being closed…  
Shutdown completed; log sequence number 12126795963  
Number of pools: 1  
210413 08:51:46 completed OK!
