# xtrabackup 8.0.5 mysql 8.0.15 prepare failes with xtrabackup: Unknown error 3611

**URL:** <https://forums.percona.com/t/xtrabackup-8-0-5-mysql-8-0-15-prepare-failes-with-xtrabackup-unknown-error-3611/6888>\
**Category:** Percona XtraBackup\
**Created:** [March 5, 2019, 9:51am UTC](https://forums.percona.com/t/xtrabackup-8-0-5-mysql-8-0-15-prepare-failes-with-xtrabackup-unknown-error-3611/6888 "2019-03-05T09:51:33Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![jonssonjn](https://avatars.discourse-cdn.com/v4/letter/j/7ab992/32.png) [@jonssonjn](https://forums.percona.com/u/jonssonjn)\
**Post date:** [March 5, 2019, 9:51am UTC](https://forums.percona.com/t/xtrabackup-8-0-5-mysql-8-0-15-prepare-failes-with-xtrabackup-unknown-error-3611/6888/1 "2019-03-05T09:51:33Z")

</div>

[mysql@mysqlrouter MYSQL8]$ xtrabackup --prepare --target-dir=/opt/mysql/mysqldata/mysqlbackup/MYSQL8/2019-03-05-15-59-full  
xtrabackup: recognized server arguments: --innodb\_checksum\_algorithm=innodb --innodb\_log\_checksums=1 --innodb\_data\_file\_path=ibdata1:12M:autoextend --innodb\_log\_files\_in\_group=2 --innodb\_log\_file\_size=104857600 --innodb\_page\_size=16384 --innodb\_undo\_directory=./ --innodb\_undo\_tablespaces=2 --server-id=6 --innodb\_log\_checksums=ON --innodb\_redo\_log\_encrypt=0 --innodb\_undo\_log\_encrypt=0  
xtrabackup: recognized client arguments: --prepare=1 --target-dir=/opt/mysql/mysqldata/mysqlbackup/MYSQL8/2019-03-05-15-59-full  
xtrabackup version 8.0.1 based on MySQL server 8.0.12 Linux (x86\_64) (revision id: )  
xtrabackup: cd to /opt/mysql/mysqldata/mysqlbackup/MYSQL8/2019-03-05-15-59-full/  
xtrabackup: This target seems to be not prepared yet.  
InnoDB: Number of pools: 1  
xtrabackup: xtrabackup\_logfile detected: size=8388608, start\_lsn=(99712145519)  
xtrabackup: using the following InnoDB configuration for recovery:  
xtrabackup: innodb\_data\_home\_dir = .  
xtrabackup: innodb\_data\_file\_path = ibdata1:12M:autoextend  
xtrabackup: innodb\_log\_group\_home\_dir = .  
xtrabackup: innodb\_log\_files\_in\_group = 1  
xtrabackup: innodb\_log\_file\_size = 8388608  
xtrabackup: using the following InnoDB configuration for recovery:  
xtrabackup: innodb\_data\_home\_dir = .  
xtrabackup: innodb\_data\_file\_path = ibdata1:12M:autoextend  
xtrabackup: innodb\_log\_group\_home\_dir = .  
xtrabackup: innodb\_log\_files\_in\_group = 1  
xtrabackup: innodb\_log\_file\_size = 8388608  
xtrabackup: Starting InnoDB instance for recovery.  
xtrabackup: Using 104857600 bytes for buffer pool (set by --use-memory parameter)  
InnoDB: PUNCH HOLE support available  
InnoDB: Mutexes and rw\_locks use GCC atomic builtins  
InnoDB: Uses event mutexes  
InnoDB: GCC builtin \_\_atomic\_thread\_fence() is used for memory barrier  
InnoDB: Compressed tables use zlib 1.2.7  
InnoDB: Number of pools: 1  
InnoDB: Using CPU crc32 instructions  
InnoDB: Directories to scan ‘.;.;.’  
InnoDB: Scanning ‘./’  
InnoDB: Completed space ID check of 70 files.  
InnoDB: Initializing buffer pool, total size = 128.000000M, instances = 1, chunk size =128.000000M  
InnoDB: Completed initialization of buffer pool  
InnoDB: If the mysqld execution user is authorized, page cleaner thread priority can be changed. See the man page of setpriority().  
InnoDB: The log sequence number 99712059123 in the system tablespace does not match the log sequence number 99712145519 in the ib\_logfiles!  
InnoDB: Database was not shutdown normally!  
InnoDB: Starting crash recovery.  
InnoDB: Starting to parse redo log at lsn = 99712145466, whereas checkpoint\_lsn = 99712145519  
InnoDB: Doing recovery: scanned up to log sequence number 99712145519  
InnoDB: Log background threads are being started…  
InnoDB: Applying a batch of 0 redo log records …  
InnoDB: Apply batch completed!  
InnoDB: xtrabackup: Last MySQL binlog file position 4714, file name MYSQL8.000014  
InnoDB: Opened 2 existing undo tablespaces.  
InnoDB: Creating shared tablespace for temporary tables  
InnoDB: Setting file ‘./ibtmp1’ size to 12 MB. Physically writing the file full; Please wait …  
InnoDB: File ‘./ibtmp1’ size is now 12 MB.  
InnoDB: Created 128 and tracked 128 new rollback segment(s) in the temporary tablespace. 128 are now active.  
InnoDB: 8.0.12 started; log sequence number 99712145519  
Populating InnoDB table cache.  
InnoDB: Allocated tablespace ID 174 for mcdb/customers, old maximum was 0  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
xtrabackup: Unknown error 3611  
15:12:57 UTC - mysqld got signal 11 ;  
This could be because you hit a bug. It is also possible that this binary  
or one of the libraries it was linked against is corrupt, improperly built,  
or misconfigured. This error can also be caused by malfunctioning hardware.  
Attempting to collect some information that could help diagnose the problem.  
As this is a crash and something is definitely wrong, the information  
collection process might fail.

key\_buffer\_size=0  
read\_buffer\_size=131072  
max\_used\_connections=0  
max\_threads=0  
thread\_count=0  
connection\_count=0  
It is possible that mysqld could use up to  
key\_buffer\_size + (read\_buffer\_size + sort\_buffer\_size)\*max\_threads = 1662 K bytes of memory  
Hope that’s ok; if not, decrease some variables in the equation.

Thread pointer: 0x0  
Attempting backtrace. You can use the following information to find out  
where mysqld died. If you see no messages after this, something went  
terribly wrong…  
stack\_bottom = 0 thread\_stack 0x46000  
xtrabackup(my\_print\_stacktrace(unsigned char\*, unsigned long)+0x2e) [0x1f1c7ce]  
xtrabackup(handle\_fatal\_signal+0x425) [0xfd1e05]  
/lib64/libpthread.so.0(+0xf5d0) [0x7f0a5a2265d0]  
xtrabackup(dd::get\_dd\_client(THD\*)+0x1) [0x141fbb1]  
xtrabackup(dd\_table\_open\_on\_name(THD\*, MDL\_ticket\*\*, char const\*, bool, unsigned long)+0x497) [0x1147187]  
xtrabackup() [0xb86a53]  
xtrabackup(main+0x1920) [0xb494a0]  
/lib64/libc.so.6(\_\_libc\_start\_main+0xf5) [0x7f0a57f07495]  
xtrabackup() [0xb79554]  
The manual page at [url][http://dev.mysql.com/doc/mysql/en/crashing.html[/url]](http://dev.mysql.com/doc/mysql/en/crashing.html%5B/url%5D) contains  
information that should help you find out what is causing the crash.

---

<div class="post-metadata">

**Author:** ![jonssonjn](https://avatars.discourse-cdn.com/v4/letter/j/7ab992/32.png) [@jonssonjn](https://forums.percona.com/u/jonssonjn)\
**Post date:** [March 5, 2019, 10:06am UTC](https://forums.percona.com/t/xtrabackup-8-0-5-mysql-8-0-15-prepare-failes-with-xtrabackup-unknown-error-3611/6888/2 "2019-03-05T10:06:02Z")

</div>

Please igone it took 8.0.1 xtrabackup from other installation in path first.  
8.0.5 is working great

---

<div class="post-metadata">

**Author:** ![hackituria](https://avatars.discourse-cdn.com/v4/letter/h/e95f7d/32.png) [@hackituria](https://forums.percona.com/u/hackituria)\
**Post date:** [May 1, 2019, 4:47am UTC](https://forums.percona.com/t/xtrabackup-8-0-5-mysql-8-0-15-prepare-failes-with-xtrabackup-unknown-error-3611/6888/3 "2019-05-01T04:47:30Z")

</div>

I have the same problem and I am using 8.0.5 version with MYSQL 8.0.16. How can I solve it?
