# xbstream error - xb\_stream\_read\_chunk(): invalid checksum

**URL:** <https://forums.percona.com/t/xbstream-error-xb-stream-read-chunk-invalid-checksum/5683>\
**Category:** Percona XtraBackup\
**Created:** [June 15, 2017, 9:10am UTC](https://forums.percona.com/t/xbstream-error-xb-stream-read-chunk-invalid-checksum/5683 "2017-06-15T09:10:19Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![cksbaird](https://avatars.discourse-cdn.com/v4/letter/c/db5fbb/32.png) [@cksbaird](https://forums.percona.com/u/cksbaird)\
**Post date:** [June 15, 2017, 9:10am UTC](https://forums.percona.com/t/xbstream-error-xb-stream-read-chunk-invalid-checksum/5683/1 "2017-06-15T09:10:19Z")

</div>

Has anyone run into the following and been able to fix it?

xb\_stream\_read\_chunk(): invalid checksum at offset 0x91a7be850: expected 0x3d87b010, read 0x8132513a.

A backup was created with the following command on Centos 6.9  
innobackupex --stream=xbstream ${TEMPDIR} 2\> $OUTPUT | gzip -3c - \> ${DESTFILE}  
(innobackupex version 2.3.8 on this machine)

When trying to restore the backup on LinuxMint 18.1 / Ubuntu 16.04 with the command below, partway through the process it fails with the error noted above.  
gzip -dc ${fullPathToBackupFile} | xbstream -xv -  
(innobackupex versin 2.3.7 on this machine)

I have tried different sources for the backup multiple times, but have always used the same destination for the restore.

---

<div class="post-metadata">

**Author:** ![jacky](https://avatars.discourse-cdn.com/v4/letter/j/ce73a5/32.png) [@jacky](https://forums.percona.com/u/jacky)\
**Post date:** [October 8, 2024, 7:37am UTC](https://forums.percona.com/t/xbstream-error-xb-stream-read-chunk-invalid-checksum/5683/2 "2024-10-08T07:37:53Z")

</div>

Yeah, i ran into this error too. I backup mysql server successfully with xbstream。when i tried to restore it on another machine，the xtrabackup exit with this error:

```auto
xb_stream_read_chunk(): invalid checksum at offset 0x114b2cc99: expected 0x75f78f4b, read 0xcfc69782.

```

this is my situation:  
mysql version 5.7.25  
xtrabackup version is 2.4

mysql ssl-mode is denied.

```auto
 SSL: Not in use

```

I backup mysql with innobackupex without --ssl-mode option specified。  
Could anyone help me to fix it?  
Thank you in advance.

---

<div class="post-metadata">

**Author:** ![jacky](https://avatars.discourse-cdn.com/v4/letter/j/ce73a5/32.png) [@jacky](https://forums.percona.com/u/jacky)\
**Post date:** [October 9, 2024, 6:33am UTC](https://forums.percona.com/t/xbstream-error-xb-stream-read-chunk-invalid-checksum/5683/3 "2024-10-09T06:33:47Z")

</div>

One day later，I retried to download xb backup file and restore it again, there’s no such error appeared， Maybe the last download file is not completed。So when you came across this error，You may try it again first。
