# WSREP\_SST: \[ERROR\]

**URL:** <https://forums.percona.com/t/wsrep-sst-error/2837>\
**Category:** Percona XtraDB Cluster 5.x\
**Created:** [July 23, 2013, 11:59am UTC](https://forums.percona.com/t/wsrep-sst-error/2837 "2013-07-23T11:59:05Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![allanmoraes](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/allanmoraes/32/947_2.png) [@allanmoraes](https://forums.percona.com/u/allanmoraes)\
**Post date:** [July 23, 2013, 11:59am UTC](https://forums.percona.com/t/wsrep-sst-error/2837/1 "2013-07-23T11:59:05Z")

</div>

Hi!

When I start my DB, this errors are generated.  
How can I fix?

[ERROR] Cleanup after exit with status:32 (20130723 14:21:44.199) WSREP\_SST: [ERROR] Killing nc pid 28030 (20130723 14:21:44.237) tar: Este não parece ser um arquivo-tar tar: Exiting with failure status due to previous errors WSREP\_SST: [ERROR] Error while getting data from donor node: exit codes: 137 2 (20130723 14:21:44.241) WSREP\_SST: [INFO] Removing the sst\_in\_progress file (20130723 14:21:44.242) WSREP\_SST: [ERROR] Cleanup after exit with status:32 (20130723 14:21:44.243) 130723 14:21:44 [ERROR] WSREP: Process completed with error: wsrep\_sst\_xtrabackup --role ‘joiner’ --address ‘MYSQL03’ --auth ‘USUARIO:SENHA’ --datadir ‘/var/lib/mysql/’ --defaults-file ‘/etc/my.cnf’ --parent ‘28776’: 32 (Broken pipe) 130723 14:21:44 [ERROR] WSREP: Failed to read uuid:seqno from joiner script. 130723 14:21:44 [ERROR] WSREP: SST failed: 32 (Broken pipe) 130723 14:21:44 [ERROR] Aborting

---

<div class="post-metadata">

**Author:** ![AdriannaXTS](https://avatars.discourse-cdn.com/v4/letter/a/b487fb/32.png) [@AdriannaXTS](https://forums.percona.com/u/AdriannaXTS)\
**Post date:** [July 25, 2013, 8:21am UTC](https://forums.percona.com/t/wsrep-sst-error/2837/2 "2013-07-25T08:21:21Z")

</div>

Hi;

Could you copy and paste your my.cnf file configuration?

When I have this problem , I juste add this line in my conf “wsrep\_sst\_donor= node 1”.

A.

---

<div class="post-metadata">

**Author:** ![przemek](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/przemek/32/3_2.png) [@przemek](https://forums.percona.com/u/przemek)\
**Post date:** [July 29, 2013, 7:22am UTC](https://forums.percona.com/t/wsrep-sst-error/2837/3 "2013-07-29T07:22:52Z")

</div>

Allan,  
Check if xtrabackup is already running on any of the nodes. It could be left orphaned after last failed SST. Also make sure all the important TCP ports are opened between nodes - 4567, 4444, 4568.

---

<div class="post-metadata">

**Author:** ![asdbnmzxc1](https://avatars.discourse-cdn.com/v4/letter/a/97f17d/32.png) [@asdbnmzxc1](https://forums.percona.com/u/asdbnmzxc1)\
**Post date:** [July 31, 2013, 1:44am UTC](https://forums.percona.com/t/wsrep-sst-error/2837/4 "2013-07-31T01:44:02Z")

</div>

Hi!  
I met the same question yet ,and i modify my.cnf ,you could try to use “rsync” sst\_method replace “xtrabackup” and try again. of course you have to make sure your Selinux stat is disabled ,and iptables is shut down! Good Luck!

---

<div class="post-metadata">

**Author:** ![przemek](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/przemek/32/3_2.png) [@przemek](https://forums.percona.com/u/przemek)\
**Post date:** [July 31, 2013, 6:09am UTC](https://forums.percona.com/t/wsrep-sst-error/2837/5 "2013-07-31T06:09:43Z")

</div>

Rsync method is a blocking one, so much less suitable for production use.  
There is no need to “shutdown” iptables - configuring it properly is enough. Also with some effort Selinux can be adjusted. This document can be helpful too:  
[url][http://www.mysqlperformanceblog.com/2012/12/20/percona-xtradb-cluster-selinux-is-not-always-the-culprit/[/url]](http://www.mysqlperformanceblog.com/2012/12/20/percona-xtradb-cluster-selinux-is-not-always-the-culprit/%5B/url%5D)
