# WSREP: cluster conflict due to certification failure for threads:

**URL:** <https://forums.percona.com/t/wsrep-cluster-conflict-due-to-certification-failure-for-threads/5864>\
**Category:** Percona XtraDB Cluster 5.x\
**Created:** [September 14, 2017, 12:06pm UTC](https://forums.percona.com/t/wsrep-cluster-conflict-due-to-certification-failure-for-threads/5864 "2017-09-14T12:06:46Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![paramesh.n](https://avatars.discourse-cdn.com/v4/letter/p/8491ac/32.png) [@paramesh.n](https://forums.percona.com/u/paramesh.n)\
**Post date:** [September 14, 2017, 12:06pm UTC](https://forums.percona.com/t/wsrep-cluster-conflict-due-to-certification-failure-for-threads/5864/1 "2017-09-14T12:06:46Z")

</div>

Hi All,

We are using an online application built on Liferay framework with Ubunt mysql as the database. We use multi-thread calls for the application and it used to work fine with stand alone server(dev) and 2 node cluster for UAT and Prod. We have upgraded the db version to Percona now and we are struggling with multiple issue such as pxc\_strict\_mode set as Enforcing causing deadlocks and mandatory to add primary key in all the tables. We have addressed these two issues, however we are facing the WSREP: cluster conflict due to certification failure for threads. We are going crazy on how to get this resolved.

Kindly request any of the experts to help us in this regard.

Thanks  
Paramesh

---

<div class="post-metadata">

**Author:** ![miguelangelnieto](https://avatars.discourse-cdn.com/v4/letter/m/b9e5f3/32.png) [@miguelangelnieto](https://forums.percona.com/u/miguelangelnieto)\
**Post date:** [September 19, 2017, 2:06am UTC](https://forums.percona.com/t/wsrep-cluster-conflict-due-to-certification-failure-for-threads/5864/2 "2017-09-19T02:06:24Z")

</div>

Hello,

First you need some more info about what those cluster conflicts are and what queries are causing them. You can enable extra log information by following this link:

[url][http://www.fromdual.com/logging-galera-cluster-conflicts[/url]](http://www.fromdual.com/logging-galera-cluster-conflicts%5B/url%5D)

Then you will get an output similar to what you see in InnoDB with deadlocks. There you can see what transactions are in conflict and investigate why. Maybe you are updating the same row on different nodes.
