# Why does innobackupex require access to mysql data dir when backing up a remote host?

**URL:** <https://forums.percona.com/t/why-does-innobackupex-require-access-to-mysql-data-dir-when-backing-up-a-remote-host/3378>\
**Category:** Percona XtraBackup\
**Created:** [April 2, 2014, 9:51am UTC](https://forums.percona.com/t/why-does-innobackupex-require-access-to-mysql-data-dir-when-backing-up-a-remote-host/3378 "2014-04-02T09:51:27Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![Ueland](https://avatars.discourse-cdn.com/v4/letter/u/f08c70/32.png) [@Ueland](https://forums.percona.com/u/Ueland)\
**Post date:** [April 2, 2014, 9:51am UTC](https://forums.percona.com/t/why-does-innobackupex-require-access-to-mysql-data-dir-when-backing-up-a-remote-host/3378/1 "2014-04-02T09:51:27Z")

</div>

Hello,

I am trying to use innobackupex to backup a MySQL server which runs on another server:

“innobackupex --no-timestamp --parallel=4 --user=root --host=_hostname_ --password=“_password_””

This will fail with the following error:

“xtrabackup: Can’t change dir to ‘/var/lib/mysql’ (Errcode: 2)  
xtrabackup: cannot my\_setwd /app/mysql”

Errorcode 2 is of course “no such file or folder”.

The question is, since i can give it a remote host option, should it not be possible to do a complete backup of that remote host?

Can i simply create a empty “/var/lib/mysql”-folder, or is it something i am missing here?

regards,  
Tor
