# Why can't I add the primary node to Pxc5.7.40 compiled by myself，Please help me

**URL:** https://forums.percona.com/t/why-cant-i-add-the-primary-node-to-pxc5-7-40-compiled-by-myself-please-help-me/20483
**Category:** Percona XtraDB Cluster 5.x
**Tags:** mysql, percona
**Created:** [March 9, 2023, 6:34am UTC](https://forums.percona.com/t/why-cant-i-add-the-primary-node-to-pxc5-7-40-compiled-by-myself-please-help-me/20483 "2023-03-09T06:34:23Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![chenhuanhui](https://avatars.discourse-cdn.com/v4/letter/c/13edae/32.png) [@chenhuanhui](https://forums.percona.com/u/chenhuanhui)
#### Post date: [March 9, 2023, 6:34am UTC](https://forums.percona.com/t/why-cant-i-add-the-primary-node-to-pxc5-7-40-compiled-by-myself-please-help-me/20483/1 "2023-03-09T06:34:24Z")

</div>

I have a machine with ARM architecture，I tried to compile it， Now I have two files：Percona-XtraDB-Cluster-5.7.40-rel43-63.1.Linux.aarch64-minimal.tar.gz Percona-XtraDB-Cluster-5.7.40-rel43-63.1.Linux.aarch64.tar.gz， I unzipped “PXC Percona-XtraDB-Cluster-5.7.40-rel43-63.1.Linux.aarch64.tar.gz” to the /usr/local/mysql， Added the configuration file here（/usr/local/mysql/my.cnf），And then run  
/usr/local/mysql/bin/mysqld --defaults-file=/usr/local/mysql/my.cnf --basedir=/usr/local/mysql --datadir=/usr/local/mysql/data --user=mysql --initialize  
/usr/local/mysql/bin/mysqld --defaults-file=/usr/local/mysql/my.cnf --basedir=/usr/local/mysql --datadir=/usr/local/mysql/data --user=mysql

- Run failed  
Please help me

---

<div class="post-metadata">

### Author: ![chenhuanhui](https://avatars.discourse-cdn.com/v4/letter/c/13edae/32.png) [@chenhuanhui](https://forums.percona.com/u/chenhuanhui)
#### Post date: [March 9, 2023, 6:39am UTC](https://forums.percona.com/t/why-cant-i-add-the-primary-node-to-pxc5-7-40-compiled-by-myself-please-help-me/20483/2 "2023-03-09T06:39:43Z")

</div>

my my.cnf  
[client]

socket=/usr/local/mysql/mysql.sock

port = 3306

default-character-set = utf8

[mysqld]

socket=/usr/local/mysql/mysql.sock

basedir = /usr/local/mysql

datadir = /usr/local/mysql/data

port = 3306

server\_id = 10215

pid-file = /usr/local/mysql/mysql.pid

key\_buffer\_size =128M

max\_allowed\_packet = 16M

table\_open\_cache = 512

max\_connections = 200

sort\_buffer\_size = 20M

read\_buffer\_size = 20M

read\_rnd\_buffer\_size = 8M

myisam\_sort\_buffer\_size = 64M

thread\_cache\_size = 8

query\_cache\_size = 32M

character-set-server=utf8

innodb\_buffer\_pool\_size = 256M

innodb\_log\_file\_size = 48M

innodb\_log\_buffer\_size = 8M

innodb\_flush\_log\_at\_trx\_commit = 1

innodb\_file\_per\_table=1

lower\_case\_table\_names=1

innodb\_temp\_data\_file\_path = ibtmp1:12M:autoextend:max:5120M

explicit\_defaults\_for\_timestamp=TRUE

sql\_mode=NO\_ENGINE\_SUBSTITUTION,STRICT\_TRANS\_TABLES,only\_full\_group\_by

skip-name-resolve

log-bin = /usr/local/mysql/binlog/mysql-bin

expire\_logs\_days = 7

#binlog-do-db=plateform\_stable,finance\_stable,location\_log\_stable

#binlog-ignore-db=mysql,information\_schema,test

binlog\_format=ROW

log\_slave\_updates

symbolic-links=0

default\_storage\_engine=InnoDB

innodb\_autoinc\_lock\_mode=2

log-error=/usr/local/mysql/data/mysqld-error.log

###指 定 您 的 群 集 的 逻 辑 名 称 。 它 必 须 对 群 集 中 的 所 有 节 点 都 相 同 。

wsrep\_cluster\_name =MYPXC

wsrep\_provider=/usr/local/mysql/lib/libgalera\_smm.so

###指 定 群 集 中 节 点 的 IP地 址 ， 节 点 加 入 群 集 至 少 需 要 一 个 ， 但 建 议 列 出 所 有 节 点 的 地 址 。

wsrep\_cluster\_address=“gcomm://192.168.1.206:4567”

###用 于 SST传 送 的 端 口

wsrep\_sst\_receive\_address=192.168.1.185

###定 义 节 点 期 望 客 户 端 连 接 的 IP地 址 和 端 口 。

#wsrep\_node\_incoming\_address=192.168.1.185

#wsrep\_provider\_options = “gmcast.listen\_addr=tcp://192.168.1.185;ist.recv\_addr=192.168.1.185;”

###gmcast.listen

###来 自 其 他 节 点 的 地 址 Galera侦 听 连 接 。 可 以 用 来 覆 盖 默 认 端 口 倾 听 ,这 是 获 得 从 连 接 地 址 。

###ist.recv\_addr

###地 址 监 听 增 量 状 态 传 输 。

wsrep\_slave\_threads= 4

wsrep\_log\_conflicts

###集 群 节 点 地 址

wsrep\_node\_address=192.168.1.185

###默 认 情 况 下 ， Percona XtraDB群 集 使 用 Percona XtraBackup进 行 状 态 快 照 传 输 （ SST） 。

wsrep\_sst\_method=xtrabackup-v2

###将 SST的 身 份 验 证 凭 据 指 定 为 ： 。 您 必 须 创 建 此 用 户

wsrep\_sst\_auth=‘xtrabackup:123456’

wsrep\_log\_conflicts

wsrep\_retry\_autocommit=8

secure\_file\_priv=“”

innodb\_page\_cleaners=8

wsrep\_node\_name=mypxc004d

[mysqldump]

quick

max\_allowed\_packet = 16M

[mysql]

no-auto-rehash

port = 3306

default-character-set = utf8

socket=/usr/local/mysql/mysql.sock

[myisamchk]

key\_buffer\_size = 256M

sort\_buffer\_size = 256M

read\_buffer = 2M

write\_buffer = 2M

[mysqlhotcopy]

interactive-timeout

[sst]

progress=/usr/local/mysql/data/sst\_in\_progress

---

<div class="post-metadata">

### Author: ![chenhuanhui](https://avatars.discourse-cdn.com/v4/letter/c/13edae/32.png) [@chenhuanhui](https://forums.percona.com/u/chenhuanhui)
#### Post date: [March 9, 2023, 6:40am UTC](https://forums.percona.com/t/why-cant-i-add-the-primary-node-to-pxc5-7-40-compiled-by-myself-please-help-me/20483/3 "2023-03-09T06:40:36Z")

</div>

mysql-error.log

2023-03-09T06:10:44.009673Z 0 [Warning] ‘NO\_ZERO\_DATE’, ‘NO\_ZERO\_IN\_DATE’ and ‘ERROR\_FOR\_DIVISION\_BY\_ZERO’ sql modes should be used with strict mode. They will be merged with strict mode in a future release.  
2023-03-09T06:10:44.009802Z 0 [Warning] ‘NO\_AUTO\_CREATE\_USER’ sql mode was not set.  
2023-03-09T06:10:44.009987Z 0 [Warning] WSREP: Node is running in bootstrap/initialize mode. Disabling pxc\_strict\_mode checks  
2023-03-09T06:10:45.013551Z 0 [Warning] InnoDB: New log files created, LSN=45790  
2023-03-09T06:10:45.209301Z 0 [Warning] InnoDB: Creating foreign key constraint system tables.  
2023-03-09T06:10:45.289795Z 0 [Warning] No existing UUID has been found, so we assume that this is the first time that this server has been started. Generating a new UUID: 20ecd758-be41-11ed-abeb-46014e9a285c.  
2023-03-09T06:10:45.292318Z 0 [Warning] Gtid table is not ready to be used. Table ‘mysql.gtid\_executed’ cannot be opened.  
2023-03-09T06:10:45.941549Z 0 [Warning] A deprecated TLS version TLSv1 is enabled. Please use TLSv1.2 or higher.  
2023-03-09T06:10:45.941561Z 0 [Warning] A deprecated TLS version TLSv1.1 is enabled. Please use TLSv1.2 or higher.  
2023-03-09T06:10:45.942016Z 0 [Warning] CA certificate ca.pem is self signed.  
2023-03-09T06:10:46.067323Z 1 [Note] A temporary password is generated for root@localhost: PwiU)63uRuv\_  
2023-03-09T06:13:48.702000Z 0 [Warning] ‘NO\_ZERO\_DATE’, ‘NO\_ZERO\_IN\_DATE’ and ‘ERROR\_FOR\_DIVISION\_BY\_ZERO’ sql modes should be used with strict mode. They will be merged with strict mode in a future release.  
2023-03-09T06:13:48.702061Z 0 [Warning] ‘NO\_AUTO\_CREATE\_USER’ sql mode was not set.  
2023-03-09T06:13:48.702101Z 0 [Warning] Insecure configuration for --secure-file-priv: Current value does not restrict location of generated files. Consider setting it to a valid, non-empty path.  
2023-03-09T06:13:48.702122Z 0 [Note] /usr/local/mysql/bin/mysqld (mysqld 5.7.40-43-63-log) starting as process 148101 …  
2023-03-09T06:13:48.707143Z 0 [Note] WSREP: Setting wsrep\_ready to false  
2023-03-09T06:13:48.707160Z 0 [Note] WSREP: No pre-stored wsrep-start position found. Skipping position initialization.  
2023-03-09T06:13:48.707165Z 0 [Note] WSREP: wsrep\_load(): loading provider library ‘/usr/local/mysql/lib/libgalera\_smm.so’  
2023-03-09T06:13:48.707870Z 0 [Note] WSREP: wsrep\_load(): Galera 3.63(rf47405c) by Codership Oy [info@codership.com](mailto:info@codership.com) loaded successfully.  
2023-03-09T06:13:48.707932Z 0 [Note] WSREP: CRC-32C: using hardware acceleration.  
2023-03-09T06:13:48.708208Z 0 [Warning] WSREP: Could not open state file for reading: ‘/usr/local/mysql/data//grastate.dat’  
2023-03-09T06:13:48.708218Z 0 [Warning] WSREP: No persistent state found. Bootstraping with default state  
2023-03-09T06:13:48.708266Z 0 [Note] WSREP: Found saved state: 00000000-0000-0000-0000-000000000000:-1, safe\_to\_bootstrap: 1  
2023-03-09T06:13:48.714853Z 0 [Note] WSREP: Passing config to GCS: base\_dir = /usr/local/mysql/data/; base\_host = 192.168.1.185; base\_port = 4567; cert.log\_conflicts = no; cert.optimistic\_pa = yes; debug = no; evs.auto\_evict = 0; evs.delay\_margin = PT1S; evs.delayed\_keep\_period = PT30S; evs.inactive\_check\_period = PT0.5S; evs.inactive\_timeout = PT15S; evs.join\_retrans\_period = PT1S; evs.max\_install\_timeouts = 3; evs.send\_window = 10; evs.stats\_report\_period = PT1M; evs.suspect\_timeout = PT5S; evs.user\_send\_window = 4; evs.view\_forget\_timeout = PT24H; gcache.dir = /usr/local/mysql/data/; gcache.freeze\_purge\_at\_seqno = -1; gcache.keep\_pages\_count = 0; gcache.keep\_pages\_size = 0; gcache.mem\_size = 0; gcache.name = /usr/local/mysql/data//galera.cache; gcache.page\_size = 128M; gcache.recover = no; gcache.size = 128M; gcomm.thread\_prio = ; gcs.fc\_debug = 0; gcs.fc\_factor = 1; gcs.fc\_limit = 100; gcs.fc\_master\_slave = no; gcs.max\_packet\_size = 64500; gcs.max\_throttle = 0.25; gcs.recv\_q\_hard\_limit = 9223372036854775807; gcs.recv\_q\_soft\_limit = 0.25; gcs.sync\_donor = no; gmcast.segment = 0; gmcast.version = 0; pc.announce\_timeout = PT3S; pc.checksum = false; pc.ignore\_quorum = false; pc.ignore\_sb = false; pc.npvo = false; pc.recovery = true; pc.version = 0; pc.wait\_prim = true; pc.wait\_prim\_timeout = PT30S; pc.weight = 1; protonet.backend = asio; protonet.version = 0; repl.causal\_read\_timeout = PT30S; repl.commit\_order = 3; repl.key\_format = FLAT8; repl.max\_ws\_size = 2147483647; repl.proto\_max = 9; socket.checksum = 2; socket.recv\_buf\_size = auto; socket.send\_buf\_size = auto;  
2023-03-09T06:13:48.727474Z 0 [Note] WSREP: GCache history reset: 00000000-0000-0000-0000-000000000000:0 → 00000000-0000-0000-0000-000000000000:-1  
2023-03-09T06:13:48.727941Z 0 [Note] WSREP: Assign initial position for certification: -1, protocol version: -1  
2023-03-09T06:13:48.727965Z 0 [Note] WSREP: Preparing to initiate SST/IST  
2023-03-09T06:13:48.727973Z 0 [Note] WSREP: Starting replication  
2023-03-09T06:13:48.727985Z 0 [Note] WSREP: Setting initial position to 00000000-0000-0000-0000-000000000000:-1  
2023-03-09T06:13:48.728189Z 0 [Note] WSREP: Using CRC-32C for message checksums.  
2023-03-09T06:13:48.728307Z 0 [Note] WSREP: gcomm thread scheduling priority set to other:0  
2023-03-09T06:13:48.728430Z 0 [Note] WSREP: Fail to access the file (/usr/local/mysql/data//gvwstate.dat) error (No such file or directory). It is possible if node is booting for first time or re-booting after a graceful shutdown  
2023-03-09T06:13:48.728440Z 0 [Note] WSREP: Restoring primary-component from disk failed. Either node is booting for first time or re-booting after a graceful shutdown  
2023-03-09T06:13:48.728653Z 0 [Note] WSREP: GMCast version 0  
2023-03-09T06:13:48.728798Z 0 [Note] WSREP: (8e435dab, ‘tcp://0.0.0.0:4567’) listening at tcp://0.0.0.0:4567  
2023-03-09T06:13:48.728806Z 0 [Note] WSREP: (8e435dab, ‘tcp://0.0.0.0:4567’) multicast: , ttl: 1  
2023-03-09T06:13:48.729139Z 0 [Note] WSREP: EVS version 0  
2023-03-09T06:13:48.729224Z 0 [Note] WSREP: gcomm: connecting to group ‘MYPXC’, peer ‘192.168.1.206:4567’  
2023-03-09T06:13:48.740253Z 0 [Note] WSREP: (8e435dab, ‘tcp://0.0.0.0:4567’) connection established to 2503f915 tcp://192.168.1.206:4567  
2023-03-09T06:13:48.742464Z 0 [Note] WSREP: (8e435dab, ‘tcp://0.0.0.0:4567’) turning message relay requesting on, nonlive peers:  
2023-03-09T06:13:49.238352Z 0 [Note] WSREP: declaring 2503f915 at tcp://192.168.1.206:4567 stable  
2023-03-09T06:13:49.245264Z 0 [Note] WSREP: Node 2503f915 state primary  
2023-03-09T06:13:49.257334Z 0 [Note] WSREP: Current view of cluster as seen by this node  
view (view\_id(PRIM,2503f915,12)  
memb {  
2503f915,0  
8e435dab,0  
}  
joined {  
}  
left {  
}  
partitioned {  
}  
)  
2023-03-09T06:13:49.257494Z 0 [Note] WSREP: Save the discovered primary-component to disk  
2023-03-09T06:13:49.730133Z 0 [Note] WSREP: gcomm: connected  
2023-03-09T06:13:49.731086Z 0 [Note] WSREP: Shifting CLOSED → OPEN (TO: 0)  
2023-03-09T06:13:49.731636Z 0 [Note] WSREP: New COMPONENT: primary = yes, bootstrap = no, my\_idx = 1, memb\_num = 2  
2023-03-09T06:13:49.731813Z 0 [Note] WSREP: STATE EXCHANGE: Waiting for state UUID.  
2023-03-09T06:13:49.731922Z 0 [Note] WSREP: Waiting for SST/IST to complete.  
2023-03-09T06:13:49.732037Z 0 [Note] WSREP: STATE EXCHANGE: sent state msg: 8e944acf-be41-11ed-a16f-7abe185ea36d  
2023-03-09T06:13:49.732690Z 0 [Note] WSREP: STATE EXCHANGE: got state msg: 8e944acf-be41-11ed-a16f-7abe185ea36d from 0 (maneger)  
2023-03-09T06:13:49.734264Z 0 [Note] WSREP: STATE EXCHANGE: got state msg: 8e944acf-be41-11ed-a16f-7abe185ea36d from 1 (mypxc004d)  
2023-03-09T06:13:49.734403Z 0 [Note] WSREP: Quorum results:  
version = 6,  
component = PRIMARY,  
conf\_id = 11,  
members = 1/2 (primary/total),  
act\_id = 21,  
last\_appl. = -1,  
protocols = 0/9/3 (gcs/repl/appl),  
group UUID = a07d3a6a-bd9f-11ed-85e2-3f289993f145  
2023-03-09T06:13:49.734525Z 0 [Note] WSREP: Flow-control interval: [141, 141]  
2023-03-09T06:13:49.734683Z 0 [Note] WSREP: Shifting OPEN → PRIMARY (TO: 21)  
2023-03-09T06:13:49.735121Z 1 [Note] WSREP: State transfer required:  
Group state: a07d3a6a-bd9f-11ed-85e2-3f289993f145:21  
Local state: 00000000-0000-0000-0000-000000000000:-1  
2023-03-09T06:13:49.735198Z 1 [Note] WSREP: REPL Protocols: 9 (4, 2)  
2023-03-09T06:13:49.735232Z 1 [Note] WSREP: REPL Protocols: 9 (4, 2)  
2023-03-09T06:13:49.735324Z 1 [Note] WSREP: New cluster view: global state: a07d3a6a-bd9f-11ed-85e2-3f289993f145:21, view# 12: Primary, number of nodes: 2, my index: 1, protocol version 3  
2023-03-09T06:13:49.735348Z 1 [Note] WSREP: Setting wsrep\_ready to true  
2023-03-09T06:13:49.735369Z 1 [Warning] WSREP: Gap in state sequence. Need state transfer.  
2023-03-09T06:13:49.735387Z 1 [Note] WSREP: Setting wsrep\_ready to false  
2023-03-09T06:13:49.735967Z 0 [Note] WSREP: Initiating SST/IST transfer on JOINER side (wsrep\_sst\_xtrabackup-v2 --role ‘joiner’ --address ‘192.168.1.185’ --datadir ‘/usr/local/mysql/data/’ --defaults-file ‘/usr/local/mysql/my.cnf’ --defaults-group-suffix ‘’ --parent ‘148101’ --mysqld-version ‘5.7.40-43-63’ ‘’ )  
2023-03-09T06:13:50.995106Z WSREP\_SST: [INFO] Streaming with xbstream  
/usr/local/mysql/bin/wsrep\_sst\_xtrabackup-v2: line 222: xbstream: command not found  
2023-03-09T06:13:51.822602Z 1 [Note] WSREP: Prepared SST/IST request: xtrabackup-v2|192.168.1.185:4444/xtrabackup\_sst//1  
2023-03-09T06:13:51.822718Z 1 [Note] WSREP: Auto Increment Offset/Increment re-align with cluster membership change (Offset: 1 → 2) (Increment: 1 → 2)  
2023-03-09T06:13:51.822762Z 1 [Note] WSREP: wsrep\_notify\_cmd is not defined, skipping notification.  
2023-03-09T06:13:51.822835Z 1 [Note] WSREP: Assign initial position for certification: 21, protocol version: 4  
2023-03-09T06:13:51.823022Z 0 [Note] WSREP: Service thread queue flushed.  
2023-03-09T06:13:51.823348Z 1 [Note] WSREP: Check if state gap can be serviced using IST  
2023-03-09T06:13:51.823441Z 1 [Note] WSREP: Local UUID: 00000000-0000-0000-0000-000000000000 != Group UUID: a07d3a6a-bd9f-11ed-85e2-3f289993f145  
2023-03-09T06:13:51.823651Z 1 [Note] WSREP: State gap can’t be serviced using IST. Switching to SST  
2023-03-09T06:13:51.823684Z 1 [Note] WSREP: Failed to prepare for incremental state transfer: Local state UUID (00000000-0000-0000-0000-000000000000) does not match group state UUID (a07d3a6a-bd9f-11ed-85e2-3f289993f145): 1 (Operation not permitted)  
at galera/src/replicator\_str.cpp:prepare\_for\_IST():518. IST will be unavailable.  
2023-03-09T06:13:51.825803Z 0 [Note] WSREP: Member 1.0 (mypxc004d) requested state transfer from ‘_any_’. Selected 0.0 (maneger)(SYNCED) as donor.  
2023-03-09T06:13:51.825867Z 0 [Note] WSREP: Shifting PRIMARY → JOINER (TO: 21)  
2023-03-09T06:13:51.826086Z 1 [Note] WSREP: Requesting state transfer: success, donor: 0  
2023-03-09T06:13:51.826177Z 1 [Note] WSREP: GCache history reset: 00000000-0000-0000-0000-000000000000:0 → a07d3a6a-bd9f-11ed-85e2-3f289993f145:21  
2023-03-09T06:13:52.231050Z 0 [Note] WSREP: (8e435dab, ‘tcp://0.0.0.0:4567’) turning message relay requesting off  
2023-03-09T06:13:53.239589Z WSREP\_SST: [ERROR] \*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\* FATAL ERROR \*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*  
2023-03-09T06:13:53.250358Z WSREP\_SST: [ERROR] Error while getting data from donor node: exit codes: 0 0 0 127  
2023-03-09T06:13:53.261681Z WSREP\_SST: [ERROR] \*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*  
2023-03-09T06:13:53.273471Z WSREP\_SST: [ERROR] Cleanup after exit with status:32  
2023-03-09T06:13:53.369230Z 0 [ERROR] WSREP: Process completed with error: wsrep\_sst\_xtrabackup-v2 --role ‘joiner’ --address ‘192.168.1.185’ --datadir ‘/usr/local/mysql/data/’ --defaults-file ‘/usr/local/mysql/my.cnf’ --defaults-group-suffix ‘’ --parent ‘148101’ --mysqld-version ‘5.7.40-43-63’ ‘’ : 32 (Broken pipe)  
2023-03-09T06:13:53.369382Z 0 [ERROR] WSREP: Failed to read uuid:seqno from joiner script.  
2023-03-09T06:13:53.369412Z 0 [ERROR] WSREP: SST script aborted with error 32 (Broken pipe)  
2023-03-09T06:13:53.369578Z 0 [ERROR] WSREP: SST failed: 32 (Broken pipe)  
2023-03-09T06:13:53.369625Z 0 [ERROR] Aborting

2023-03-09T06:13:53.369651Z 0 [Note] WSREP: Signalling cancellation of the SST request.  
2023-03-09T06:13:53.369725Z 0 [Note] WSREP: SST request was cancelled  
2023-03-09T06:13:53.369782Z 0 [Note] Giving 2 client threads a chance to die gracefully  
2023-03-09T06:13:53.369807Z 1 [Note] WSREP: Closing send monitor…  
2023-03-09T06:13:53.369847Z 1 [Note] WSREP: Closed send monitor.  
2023-03-09T06:13:53.369945Z 1 [Note] WSREP: gcomm: terminating thread  
2023-03-09T06:13:53.370006Z 1 [Note] WSREP: gcomm: joining thread  
2023-03-09T06:13:53.370351Z 1 [Note] WSREP: gcomm: closing backend  
2023-03-09T06:13:54.382983Z 1 [Note] WSREP: Current view of cluster as seen by this node  
view (view\_id(NON\_PRIM,2503f915,12)  
memb {  
8e435dab,0  
}  
joined {  
}  
left {  
}  
partitioned {  
2503f915,0  
}  
)  
2023-03-09T06:13:54.383058Z 1 [Note] WSREP: Current view of cluster as seen by this node  
view ((empty))  
2023-03-09T06:13:54.388665Z 1 [Note] WSREP: gcomm: closed  
2023-03-09T06:13:54.388754Z 0 [Note] WSREP: New COMPONENT: primary = no, bootstrap = no, my\_idx = 0, memb\_num = 1  
2023-03-09T06:13:54.388842Z 0 [Note] WSREP: Flow-control interval: [100, 100]  
2023-03-09T06:13:54.388860Z 0 [Note] WSREP: Received NON-PRIMARY.  
2023-03-09T06:13:54.388875Z 0 [Note] WSREP: Shifting JOINER → OPEN (TO: 21)  
2023-03-09T06:13:54.388944Z 0 [Note] WSREP: Received self-leave message.  
2023-03-09T06:13:54.388967Z 0 [Note] WSREP: Flow-control interval: [0, 0]  
2023-03-09T06:13:54.388981Z 0 [Note] WSREP: Received SELF-LEAVE. Closing connection.  
2023-03-09T06:13:54.388995Z 0 [Note] WSREP: Shifting OPEN → CLOSED (TO: 21)  
2023-03-09T06:13:54.389014Z 0 [Note] WSREP: RECV thread exiting 0: Success  
2023-03-09T06:13:54.389230Z 1 [Note] WSREP: recv\_thread() joined.  
2023-03-09T06:13:54.389284Z 1 [Note] WSREP: Closing replication queue.  
2023-03-09T06:13:54.389308Z 1 [Note] WSREP: Closing slave action queue.  
2023-03-09T06:13:54.389448Z 1 [Note] WSREP: New cluster view: global state: 00000000-0000-0000-0000-000000000000:0, view# -1: non-Primary, number of nodes: 0, my index: -1, protocol version -1  
2023-03-09T06:13:54.389478Z 1 [Note] WSREP: Setting wsrep\_ready to false  
2023-03-09T06:13:54.389500Z 1 [Note] WSREP: wsrep\_notify\_cmd is not defined, skipping notification.  
2023-03-09T06:13:54.389527Z 1 [Note] WSREP: applier thread exiting (code:6)  
2023-03-09T06:13:55.370037Z 0 [Note] WSREP: Waiting for active wsrep applier to exit  
2023-03-09T06:13:55.370139Z 2 [Note] WSREP: rollbacker thread exiting  
2023-03-09T06:13:55.370266Z 0 [Note] WSREP: Service disconnected.  
2023-03-09T06:13:55.370284Z 0 [Note] WSREP: Waiting to close threads…  
2023-03-09T06:14:00.370390Z 0 [Note] WSREP: Some threads may fail to exit.  
2023-03-09T06:14:00.435282Z 0 [Note] WSREP: Service thread queue flushed.  
2023-03-09T06:14:00.435828Z 0 [Note] WSREP: MemPool(SlaveTrxHandle): hit ratio: 0, misses: 0, in use: 0, in pool: 0  
2023-03-09T06:14:00.440296Z 0 [Note] Binlog end  
2023-03-09T06:14:00.440669Z 0 [Note] /usr/local/mysql/bin/mysqld: Shutdown complete

---

<div class="post-metadata">

### Author: ![chenhuanhui](https://avatars.discourse-cdn.com/v4/letter/c/13edae/32.png) [@chenhuanhui](https://forums.percona.com/u/chenhuanhui)
#### Post date: [March 9, 2023, 6:43am UTC](https://forums.percona.com/t/why-cant-i-add-the-primary-node-to-pxc5-7-40-compiled-by-myself-please-help-me/20483/4 "2023-03-09T06:43:33Z")

</div>

maneger logs  
2023-03-09T06:13:48.740822Z 0 [Note] WSREP: (2503f915, ‘tcp://0.0.0.0:4567’) connection established to 8e435dab tcp://192.168.1.185:4567  
2023-03-09T06:13:48.743953Z 0 [Note] WSREP: (2503f915, ‘tcp://0.0.0.0:4567’) turning message relay requesting on, nonlive peers:  
2023-03-09T06:13:49.240623Z 0 [Note] WSREP: declaring 8e435dab at tcp://192.168.1.185:4567 stable  
2023-03-09T06:13:49.245715Z 0 [Note] WSREP: Node 2503f915 state primary  
2023-03-09T06:13:49.249296Z 0 [Note] WSREP: Current view of cluster as seen by this node  
view (view\_id(PRIM,2503f915,12)  
memb {  
2503f915,0  
8e435dab,0  
}  
joined {  
}  
left {  
}  
partitioned {  
}  
)  
2023-03-09T06:13:49.249554Z 0 [Note] WSREP: Save the discovered primary-component to disk  
2023-03-09T06:13:49.258616Z 0 [Note] WSREP: New COMPONENT: primary = yes, bootstrap = no, my\_idx = 0, memb\_num = 2  
2023-03-09T06:13:49.259757Z 0 [Note] WSREP: STATE\_EXCHANGE: sent state UUID: 8e944acf-be41-11ed-a16f-7abe185ea36d  
2023-03-09T06:13:49.269360Z 0 [Note] WSREP: STATE EXCHANGE: sent state msg: 8e944acf-be41-11ed-a16f-7abe185ea36d  
2023-03-09T06:13:49.271087Z 0 [Note] WSREP: STATE EXCHANGE: got state msg: 8e944acf-be41-11ed-a16f-7abe185ea36d from 0 (maneger)  
2023-03-09T06:13:49.736334Z 0 [Note] WSREP: STATE EXCHANGE: got state msg: 8e944acf-be41-11ed-a16f-7abe185ea36d from 1 (mypxc004d)  
2023-03-09T06:13:49.736541Z 0 [Note] WSREP: Quorum results:  
version = 6,  
component = PRIMARY,  
conf\_id = 11,  
members = 1/2 (primary/total),  
act\_id = 21,  
last\_appl. = 0,  
protocols = 0/9/3 (gcs/repl/appl),  
group UUID = a07d3a6a-bd9f-11ed-85e2-3f289993f145  
2023-03-09T06:13:49.736668Z 0 [Note] WSREP: Flow-control interval: [141, 141]  
2023-03-09T06:13:49.737533Z 1 [Note] WSREP: REPL Protocols: 9 (4, 2)  
2023-03-09T06:13:49.737625Z 1 [Note] WSREP: REPL Protocols: 9 (4, 2)  
2023-03-09T06:13:49.737638Z 1 [Note] WSREP: New cluster view: global state: a07d3a6a-bd9f-11ed-85e2-3f289993f145:21, view# 12: Primary, number of nodes: 2, my index: 0, protocol version 3  
2023-03-09T06:13:49.737643Z 1 [Note] WSREP: Setting wsrep\_ready to true  
2023-03-09T06:13:49.737648Z 1 [Note] WSREP: Auto Increment Offset/Increment re-align with cluster membership change (Offset: 1 → 1) (Increment: 1 → 2)  
2023-03-09T06:13:49.737696Z 1 [Note] WSREP: wsrep\_notify\_cmd is not defined, skipping notification.  
2023-03-09T06:13:49.737950Z 1 [Note] WSREP: Assign initial position for certification: 21, protocol version: 4  
2023-03-09T06:13:49.738354Z 0 [Note] WSREP: Service thread queue flushed.  
2023-03-09T06:13:51.827941Z 0 [Note] WSREP: Member 1.0 (mypxc004d) requested state transfer from ‘_any_’. Selected 0.0 (maneger)(SYNCED) as donor.  
2023-03-09T06:13:51.828037Z 0 [Note] WSREP: Shifting SYNCED → DONOR/DESYNCED (TO: 21)  
2023-03-09T06:13:51.828500Z 1 [Note] WSREP: wsrep\_notify\_cmd is not defined, skipping notification.  
2023-03-09T06:13:51.829202Z 0 [Note] WSREP: Initiating SST/IST transfer on DONOR side (wsrep\_sst\_xtrabackup-v2 --role ‘donor’ --address ‘192.168.1.185:4444/xtrabackup\_sst//1’ --socket ‘/tmp/mysql.sock’ --datadir ‘/var/lib/mysql/’ --defaults-file ‘/etc/my.cnf’ --defaults-group-suffix ‘’ --mysqld-version ‘5.7.40-43-57’ ‘’ --gtid ‘a07d3a6a-bd9f-11ed-85e2-3f289993f145:21’ )  
2023-03-09T06:13:51.831437Z 1 [Note] WSREP: DONOR thread signaled with 0  
2023-03-09T06:13:51.901003Z 0 [Note] WSREP: (2503f915, ‘tcp://0.0.0.0:4567’) turning message relay requesting off  
2023-03-09T06:13:52.692795Z WSREP\_SST: [INFO] Streaming with xbstream  
2023-03-09T06:13:54.374710Z 0 [Note] WSREP: forgetting 8e435dab (tcp://192.168.1.185:4567)  
2023-03-09T06:13:54.374966Z 0 [Note] WSREP: Node 2503f915 state primary  
2023-03-09T06:13:54.375286Z 0 [Note] WSREP: Current view of cluster as seen by this node  
view (view\_id(PRIM,2503f915,13)  
memb {  
2503f915,0  
}  
joined {  
}  
left {  
}  
partitioned {  
8e435dab,0  
}  
)  
2023-03-09T06:13:54.375324Z 0 [Note] WSREP: Save the discovered primary-component to disk  
2023-03-09T06:13:54.382869Z 0 [Note] WSREP: forgetting 8e435dab (tcp://192.168.1.185:4567)  
2023-03-09T06:13:54.383322Z 0 [Note] WSREP: New COMPONENT: primary = yes, bootstrap = no, my\_idx = 0, memb\_num = 1  
2023-03-09T06:13:54.387276Z 0 [Note] WSREP: STATE\_EXCHANGE: sent state UUID: 91a23bfe-be41-11ed-b141-62b32f4c30a0  
2023-03-09T06:13:54.387486Z 0 [Note] WSREP: STATE EXCHANGE: sent state msg: 91a23bfe-be41-11ed-b141-62b32f4c30a0  
2023-03-09T06:13:54.387510Z 0 [Note] WSREP: STATE EXCHANGE: got state msg: 91a23bfe-be41-11ed-b141-62b32f4c30a0 from 0 (maneger)  
2023-03-09T06:13:54.387530Z 0 [Note] WSREP: Quorum results:  
version = 6,  
component = PRIMARY,  
conf\_id = 12,  
members = 1/1 (primary/total),  
act\_id = 21,  
last\_appl. = 0,  
protocols = 0/9/3 (gcs/repl/appl),  
group UUID = a07d3a6a-bd9f-11ed-85e2-3f289993f145  
2023-03-09T06:13:54.387546Z 0 [Note] WSREP: Flow-control interval: [100, 100]  
2023-03-09T06:13:54.388486Z 4 [Note] WSREP: REPL Protocols: 9 (4, 2)  
2023-03-09T06:13:54.388687Z 4 [Note] WSREP: REPL Protocols: 9 (4, 2)  
2023-03-09T06:13:54.388715Z 4 [Note] WSREP: New cluster view: global state: a07d3a6a-bd9f-11ed-85e2-3f289993f145:21, view# 13: Primary, number of nodes: 1, my index: 0, protocol version 3  
2023-03-09T06:13:54.388726Z 4 [Note] WSREP: Setting wsrep\_ready to true  
2023-03-09T06:13:54.388737Z 4 [Note] WSREP: Auto Increment Offset/Increment re-align with cluster membership change (Offset: 1 → 1) (Increment: 2 → 1)  
2023-03-09T06:13:54.389371Z 4 [Note] WSREP: wsrep\_notify\_cmd is not defined, skipping notification.  
2023-03-09T06:13:54.389749Z 4 [Note] WSREP: Assign initial position for certification: 21, protocol version: 4  
2023-03-09T06:13:54.389818Z 0 [Note] WSREP: Service thread queue flushed.  
2023-03-09T06:13:59.421411Z 0 [Note] WSREP: cleaning up 8e435dab (tcp://192.168.1.185:4567)  
2023-03-09T06:14:03.869407Z WSREP\_SST: [INFO] Streaming the backup to joiner at 192.168.1.185 4444  
2023/03/09 06:14:04 socat[2212] E write(6, 0x55d748504000, 8192): Connection refused  
2023-03-09T06:14:05.223268Z 10 [Note] Aborted connection 10 to db: ‘unconnected’ user: ‘xtrabackup’ host: ‘localhost’ (Got an error reading communication packets)  
2023-03-09T06:14:05.236891Z WSREP\_SST: [ERROR] \*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\* FATAL ERROR \*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*  
2023-03-09T06:14:05.250241Z WSREP\_SST: [ERROR] xtrabackup finished with error: 1. Check /var/lib/mysql//innobackup.backup.log  
--------------- innobackup.backup.log (START) --------------------  
xtrabackup: recognized server arguments: --datadir=/var/lib/mysql --innodb\_flush\_log\_at\_trx\_commit=0 --innodb\_flush\_method=O\_DIRECT --innodb\_file\_per\_table=1 --defaults\_group=mysqld --parallel=4  
xtrabackup: recognized client arguments: --socket=/tmp/mysql.sock --no-version-check=1 --user=xtrabackup --password=\* --socket=/tmp/mysql.sock --lock-ddl=1 --backup=1 --galera-info=1 --binlog-info=ON --stream=xbstream --target-dir=/tmp/pxc\_sst\_jG7d/donor\_xb\_h569  
230309 06:14:03 Connecting to MySQL server host: localhost, user: xtrabackup, password: set, port: not set, socket: /tmp/mysql.sock  
Using server version 5.7.40-43-57  
230309 06:14:03 Executing LOCK TABLES FOR BACKUP…  
xtrabackup version 2.4.27 based on MySQL server 5.7.40 Linux (x86\_64) (revision id: aae8e82)  
xtrabackup: uses posix\_fadvise().  
xtrabackup: cd to /var/lib/mysql  
xtrabackup: open files limit requested 0, set to 1048576  
xtrabackup: using the following InnoDB configuration:  
xtrabackup: innodb\_data\_home\_dir = .  
xtrabackup: innodb\_data\_file\_path = ibdata1:12M:autoextend  
xtrabackup: innodb\_log\_group\_home\_dir = ./  
xtrabackup: innodb\_log\_files\_in\_group = 2  
xtrabackup: innodb\_log\_file\_size = 50331648  
xtrabackup: using O\_DIRECT  
InnoDB: Number of pools: 1  
230309 06:14:03 \>\> log scanned up to (12408431)  
xtrabackup: Generating a list of tablespaces  
InnoDB: Allocated tablespace ID 19 for mysql/server\_cost, old maximum was 0  
xtrabackup: Starting 4 threads for parallel data files transfer  
230309 06:14:04 [01] Streaming ./ibdata1  
230309 06:14:04 [03] Streaming ./mysql/servers.ibd  
230309 06:14:04 [02] Streaming ./mysql/server\_cost.ibd  
230309 06:14:04 [04] Streaming ./mysql/help\_keyword.ibd  
230309 06:14:04 [03] …done  
230309 06:14:04 [04] …done  
230309 06:14:04 [02] …done  
xtrabackup: Error writing file ‘UNOPENED’ (Errcode: 32 - Broken pipe)  
xtrabackup: Error writing file ‘UNOPENED’ (Errcode: 32 - Broken pipe)  
xtrabackup: Error writing file ‘UNOPENED’ (Errcode: 32 - Broken pipe)  
[04] xtrabackup: Error: failed to copy datafile.  
[02] xtrabackup: Error: failed to copy datafile.  
[03] xtrabackup: Error: failed to copy datafile.  
xtrabackup: Error writing file ‘UNOPENED’ (Errcode: 32 - Broken pipe)  
xb\_stream\_write\_data() failed.  
xtrabackup: Error writing file ‘UNOPENED’ (Errcode: 32 - Broken pipe)  
[01] xtrabackup: Error: xtrabackup\_copy\_datafile() failed.  
[01] xtrabackup: Error: failed to copy datafile.  
230309 06:14:04 \>\> log scanned up to (12408431)  
--------------- innobackup.backup.log (END) ----------------------  
2023-03-09T06:14:05.273418Z WSREP\_SST: [ERROR] \*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*  
2023-03-09T06:14:05.285933Z WSREP\_SST: [ERROR] Cleanup after exit with status:22  
2023-03-09T06:14:05.322536Z 0 [ERROR] WSREP: Process completed with error: wsrep\_sst\_xtrabackup-v2 --role ‘donor’ --address ‘192.168.1.185:4444/xtrabackup\_sst//1’ --socket ‘/tmp/mysql.sock’ --datadir ‘/var/lib/mysql/’ --defaults-file ‘/etc/my.cnf’ --defaults-group-suffix ‘’ --mysqld-version ‘5.7.40-43-57’ ‘’ --gtid ‘a07d3a6a-bd9f-11ed-85e2-3f289993f145:21’ : 22 (Invalid argument)  
2023-03-09T06:14:05.322789Z 0 [ERROR] WSREP: Command did not run: wsrep\_sst\_xtrabackup-v2 --role ‘donor’ --address ‘192.168.1.185:4444/xtrabackup\_sst//1’ --socket ‘/tmp/mysql.sock’ --datadir ‘/var/lib/mysql/’ --defaults-file ‘/etc/my.cnf’ --defaults-group-suffix ‘’ --mysqld-version ‘5.7.40-43-57’ ‘’ --gtid ‘a07d3a6a-bd9f-11ed-85e2-3f289993f145:21’  
2023-03-09T06:14:05.322864Z 0 [Warning] WSREP: Could not find peer: 8e435dab-be41-11ed-8ca0-33ca40fbddcd  
2023-03-09T06:14:05.322885Z 0 [Warning] WSREP: 0.0 (maneger): State transfer to -1.-1 (left the group) failed: -22 (Invalid argument)  
2023-03-09T06:14:05.322895Z 0 [Note] WSREP: Shifting DONOR/DESYNCED → JOINED (TO: 21)  
2023-03-09T06:14:05.322934Z 0 [Note] WSREP: Member 0.0 (maneger) synced with group.  
2023-03-09T06:14:05.323033Z 0 [Note] WSREP: Shifting JOINED → SYNCED (TO: 21)  
2023-03-09T06:14:05.323097Z 1 [Note] WSREP: Synchronized with group, ready for connections  
2023-03-09T06:14:05.323104Z 1 [Note] WSREP: Setting wsrep\_ready to true  
2023-03-09T06:14:05.323111Z 1 [Note] WSREP: wsrep\_notify\_cmd is not defined, skipping notification.

---

<div class="post-metadata">

### Author: ![Alex\_Miroshnychenko](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/alex_miroshnychenko/32/2621_2.png) [@Alex\_Miroshnychenko](https://forums.percona.com/u/Alex_Miroshnychenko)
#### Post date: [March 9, 2023, 8:39am UTC](https://forums.percona.com/t/why-cant-i-add-the-primary-node-to-pxc5-7-40-compiled-by-myself-please-help-me/20483/5 "2023-03-09T08:39:36Z")

</div>

Hi @chenhuanhui  
Please check if there are no firewall rules that could block the connection between your new node and two other nodes:

> **[Percona Documentation - Percona](https://docs.percona.com/percona-xtradb-cluster/5.7/security/secure-network.html)**
>
> Percona database support services ensures 24x7x365 database support for better performance. Highly responsive, effective and affordable.

---

<div class="post-metadata">

### Author: ![matthewb](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/matthewb/32/34_2.png) [@matthewb](https://forums.percona.com/u/matthewb)
#### Post date: [March 9, 2023, 1:47pm UTC](https://forums.percona.com/t/why-cant-i-add-the-primary-node-to-pxc5-7-40-compiled-by-myself-please-help-me/20483/6 "2023-03-09T13:47:37Z")

</div>

Your errors logs also say “unable to find xbstream”. Did you also compile and install xtrabackup + xbstream?
