# While restoring pmm 3.4 data getting permission errors

**URL:** https://forums.percona.com/t/while-restoring-pmm-3-4-data-getting-permission-errors/39545
**Category:** Uncategorized
**Created:** [October 13, 2025, 3:24pm UTC](https://forums.percona.com/t/while-restoring-pmm-3-4-data-getting-permission-errors/39545 "2025-10-13T15:24:00Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![suman\_8864](https://avatars.discourse-cdn.com/v4/letter/s/13edae/32.png) [@suman\_8864](https://forums.percona.com/u/suman_8864)
#### Post date: [October 13, 2025, 3:24pm UTC](https://forums.percona.com/t/while-restoring-pmm-3-4-data-getting-permission-errors/39545/1 "2025-10-13T15:24:01Z")

</div>

Hi,

Server1 is running **PMM 3.4.0** , and Server2 has also been installed with **PMM 3.4.0**.We are attempting to restore the **PMM 3.4.0 backup** from Server1 onto Server2.

However, during the restoration process, we are encountering the following errors

2025-10-13T15:16:56.797Z info VictoriaMetrics/lib/backup/actions/restore.go:190 restored 39853119055 bytes from backup in 71.439 seconds; deleted 6461465 bytes; downloaded 39853119047 bytes  
2025-10-13T15:16:56.797Z info VictoriaMetrics/app/vmrestore/main.go:66 gracefully shutting down http server for metrics at “[:8421]”  
2025-10-13T15:16:56.798Z info VictoriaMetrics/app/vmrestore/main.go:70 successfully shut down http server for metrics in 0.000 seconds  
chown: changing ownership of ‘/srv/victoriametrics/data/metadata/minTimestampForCompositeIndex’: Operation not permitted  
chown: changing ownership of ‘/srv/victoriametrics/data/metadata’: Operation not permitted  
chown: changing ownership of ‘/srv/victoriametrics/data/flock.lock’: Operation not permitted  
chown: changing ownership of ‘/srv/victoriametrics/data/indexdb/183F6EEF7B7D7CB1/186DF9C1B8E50DD1/metadata.json’: Operation not permitted  
chown: changing ownership of ‘/srv/victoriametrics/data/indexdb/183F6EEF7B7D7CB1/186DF9C1B8E50DD1/metaindex.bin’: Operation not permitted  
chown: changing ownership of ‘/srv/victoriametrics/data/indexdb/183F6EEF7B7D7CB1/186DF9C1B8E50DD1/items.bin’: Operation not permitted  
chown: changing ownership of ‘/srv/victoriametrics/data/indexdb/183F6EEF7B7D7CB1/186DF9C1B8E50DD1/lens.bin’: Operation not permitted  
chown: changing ownership of ‘/srv/victoriametrics/data/indexdb/183F6EEF7B7D7CB1/186DF9C1B8E50DD1/index.bin’: Operation not permitted  
chown: changing ownership of ‘/srv/victoriametrics/data/indexdb/183F6EEF7B7D7CB1/186DF9C1B8E50DD1’: Operation not permitted  
chown: changing ownership of ‘/srv/victoriametrics/data/indexdb/183F6EEF7B7D7CB1/186DF9C1B8E50FEC/metadata.json’: Operation not permitted  
chown: changing ownership of ‘/srv/victoriametrics/data/indexdb/183F6EEF7B7D7CB1/186DF9C1B8E50FEC/metaindex.bin’: Operation not permitted  
chown: changing ownership of ‘/srv/victoriametrics/data/indexdb/183F6EEF7B7D7CB1/186DF9C1B8E50FEC/items.bin’: Operation not permitted.

Could you please check and let us know how we can fix it?

Thanks,

Suman.A

---

<div class="post-metadata">

### Author: ![jaimes](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/jaimes/32/20419_2.png) [@jaimes](https://forums.percona.com/u/jaimes)
#### Post date: [May 5, 2026, 4:29am UTC](https://forums.percona.com/t/while-restoring-pmm-3-4-data-getting-permission-errors/39545/2 "2026-05-05T04:29:20Z")

</div>

Hi Suman.A,

Can you provide the instructions on how you are copying the files from Server1 to Server2 so I can help you? That being said, restore methods are provided in this link: [Restore PMM Server Docker container - Percona Monitoring and Management](https://docs.percona.com/percona-monitoring-and-management/3/install-pmm/install-pmm-server/deployment-options/docker/restore_container.html)

Thanks.
