# Where are percona distribution for PostgreSQL rpm?

**URL:** <https://forums.percona.com/t/where-are-percona-distribution-for-postgresql-rpm/39121>\
**Category:** Percona Distribution for PostgreSQL\
**Created:** [August 14, 2025, 12:14pm UTC](https://forums.percona.com/t/where-are-percona-distribution-for-postgresql-rpm/39121 "2025-08-14T12:14:13Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![did16](https://avatars.discourse-cdn.com/v4/letter/d/dfb087/32.png) [@did16](https://forums.percona.com/u/did16)\
**Post date:** [August 14, 2025, 12:14pm UTC](https://forums.percona.com/t/where-are-percona-distribution-for-postgresql-rpm/39121/1 "2025-08-14T12:14:13Z")

</div>

Hi

Where can I download the percona distribution for PostgreSQL rpm packages ? I can’t find them ?  
I can not use the percona repository in my firm. I have to download rpm packages manually.

---

<div class="post-metadata">

**Author:** ![Vadim\_Yalovets](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/vadim_yalovets/32/43_2.png) [@Vadim\_Yalovets](https://forums.percona.com/u/Vadim_Yalovets)\
**Post date:** [August 14, 2025, 1:04pm UTC](https://forums.percona.com/t/where-are-percona-distribution-for-postgresql-rpm/39121/2 "2025-08-14T13:04:01Z")

</div>

Hi @did16

Packages can be downloaded from the site [https://repo.percona.com/](https://repo.percona.com/)

 ![Screenshot 2025-08-14 at 16.03.42](https://us1.discourse-cdn.com/flex019/uploads/percona1/original/3X/9/a/9af4318bcfad55bb683adeff6f72a4a6565185e5.png)

---

<div class="post-metadata">

**Author:** ![did16](https://avatars.discourse-cdn.com/v4/letter/d/dfb087/32.png) [@did16](https://forums.percona.com/u/did16)\
**Post date:** [August 14, 2025, 3:00pm UTC](https://forums.percona.com/t/where-are-percona-distribution-for-postgresql-rpm/39121/3 "2025-08-14T15:00:04Z")

</div>

Thanks for the quick answer.  
When I try to install percona-postgresql17-server-17.5-2.el8.x86\_64.rpm . I have this error :

 ![image](https://us1.discourse-cdn.com/flex019/uploads/percona1/original/3X/4/4/44435ecc95d0597e3a76ee71c907284cdcab526a.png)

then

yum install percona-pg-telemetry17-1.1.2-1.el8.x86\_64.rpm

 ![image](https://us1.discourse-cdn.com/flex019/uploads/percona1/original/3X/0/5/05bb5caed3e68c90b3ca65a4a056e85df69d47a9.png)

then unable to find percona-telemetry-agent rpm.  
what can I do ?

---

<div class="post-metadata">

**Author:** ![Anup\_Kumar\_Gupta](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/anup_kumar_gupta/32/19930_2.png) [@Anup\_Kumar\_Gupta](https://forums.percona.com/u/Anup_Kumar_Gupta)\
**Post date:** [August 14, 2025, 4:32pm UTC](https://forums.percona.com/t/where-are-percona-distribution-for-postgresql-rpm/39121/4 "2025-08-14T16:32:42Z")

</div>

I would suggest you use the below RPM instead. It will bypass the dependency of telemetry packages.

[percona-ppg-server17-17.5-1.el8.x86\_64.rpm](https://repo.percona.com/ppg-17.5/yum/release/8Server/RPMS/x86_64/percona-ppg-server17-17.5-1.el8.x86_64.rpm "percona-ppg-server17-17.5-1.el8.x86\_64.rpm")

But, it needs other dependent packages which you can find it in the repo.

Another option is to use internet based installations. This is documented [here](https://docs.percona.com/postgresql/17/yum.html#configure-the-repository).  
`sudo yum install ``https://repo.percona.com/yum/percona-release-latest.noarch.rpm`  
`sudo percona-release setup ppg17`  
`sudo yum install percona-ppg-server17`

Regards

Anup Gupta

---

<div class="post-metadata">

**Author:** ![Evgeniy\_Patlan](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/evgeniy_patlan/32/41_2.png) [@Evgeniy\_Patlan](https://forums.percona.com/u/Evgeniy_Patlan)\
**Post date:** [August 18, 2025, 3:35pm UTC](https://forums.percona.com/t/where-are-percona-distribution-for-postgresql-rpm/39121/5 "2025-08-18T15:35:38Z")

</div>

It is recommended to install percona-telemetry package. it can be installed from our repo.  
Once it is installed you can disable telemetry.

---

<div class="post-metadata">

**Author:** ![did16](https://avatars.discourse-cdn.com/v4/letter/d/dfb087/32.png) [@did16](https://forums.percona.com/u/did16)\
**Post date:** [August 19, 2025, 9:21am UTC](https://forums.percona.com/t/where-are-percona-distribution-for-postgresql-rpm/39121/6 "2025-08-19T09:21:53Z")

</div>

Hi  
The problem is , in real life, it is not possible to access percona repository, because of firewalls. in my firm , unable to acces internet for security reasons.

We have to install percona postgresql with rpm packages manually.

---

<div class="post-metadata">

**Author:** ![Anup\_Kumar\_Gupta](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/anup_kumar_gupta/32/19930_2.png) [@Anup\_Kumar\_Gupta](https://forums.percona.com/u/Anup_Kumar_Gupta)\
**Post date:** [August 19, 2025, 9:40am UTC](https://forums.percona.com/t/where-are-percona-distribution-for-postgresql-rpm/39121/7 "2025-08-19T09:40:33Z")

</div>

> [@did16](#):
>
> it is not possible to access percona repository, because of firewalls. in

In such cases of airgapped environment , you can setup a local repo as explained [here](https://docs.percona.com/percona-software-repositories/mirror.html) and install the required packages.

> **[Percona Software Repositories - Create a local mirror of a Percona repository](https://docs.percona.com/percona-software-repositories/mirror.html)**
>
> Enterprises introduce various security policies: for example, allow Internet access only on one server or deny root privileges to database administrators.

---

<div class="post-metadata">

**Author:** ![did16](https://avatars.discourse-cdn.com/v4/letter/d/dfb087/32.png) [@did16](https://forums.percona.com/u/did16)\
**Post date:** [August 19, 2025, 11:58am UTC](https://forums.percona.com/t/where-are-percona-distribution-for-postgresql-rpm/39121/8 "2025-08-19T11:58:00Z")

</div>

I have the following error message :

> >

rsync: failed to connect to [rsync.percona.com](http://rsync.percona.com) (49.12.125.205): Connection timed out (110)  
rsync: failed to connect to [rsync.percona.com](http://rsync.percona.com) (2a01:4f8:242:5792::2): Cannot assign requested address (99)  
rsync error: error in socket IO (code 10) at clientserver.c(128) [Receiver=3.1.3]

\<\<

Unfortunately, this is not the solution.
