# What is the correct Percona 8.0.21 tag to replace Percona 8.0.15-6 CentOS

**URL:** <https://forums.percona.com/t/what-is-the-correct-percona-8-0-21-tag-to-replace-percona-8-0-15-6-centos/10630>\
**Category:** Percona Server for MySQL 8.0\
**Tags:** mysql, percona\
**Created:** [May 30, 2021, 12:09pm UTC](https://forums.percona.com/t/what-is-the-correct-percona-8-0-21-tag-to-replace-percona-8-0-15-6-centos/10630 "2021-05-30T12:09:50Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![imriss](https://avatars.discourse-cdn.com/v4/letter/i/eb9ed0/32.png) [@imriss](https://forums.percona.com/u/imriss)\
**Post date:** [May 30, 2021, 12:09pm UTC](https://forums.percona.com/t/what-is-the-correct-percona-8-0-21-tag-to-replace-percona-8-0-15-6-centos/10630/1 "2021-05-30T12:09:50Z")

</div>

Hi,  
In Presslabs Mysql Operator which uses Percona in the backend, I am currently using Percona 8.0.15-6 with the following hash:

`percona@sha256:6bbb0e2830793107bae90569f34e59d4b442b250703b5d4b1e8a8996f61c8f2c`

I would like to upgrade it to 8.0.21.

However, the Mysql container stops with the following error:

```auto
Can't start server: can't create PID file: Permission denied

[ERROR] [MY-013129] [Server] A message intended for a client cannot be sent there as no client-session is attached. Therefore, we're sending the information to the error-log instead: MY-000001 - Can't create/write to file '/var/run/mysqld/mysqld.pid' (OS errno 13 - Permission denied)
[ERROR] [MY-010092] [Server] Can't start server: can't create PID file: Permission denied

```

I have tried both following hashes (that I found on Docker Hub), but the outcome was the same:

`percona/percona-server@sha256:b389bb76e2750e39a28bbf35ad95d438d12eb08b3a1576d0bde2d86773a64e79`

`percona@sha256:e6be2b95cb47d2e8b9d9611f25c898be72da2f47d185da5164f4883632d896c9`

Please let me know what would be the correct tag/hash for Percona 8.0.21.

PS. At the time of testing, I tried 8.0.21. I am also good with any other versions equal or above 8.0.22.

Thanks

---

<div class="post-metadata">

**Author:** ![matthewb](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/matthewb/32/34_2.png) [@matthewb](https://forums.percona.com/u/matthewb)\
**Post date:** [July 6, 2021, 5:55pm UTC](https://forums.percona.com/t/what-is-the-correct-percona-8-0-21-tag-to-replace-percona-8-0-15-6-centos/10630/2 "2021-07-06T17:55:02Z")

</div>

Hello @imriss ,  
I just pulled the latest percona:8  
`sha256:ffd7a2cfedf02d49e812e85383c0dbaf265255adf30a954feaddb4d38d48ddfa`  
and it started without issue.

```
$ docker run -e MYSQL_ROOT_PASSWORD=Percona1234 percona:8
...
2021-07-06T17:46:45.540771Z 0 [System] [MY-010931] [Server] /usr/sbin/mysqld: ready for connections. Version: '8.0.23-14' socket: '/var/lib/mysql/mysql.sock' port: 3306 Percona Server (GPL), Release 14, Revision 3558242.

```

---

<div class="post-metadata">

**Author:** ![imriss](https://avatars.discourse-cdn.com/v4/letter/i/eb9ed0/32.png) [@imriss](https://forums.percona.com/u/imriss)\
**Post date:** [August 9, 2021, 1:03pm UTC](https://forums.percona.com/t/what-is-the-correct-percona-8-0-21-tag-to-replace-percona-8-0-15-6-centos/10630/3 "2021-08-09T13:03:05Z")

</div>

Hello @matthewb , thank you, and sorry I missed your reply.

I agree that the docker image works fine by itself.

For my case, I am using it as part of Presslabs Mysql Operator. It seems that they run the docker image under the “mysql” user, not root. For Percona versions lower or equal to 8.0.19, there is no issues. However, for version higher than 8.0.19, it seems that it needs some kind of root level access, and the deployment under Presslabs Mysql Operator fails.

I would like to see if there is any workarounds. The error message is:

```auto
Can't create/write to file '/var/run/mysqld/mysqld.pid' (OS errno 13 - Permission denied)

```

Thanks

---

<div class="post-metadata">

**Author:** ![matthewb](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/matthewb/32/34_2.png) [@matthewb](https://forums.percona.com/u/matthewb)\
**Post date:** [August 9, 2021, 2:48pm UTC](https://forums.percona.com/t/what-is-the-correct-percona-8-0-21-tag-to-replace-percona-8-0-15-6-centos/10630/4 "2021-08-09T14:48:35Z")

</div>

You would need to have some way to launch the container with appropriate permissions. MySQL is always started as the root user and then is forked to run under the mysql user.

For that particular error, I would change the PID location. Create/edit a mysql config and add the following:

```
[mysql.server]
pid-file=/tmp/mysql.pid

```

See if that helps get around the permissions issue

---

<div class="post-metadata">

**Author:** ![imriss](https://avatars.discourse-cdn.com/v4/letter/i/eb9ed0/32.png) [@imriss](https://forums.percona.com/u/imriss)\
**Post date:** [September 3, 2021, 7:19pm UTC](https://forums.percona.com/t/what-is-the-correct-percona-8-0-21-tag-to-replace-percona-8-0-15-6-centos/10630/5 "2021-09-03T19:19:12Z")

</div>

Hello @matthewb , sorry for the delay.  
The /tmp/mysql.pid suggestion unblocked me. Thanks for the help.
