# \[Warning\] WSREP: last inactive check more than PT1.5S ago, skipping check

**URL:** https://forums.percona.com/t/warning-wsrep-last-inactive-check-more-than-pt1-5s-ago-skipping-check/4325
**Category:** Percona XtraDB Cluster 5.x
**Created:** [July 28, 2015, 3:29am UTC](https://forums.percona.com/t/warning-wsrep-last-inactive-check-more-than-pt1-5s-ago-skipping-check/4325 "2015-07-28T03:29:24Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![uxer](https://avatars.discourse-cdn.com/v4/letter/u/b5ac83/32.png) [@uxer](https://forums.percona.com/u/uxer)
#### Post date: [July 28, 2015, 3:29am UTC](https://forums.percona.com/t/warning-wsrep-last-inactive-check-more-than-pt1-5s-ago-skipping-check/4325/1 "2015-07-28T03:29:24Z")

</div>

I had 3 node galera cluster running on RHEL6.5x64.  
node1 - 10.22.5.8  
node2 - 10.22.5.11  
node3 - 10.22.75.185

Version on all nodes : mysqld Ver 5.5.23 for Linux on x86\_64 (Percona XtraDB Cluster (GPL), wsrep\_23.5.r333)

node1 /etc/my.cnf  
== [MYSQLD]  
user=mysql  
basedir=/usr/  
datadir=/var/lib/mysql  
socket=/var/lib/mysql/mysql.sock  
pid-file=mysqld.pid  
port=3306  
log-error=error.log  
character\_set\_client=utf8  
character\_set\_server=utf8  
innodb-buffer-pool-size=8964M  
innodb-flush-log-at-trx\_commit=2  
innodb-file-per-table=1  
innodb-doublewrite=0  
innodb\_log\_file\_size=256M  
innodb-log-files-in-group=3  
innodb-thread-concurrency=0  
innodb-flush-method = O\_DIRECT  
innodb\_locks\_unsafe\_for\_binlog=1  
innodb\_autoinc\_lock\_mode=2  
engine-condition-pushdown=1  
binlog\_format=ROW  
key\_buffer\_size = 256M  
max-allowed-packet = 128M  
sort-buffer-size = 512K  
read-buffer-size = 256K  
read-rnd-buffer-size = 512K  
myisam-sort-buffer\_size = 8M  
skip-name-resolve  
memlock=0  
sysdate-is-now=1  
max-connections=512  
thread-cache-size=512  
query-cache-type = 0  
query-cache-size = 0  
table-open\_cache=1024  
lower-case-table-names=0  
wsrep\_provider=/usr/lib64/libgalera\_smm.so  
wsrep\_node\_address=10.22.5.8  
wsrep\_provider\_options=“pc.ignore\_sb = yes”  
wsrep\_cluster\_name=“my\_wsrep\_cluster”  
wsrep\_cluster\_address=“gcomm://10.22.75.185”  
wsrep\_node\_name=10.22.5.8  
wsrep\_slave\_threads=1  
wsrep\_certify\_nonPK=1  
wsrep\_debug=0  
wsrep\_convert\_LOCK\_to\_trx=0  
wsrep\_retry\_autocommit=1  
wsrep\_auto\_increment\_control=1  
wsrep\_drupal\_282555\_workaround=1  
wsrep\_causal\_reads=0  
wsrep\_sst\_method=rsync  
wsrep\_sst\_auth=root:passwd  
wsrep\_sst\_donor=10.22.75.185  
[MYSQL]  
socket=/var/lib/mysql/mysql.sock  
[client]  
socket=/var/lib/mysql/mysql.sock  
[MYSQLD\_SAFE]  
pid-file=mysqld.pid  
log-error=error.log  
basedir=/usr/  
datadir=/var/lib/mysql

node2 /etc/my.cnf  
== [MYSQLD]  
user=mysql  
basedir=/usr/  
datadir=/var/lib/mysql  
socket=/var/lib/mysql/mysql.sock  
pid-file=mysqld.pid  
port=3306  
log-error=error.log  
innodb-buffer-pool-size=8964M  
innodb-flush-log-at-trx\_commit=2  
innodb-file-per-table=1  
innodb-doublewrite=0  
innodb\_log\_file\_size=256M  
innodb-log-files-in-group=3  
innodb-thread-concurrency=0  
innodb-flush-method = O\_DIRECT  
innodb\_locks\_unsafe\_for\_binlog=1  
innodb\_autoinc\_lock\_mode=2  
engine-condition-pushdown=1  
binlog\_format=ROW  
key\_buffer\_size = 256M  
max-allowed-packet = 128M  
sort-buffer-size = 512K  
read-buffer-size = 256K  
read-rnd-buffer-size = 512K  
myisam-sort-buffer\_size = 8M  
skip-name-resolve  
memlock=0  
sysdate-is-now=1  
max-connections=512  
thread-cache-size=512  
query-cache-type = 0  
query-cache-size = 0  
table-open\_cache=1024  
lower-case-table-names=0  
wsrep\_provider=/usr/lib64/libgalera\_smm.so  
wsrep\_node\_address=10.22.5.11  
wsrep\_cluster\_name=“my\_wsrep\_cluster”  
wsrep\_cluster\_address=“gcomm://10.22.75.185”  
wsrep\_node\_name=10.22.5.11  
wsrep\_slave\_threads=1  
wsrep\_certify\_nonPK=1  
wsrep\_debug=0  
wsrep\_convert\_LOCK\_to\_trx=0  
wsrep\_retry\_autocommit=1  
wsrep\_auto\_increment\_control=1  
wsrep\_drupal\_282555\_workaround=1  
wsrep\_causal\_reads=0  
wsrep\_sst\_method=rsync  
wsrep\_sst\_receive\_address=10.22.5.11  
wsrep\_sst\_auth=root:passwd  
wsrep\_sst\_donor=10.22.75.185  
[MYSQL]  
socket=/var/lib/mysql/mysql.sock  
[client]  
socket=/var/lib/mysql/mysql.sock  
[MYSQLD\_SAFE]  
pid-file=mysqld.pid  
log-error=error.log  
basedir=/usr/  
datadir=/var/lib/mysql

node3 /etc/my.cnf  
== [MYSQLD]  
user=mysql  
basedir=/usr/  
datadir=/var/lib/mysql  
socket=/var/lib/mysql/mysql.sock  
pid-file=mysqld.pid  
port=3306  
log-error=error.log  
innodb-buffer-pool-size=8964M  
innodb-flush-log-at-trx\_commit=2  
innodb-file-per-table=1  
innodb-doublewrite=0  
innodb\_log\_file\_size=256M  
innodb-log-files-in-group=3  
innodb-thread-concurrency=0  
innodb-flush-method = O\_DIRECT  
innodb\_locks\_unsafe\_for\_binlog=1  
innodb\_autoinc\_lock\_mode=2  
engine-condition-pushdown=1  
binlog\_format=ROW  
key\_buffer\_size = 256M  
max-allowed-packet = 16M  
sort-buffer-size = 512K  
read-buffer-size = 256K  
read-rnd-buffer-size = 512K  
myisam-sort-buffer\_size = 8M  
skip-name-resolve  
memlock=0  
sysdate-is-now=1  
max-connections=512  
thread-cache-size=512  
query-cache-type = 0  
query-cache-size = 0  
table-open\_cache=1024  
lower-case-table-names=0  
wsrep\_provider=/usr/lib64/libgalera\_smm.so  
wsrep\_node\_address=10.22.75.185  
wsrep\_cluster\_address=“gcomm://10.22.5.11”  
wsrep\_node\_name=10.22.75.185  
wsrep\_slave\_threads=1  
wsrep\_certify\_nonPK=1  
wsrep\_debug=0  
wsrep\_convert\_LOCK\_to\_trx=0  
wsrep\_retry\_autocommit=1  
wsrep\_auto\_increment\_control=1  
wsrep\_drupal\_282555\_workaround=1  
wsrep\_causal\_reads=0  
wsrep\_sst\_method=rsync  
wsrep\_sst\_auth=root:passwd  
wsrep\_sst\_donor=10.22.5.11  
[MYSQL]  
socket=/var/lib/mysql/mysql.sock  
[client]  
socket=/var/lib/mysql/mysql.sock  
[MYSQLD\_SAFE]  
pid-file=mysqld.pid  
log-error=error.log  
basedir=/usr/  
datadir=/var/lib/mysql

I shutdown entire cluster because I had to decrease amount of ‘innodb-buffer-pool-size’ because mysqld was using to much SWAP space.  
After changing this from most advanced node which was node1 I’ve boostrapped the cluster with below command  
service mysql start --wsrep\_cluster\_address=“gcomm://”

Now cluster size is 1 and I can’t join other nodes (node2, node3) to the cluster, please observer below output from error.log of node2 during ‘service mysql start’ process.

/var/lib/mysql/error.log  
== 150728 10:34:14 mysqld\_safe Starting mysqld daemon with databases from /var/lib/mysql  
150728 10:34:14 [Note] Flashcache bypass: disabled  
150728 10:34:14 [Note] Flashcache setup error is : ioctl failed  
150728 10:34:14 [Note] WSREP: Read nil XID from storage engines, skipping position init  
150728 10:34:14 [Note] WSREP: wsrep\_load(): loading provider library ‘/usr/lib64/libgalera\_smm.so’  
150728 10:34:14 [Note] WSREP: wsrep\_load(): Galera 2.1dev(r109) by Codership Oy \<info@codership.com\> loaded succesfully.  
150728 10:34:14 [Note] WSREP: Reusing existing ‘/var/lib/mysql//galera.cache’.  
150728 10:34:14 [Note] WSREP: Passing config to GCS: base\_host = 10.22.5.11; gcache.dir = /var/lib/mysql/; gcache.keep\_pages\_size = 0; gcache.mem\_size = 0; gcache.name = /var/lib/mysql//galera.cache; gcache.page\_size = 128M; gcache.size = 128M; gcs.fc\_debug = 0; gcs.fc\_factor = 0.5; gcs.fc\_limit = 16; gcs.fc\_master\_slave = NO; gcs.max\_packet\_size = 64500; gcs.max\_throttle = 0.25; gcs.recv\_q\_hard\_limit = 9223372036854775807; gcs.recv\_q\_soft\_limit = 0.25; replicator.causal\_read\_timeout = PT30S; replicator.commit\_order = 3  
150728 10:34:14 [Note] WSREP: wsrep\_sst\_grab()  
150728 10:34:14 [Note] WSREP: Start replication  
150728 10:34:14 [Note] WSREP: Found saved state: 9ba720b3-8d53-11e1-0800-52407463bac7:304911180  
150728 10:34:14 [Note] WSREP: Assign initial position for certification: 304911180, protocol version: -1  
150728 10:34:14 [Note] WSREP: Setting initial position to 9ba720b3-8d53-11e1-0800-52407463bac7:304911180  
150728 10:34:14 [Note] WSREP: protonet asio version 0  
150728 10:34:14 [Note] WSREP: backend: asio  
150728 10:34:14 [Note] WSREP: GMCast version 0  
150728 10:34:14 [Note] WSREP: (6da55788-3503-11e5-0800-0de34d03910b, ‘tcp://0.0.0.0:4567’) listening at tcp://0.0.0.0:4567  
150728 10:34:14 [Note] WSREP: (6da55788-3503-11e5-0800-0de34d03910b, ‘tcp://0.0.0.0:4567’) multicast: , ttl: 1  
150728 10:34:14 [Note] WSREP: EVS version 0  
150728 10:34:14 [Note] WSREP: PC version 0  
150728 10:34:14 [Note] WSREP: gcomm: connecting to group ‘my\_wsrep\_cluster’, peer ‘10.22.75.185:’  
150728 10:34:17 [Warning] WSREP: no nodes coming from prim view, prim not possible  
150728 10:34:17 [Note] WSREP: view(view\_id(NON\_PRIM,6da55788-3503-11e5-0800-0de34d03910b,1) memb {  
6da55788-3503-11e5-0800-0de34d03910b,  
} joined {  
} left {  
} partitioned {  
})  
150728 10:34:17 [Note] WSREP: gcomm: connected  
150728 10:34:17 [Note] WSREP: Changing maximum packet size to 64500, resulting msg size: 32636  
150728 10:34:17 [Note] WSREP: Shifting CLOSED → OPEN (TO: 0)  
150728 10:34:17 [Note] WSREP: Opened channel ‘my\_wsrep\_cluster’  
150728 10:34:17 [Note] WSREP: New COMPONENT: primary = no, bootstrap = no, my\_idx = 0, memb\_num = 1  
150728 10:34:17 [Note] WSREP: Waiting for SST to complete.  
150728 10:34:17 [Note] WSREP: Flow-control interval: [8, 16]  
150728 10:34:17 [Note] WSREP: Received NON-PRIMARY.  
150728 10:34:17 [Note] WSREP: New cluster view: global state: 9ba720b3-8d53-11e1-0800-52407463bac7:304911180, view# -1: non-Primary, number of nodes: 1, my index: 0, protocol version -1  
150728 10:34:17 [Note] WSREP: wsrep\_notify\_cmd is not defined, skipping notification.  
150728 10:34:18 [Warning] WSREP: last inactive check more than PT1.5S ago, skipping check

---

<div class="post-metadata">

### Author: ![jrivera](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/jrivera/32/13_2.png) [@jrivera](https://forums.percona.com/u/jrivera)
#### Post date: [July 28, 2015, 10:08pm UTC](https://forums.percona.com/t/warning-wsrep-last-inactive-check-more-than-pt1-5s-ago-skipping-check/4325/2 "2015-07-28T22:08:28Z")

</div>

Can you paste SHOW STATUS LIKE ‘wsrep%’; from node1 and also attach error log from node1?
