# Upgrade-path from mysql-community-57 to Percona, rpm dependency error

**URL:** <https://forums.percona.com/t/upgrade-path-from-mysql-community-57-to-percona-rpm-dependency-error/5535>\
**Category:** Percona Server for MySQL 5.7\
**Created:** [April 10, 2017, 6:29am UTC](https://forums.percona.com/t/upgrade-path-from-mysql-community-57-to-percona-rpm-dependency-error/5535 "2017-04-10T06:29:48Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![tomsommer](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/tomsommer/32/1164_2.png) [@tomsommer](https://forums.percona.com/u/tomsommer)\
**Post date:** [April 10, 2017, 6:29am UTC](https://forums.percona.com/t/upgrade-path-from-mysql-community-57-to-percona-rpm-dependency-error/5535/1 "2017-04-10T06:29:48Z")

</div>

Should it not be possible to directly switch from MySQL-Community release to Percona?

See attached

Ultimately the problem is that Percona-Server-shared-57-5.7.17-13.1.el6.x86\_64 does not correctly replace mysql-community-libs-5.7.17-1.el6.x86\_64

```auto

file /usr/lib64/mysql/libmysqlclient.so.20.3.4 from install of Percona-Server-shared-57-5.7.17-13.1.el6.x86_64 conflicts with file from package mysql-community-libs-5.7.17-1.el6.x86_64

```

If I remove mysql-community-libs-5.7.17-1.el6.x86\_64 with --nodeps then Percona installs correctly (with Percona-Server-shared-compat)

[yum.txt](https://forums.percona.com/uploads/short-url/33fDeAA8nB8WevBvjYGdVvLqwoe.txt) (19.2 KB)

---

<div class="post-metadata">

**Author:** ![Michael\_Coburn](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/michael_coburn/32/18_2.png) [@Michael\_Coburn](https://forums.percona.com/u/Michael_Coburn)\
**Post date:** [April 10, 2017, 8:53am UTC](https://forums.percona.com/t/upgrade-path-from-mysql-community-57-to-percona-rpm-dependency-error/5535/2 "2017-04-10T08:53:52Z")

</div>

Hi [tomsommer](https://percona.vanillacommunities.com/profile/x/x/36386) , thanks for bringing this to our attention. We believe it is a legitimate bug, I’ve filed a JIRA to have it fixed in a later release. For now your workaround is the correct approach to mitigate the upgrade to Percona Server 5.7.17-13. All the best,

[url][Log in - Percona JIRA](https://jira.percona.com/browse/BLD-698%5B/url%5D)

---

<div class="post-metadata">

**Author:** ![DBennett](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/dbennett/32/17_2.png) [@DBennett](https://forums.percona.com/u/DBennett)\
**Post date:** [April 10, 2017, 11:38am UTC](https://forums.percona.com/t/upgrade-path-from-mysql-community-57-to-percona-rpm-dependency-error/5535/3 "2017-04-10T11:38:02Z")

</div>

Hi [tomsommer](https://percona.vanillacommunities.com/profile/x/x/36386),

The MySQL Community 5.7 packages need to be removed prior to installation of the Percona Server 5.7 packages. This is required since the packages cannot both be installed simultaneously. This is mentioned here:

[https://www.percona.com/doc/percona-](https://www.percona.com/doc/percona-)…-distributions

“Note that this procedure is the same for upgrading from MySQL 5.6 or 5.7 to Percona Server 5.7 …”

However, I believe this could be more prominent. I am discussing this with our documentation team to make this more clear.

–Dave

---

<div class="post-metadata">

**Author:** ![tomsommer](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/tomsommer/32/1164_2.png) [@tomsommer](https://forums.percona.com/u/tomsommer)\
**Post date:** [April 12, 2017, 1:36am UTC](https://forums.percona.com/t/upgrade-path-from-mysql-community-57-to-percona-rpm-dependency-error/5535/4 "2017-04-12T01:36:15Z")

</div>

[DBennett](https://percona.vanillacommunities.com/profile/x/x/22487) I completely missed that, a section about how to switch from MySQL Community Server would be very relevant, IMO.The section is currently about upgrading, which when you are installing does not seem relevant.
