# Unknows thread - ha\_myisam.cc:873

**URL:** https://forums.percona.com/t/unknows-thread-ha-myisam-cc-873/1852
**Category:** Other MySQL® Questions
**Created:** [July 31, 2012, 2:56am UTC](https://forums.percona.com/t/unknows-thread-ha-myisam-cc-873/1852 "2012-07-31T02:56:50Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![kjain84](https://avatars.discourse-cdn.com/v4/letter/k/779978/32.png) [@kjain84](https://forums.percona.com/u/kjain84)
#### Post date: [July 31, 2012, 2:56am UTC](https://forums.percona.com/t/unknows-thread-ha-myisam-cc-873/1852/1 "2012-07-31T02:56:50Z")

</div>

Got this error when restarted MySQL.  
[ERROR] Got an error from unknown thread, /home/buildbot/src/work/BUILD/Percona-Server-5.5.19-rel24.0/ Percona-Server-5.5.19-rel24.0/storage/myisam/ha\_myisam.cc:87 3

---

<div class="post-metadata">

### Author: ![niljoshi](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/niljoshi/32/16889_2.png) [@niljoshi](https://forums.percona.com/u/niljoshi)
#### Post date: [August 7, 2012, 2:35am UTC](https://forums.percona.com/t/unknows-thread-ha-myisam-cc-873/1852/2 "2012-08-07T02:35:13Z")

</div>

Hi,

Can you paste here the exact output of error log when you are starting MySQL?  
When you are getting this error? After installations, first time start? or MySQL was already running properly and just a schedule restart cause this error?

Please provide some more information. It would be helpful to troubleshoot this issue. Thanks.

---

<div class="post-metadata">

### Author: ![kjain84](https://avatars.discourse-cdn.com/v4/letter/k/779978/32.png) [@kjain84](https://forums.percona.com/u/kjain84)
#### Post date: [August 7, 2012, 2:56am UTC](https://forums.percona.com/t/unknows-thread-ha-myisam-cc-873/1852/3 "2012-08-07T02:56:33Z")

</div>

Please find the details below -

120727 20:40:38 mysqld\_safe Number of processes running now: 0  
120727 20:40:38 mysqld\_safe mysqld restarted  
120727 20:40:38 [Note] Flashcache bypass: disabled  
120727 20:40:38 [Note] Flashcache setup error is : ioctl failed

120727 20:40:39 [Note] Plugin ‘FEDERATED’ is disabled.  
120727 20:40:39 InnoDB: The InnoDB memory heap is disabled  
120727 20:40:39 InnoDB: Mutexes and rw\_locks use GCC atomic builtins  
120727 20:40:39 InnoDB: Compressed tables use zlib 1.2.3  
120727 20:40:39 InnoDB: Using Linux native AIO  
120727 20:40:39 InnoDB: Initializing buffer pool, size = 8.0G  
120727 20:40:40 InnoDB: Completed initialization of buffer pool  
120727 20:40:40 InnoDB: highest supported file format is Barracuda.  
InnoDB: The log sequence number in ibdata files does not match  
InnoDB: the log sequence number in the ib\_logfiles!  
120727 20:40:40 InnoDB: Database was not shut down normally!  
InnoDB: Starting crash recovery.  
InnoDB: Reading tablespace information from the .ibd files…  
InnoDB: Restoring possible half-written data pages from the doublewrite  
InnoDB: buffer…  
InnoDB: Last MySQL binlog file position 0 783116746, file name /var/log/mysql/db1.000008  
120727 20:40:44 InnoDB: Waiting for the background threads to start  
120727 20:40:45 Percona XtraDB ([http://www.percona.com](http://www.percona.com)) 1.1.8-rel24.0 started; log sequence number 10213583561  
120727 20:40:45 [Note] Recovering after a crash using /var/log/mysql/db1  
120727 20:41:07 [Note] Starting crash recovery…  
120727 20:41:07 [Note] Crash recovery finished.  
120727 20:41:08 [Note] Event Scheduler: Loaded 0 events  
120727 20:41:08 [Note] /usr/sbin/mysqld: ready for connections.  
Version: ‘5.5.19-55-log’ socket: ‘/var/lib/mysql/mysql.sock’ port: 3306 Percona Server (GPL), Release rel24.0, Revision 204  
120727 20:41:08 [Note] Event Scheduler: scheduler thread started with id 1
