# Unable to upgrade from Percona-XtraDB-Cluster 5.6 to 5.7

**URL:** <https://forums.percona.com/t/unable-to-upgrade-from-percona-xtradb-cluster-5-6-to-5-7/19806>\
**Category:** Percona XtraDB Cluster 5.x\
**Created:** [January 28, 2023, 9:34am UTC](https://forums.percona.com/t/unable-to-upgrade-from-percona-xtradb-cluster-5-6-to-5-7/19806 "2023-01-28T09:34:35Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![pravingrane](https://avatars.discourse-cdn.com/v4/letter/p/5f8ce5/32.png) [@pravingrane](https://forums.percona.com/u/pravingrane)\
**Post date:** [January 28, 2023, 9:34am UTC](https://forums.percona.com/t/unable-to-upgrade-from-percona-xtradb-cluster-5-6-to-5-7/19806/1 "2023-01-28T09:34:36Z")

</div>

I am having currently running 3 nodes Percona cluster

Number of nodes : 3  
Operating System: CentOS 6.10  
RPMs:  
Percona-XtraDB-Cluster-galera-3-3.46-1.el6.x86\_64  
percona-xtrabackup-2.3.10-1.el6.x86\_64  
percona-toolkit-2.2.20-1.noarch  
Percona-XtraDB-Cluster-shared-56-5.6.51-28.46.1.el6.x86\_64  
Percona-XtraDB-Cluster-client-56-5.6.51-28.46.1.el6.x86\_64  
Percona-XtraDB-Cluster-56-5.6.51-28.46.1.el6.x86\_64  
Percona-Server-shared-compat-5.1.68-rel14.6.551.rhel6.x86\_64  
Percona-XtraDB-Cluster-server-56-5.6.51-28.46.1.el6.x86\_64

I am currently trying in place upgrade from version 5.6 to 5.7 as per the procedure defined here.

> **[Percona Software Documentation](https://docs.percona.com/percona-xtradb-cluster/5.7/howtos/upgrade_guide.html)**
>
> .container-box-download { justify-content: flex-start; } .container-button-learn-more { margin-bottom: 10px; } .logo-server-home { background: url(/img/product-logos/sprite.png)

I am getting error in final step. when I start mysql after mysql-upgrade I see below errors in log.  
I treid upgrade process on another node but same were the results.  
--------- Log start-------  
2023-01-28T09:01:26.960195Z 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit\_defaults\_for\_timestamp server option (see documentation for more details).  
2023-01-28T09:01:26.960307Z 0 [Warning] ‘NO\_AUTO\_CREATE\_USER’ sql mode was not set.  
2023-01-28T09:01:26.963820Z 0 [Note] /usr/sbin/mysqld (mysqld 5.7.36-39-57-log) starting as process 7796 …  
2023-01-28T09:01:28.481510Z 0 [Note] WSREP: Setting wsrep\_ready to false  
2023-01-28T09:01:28.481547Z 0 [Note] WSREP: No pre-stored wsrep-start position found. Skipping position initialization.  
2023-01-28T09:01:28.481566Z 0 [Note] WSREP: wsrep\_load(): loading provider library ‘/usr/lib64/libgalera\_smm.so’  
2023-01-28T09:01:28.544447Z 0 [Note] WSREP: wsrep\_load(): Galera 3.55(r8b6416d) by Codership Oy [info@codership.com](mailto:info@codership.com) loaded successfully.  
2023-01-28T09:01:28.545672Z 0 [Note] WSREP: CRC-32C: using 64-bit x86 acceleration.  
2023-01-28T09:01:28.554099Z 0 [Note] WSREP: Found saved state: 5f19668b-6ebd-11ec-a091-bbe5ff26e53d:419124785, safe\_to\_bootstrap: 0  
2023-01-28T09:01:28.559759Z 0 [Note] WSREP: Passing config to GCS: base\_dir = /var/lib/mysql/data/; base\_host = 172.16.205.31; base\_port = 4567; cert.log\_conflicts = no; cert.optimistic\_pa = yes; debug = no; evs.auto\_evict = 0; evs.delay\_margin = PT1S; evs.delayed\_keep\_period  
= PT30S; evs.inactive\_check\_period = PT0.5S; evs.inactive\_timeout = PT15S; evs.join\_retrans\_period = PT1S; evs.max\_install\_timeouts = 3; evs.send\_window = 10; evs.stats\_report\_period = PT1M; evs.suspect\_timeout = PT5S; evs.user\_send\_window = 4; evs.view\_forget\_timeout = PT24H;  
gcache.dir = /var/lib/mysql/data/; gcache.freeze\_purge\_at\_seqno = -1; gcache.keep\_pages\_count = 0; gcache.keep\_pages\_size = 0; gcache.mem\_size = 0; gcache.name = /var/lib/mysql/data//galera.cache; gcache.page\_size = 256M; gcache.recover = no; gcache.size = 2G; gcomm.thread\_pr  
io = ; gcs.fc\_debug = 0; gcs.fc\_factor = 1; gcs.fc\_limit = 100; gcs.fc\_master\_slave = no; gcs.max\_packet\_size = 64500; gcs.max\_throttle = 0.25; gcs.recv\_q\_hard\_limit = 9223372036854775807; gcs.recv\_q\_soft\_limit = 0.25; gcs.sync\_donor = no; gmcast.segment = 0; gmcast.version =  
0; pc.announce\_timeout = PT3S; pc.checksum = false; pc.ignore\_quorum = false; pc.ignore\_sb = false; pc.npvo = false; pc.recovery = true; pc.version = 0; pc.wait\_prim = true; pc.wait\_prim\_timeout = PT30S; pc.weight = 1; protonet.backend = asio; protonet.version = 0; repl.causal  
\_read\_timeout = PT30S; repl.commit\_order = 3; repl.key\_format = FLAT8; repl.max\_ws\_size = 2147483647; repl.proto\_max = 9; socket.checksum = 2; socket.recv\_buf\_size = auto; socket.send\_buf\_size = auto;  
2023-01-28T09:01:28.575838Z 0 [Note] WSREP: GCache history reset: 5f19668b-6ebd-11ec-a091-bbe5ff26e53d:0 → 5f19668b-6ebd-11ec-a091-bbe5ff26e53d:419124785  
2023-01-28T09:01:28.576730Z 0 [Note] WSREP: Assign initial position for certification: 419124785, protocol version: -1  
2023-01-28T09:01:28.576776Z 0 [Note] WSREP: Preparing to initiate SST/IST  
2023-01-28T09:01:28.576794Z 0 [Note] WSREP: Starting replication  
2023-01-28T09:01:28.576827Z 0 [Note] WSREP: Setting initial position to 5f19668b-6ebd-11ec-a091-bbe5ff26e53d:419124785  
2023-01-28T09:01:28.588538Z 0 [Note] WSREP: Using CRC-32C for message checksums.  
2023-01-28T09:01:28.588695Z 0 [Note] WSREP: gcomm thread scheduling priority set to other:0  
2023-01-28T09:01:28.590400Z 0 [Warning] WSREP: Fail to access the file (/var/lib/mysql/data//gvwstate.dat) error (No such file or directory). It is possible if node is booting for first time or re-booting after a graceful shutdown  
2023-01-28T09:01:28.590428Z 0 [Note] WSREP: Restoring primary-component from disk failed. Either node is booting for first time or re-booting after a graceful shutdown  
2023-01-28T09:01:28.591283Z 0 [Note] WSREP: GMCast version 0  
2023-01-28T09:01:28.591593Z 0 [Note] WSREP: (59e27d70, ‘tcp://0.0.0.0:4567’) listening at tcp://0.0.0.0:4567  
2023-01-28T09:01:28.591618Z 0 [Note] WSREP: (59e27d70, ‘tcp://0.0.0.0:4567’) multicast: , ttl: 1  
2023-01-28T09:01:28.594761Z 0 [Note] WSREP: EVS version 0  
2023-01-28T09:01:28.594935Z 0 [Note] WSREP: gcomm: connecting to group ‘SITE1-MYSQL’, peer ‘172.16.205.29:,172.16.205.31:,172.16.205.34:’  
2023-01-28T09:01:28.597413Z 0 [Note] WSREP: (59e27d70, ‘tcp://0.0.0.0:4567’) Found matching local endpoint for a connection, blacklisting address tcp://172.16.205.31:4567  
2023-01-28T09:01:28.598353Z 0 [Note] WSREP: (59e27d70, ‘tcp://0.0.0.0:4567’) connection established to 2231b235 tcp://172.16.205.29:4567  
2023-01-28T09:01:28.598593Z 0 [Note] WSREP: (59e27d70, ‘tcp://0.0.0.0:4567’) turning message relay requesting on, nonlive peers:  
2023-01-28T09:01:28.598714Z 0 [Note] WSREP: (59e27d70, ‘tcp://0.0.0.0:4567’) connection established to df905242 tcp://172.16.205.34:4567  
2023-01-28T09:01:29.098296Z 0 [Note] WSREP: declaring 2231b235 at tcp://172.16.205.29:4567 stable  
2023-01-28T09:01:29.098339Z 0 [Note] WSREP: declaring df905242 at tcp://172.16.205.34:4567 stable  
2023-01-28T09:01:29.098959Z 0 [Note] WSREP: Node 2231b235 state primary  
2023-01-28T09:01:29.099464Z 0 [Note] WSREP: Current view of cluster as seen by this node  
view (view\_id(PRIM,2231b235,543)  
memb {  
2231b235,0  
59e27d70,0  
df905242,0  
}  
joined {  
}  
left {  
}  
partitioned {  
}  
)  
2023-01-28T09:01:29.099496Z 0 [Note] WSREP: Save the discovered primary-component to disk  
2023-01-28T09:01:29.596774Z 0 [Note] WSREP: gcomm: connected  
2023-01-28T09:01:29.597041Z 0 [Note] WSREP: Shifting CLOSED → OPEN (TO: 0)  
2023-01-28T09:01:29.597247Z 0 [Note] WSREP: New COMPONENT: primary = yes, bootstrap = no, my\_idx = 1, memb\_num = 3  
2023-01-28T09:01:29.597329Z 0 [Note] WSREP: Waiting for SST/IST to complete.  
2023-01-28T09:01:29.597362Z 0 [Note] WSREP: STATE EXCHANGE: Waiting for state UUID.  
2023-01-28T09:01:29.597529Z 0 [Note] WSREP: STATE EXCHANGE: sent state msg: 5a31661b-9eea-11ed-9ffb-936f108c9218  
2023-01-28T09:01:29.597556Z 0 [Note] WSREP: STATE EXCHANGE: got state msg: 5a31661b-9eea-11ed-9ffb-936f108c9218 from 0 (SITE1-MYSQL-3.tnc.mydomain.cc)  
2023-01-28T09:01:29.597572Z 0 [Note] WSREP: STATE EXCHANGE: got state msg: 5a31661b-9eea-11ed-9ffb-936f108c9218 from 2 (SITE1-MYSQL-5.tnc.mydomain.cc)  
2023-01-28T09:01:29.598281Z 0 [Note] WSREP: STATE EXCHANGE: got state msg: 5a31661b-9eea-11ed-9ffb-936f108c9218 from 1 (SITE1-MYSQL-4.tnc.mydomain.cc)  
2023-01-28T09:01:29.598301Z 0 [Note] WSREP: Quorum results:  
version = 6,  
component = PRIMARY,  
conf\_id = 321,  
members = 2/3 (primary/total),  
act\_id = 419162852,  
last\_appl. = -1,  
protocols = 0/9/3 (gcs/repl/appl),  
group UUID = 5f19668b-6ebd-11ec-a091-bbe5ff26e53d  
2023-01-28T09:01:29.598320Z 0 [Note] WSREP: Flow-control interval: [173, 173]  
2023-01-28T09:01:29.598336Z 0 [Note] WSREP: Shifting OPEN → PRIMARY (TO: 419162852)  
2023-01-28T09:01:29.598465Z 2 [Note] WSREP: State transfer required:  
Group state: 5f19668b-6ebd-11ec-a091-bbe5ff26e53d:419162852  
Local state: 5f19668b-6ebd-11ec-a091-bbe5ff26e53d:419124785  
2023-01-28T09:01:29.598533Z 2 [Note] WSREP: REPL Protocols: 9 (4, 2)  
2023-01-28T09:01:29.598556Z 2 [Note] WSREP: REPL Protocols: 9 (4, 2)  
2023-01-28T09:01:29.598589Z 2 [Note] WSREP: New cluster view: global state: 5f19668b-6ebd-11ec-a091-bbe5ff26e53d:419162852, view# 322: Primary, number of nodes: 3, my index: 1, protocol version 3  
2023-01-28T09:01:29.598607Z 2 [Note] WSREP: Setting wsrep\_ready to true  
2023-01-28T09:01:29.598624Z 2 [Warning] WSREP: Gap in state sequence. Need state transfer.  
2023-01-28T09:01:29.598651Z 2 [Note] WSREP: Setting wsrep\_ready to false  
2023-01-28T09:01:29.598874Z 0 [Note] WSREP: Initiating SST/IST transfer on JOINER side (wsrep\_sst\_xtrabackup-v2 --role ‘joiner’ --address ‘172.16.205.31’ --datadir ‘/var/lib/mysql/data/’ --defaults-file ‘/etc/my.cnf’ --defaults-group-suffix ‘’ --parent ‘7796’ --mysqld-version ‘5.7.36-39-57’ --binlog ‘/var/lib/mysql/bin/bin’ )  
2023-01-28T09:01:30.613809Z WSREP\_SST: [INFO] Streaming with xbstream  
2023-01-28T09:01:31.287303Z 2 [Note] WSREP: Prepared SST/IST request: xtrabackup-v2|172.16.205.31:4444/xtrabackup\_sst//1  
2023-01-28T09:01:31.287336Z 2 [Note] WSREP: Auto Increment Offset/Increment re-align with cluster membership change (Offset: 1 → 2) (Increment: 1 → 3)  
2023-01-28T09:01:31.287360Z 2 [Note] WSREP: wsrep\_notify\_cmd is not defined, skipping notification.  
2023-01-28T09:01:31.287397Z 2 [Note] WSREP: Assign initial position for certification: 419162852, protocol version: 4  
2023-01-28T09:01:31.287500Z 0 [Note] WSREP: Service thread queue flushed.  
2023-01-28T09:01:31.287595Z 2 [Note] WSREP: Check if state gap can be serviced using IST  
2023-01-28T09:01:31.287801Z 2 [Note] WSREP: IST receiver addr using tcp://172.16.205.31:4568  
2023-01-28T09:01:31.288444Z 2 [Note] WSREP: Prepared IST receiver, listening at: tcp://172.16.205.31:4568  
2023-01-28T09:01:31.288501Z 2 [Note] WSREP: State gap can be likely serviced using IST. SST request though present would be void.  
2023-01-28T09:01:31.290071Z 0 [Note] WSREP: Member 1.0 (SITE1-MYSQL-4.tnc.mydomain.cc) requested state transfer from ‘_any_’. Selected 2.0 (SITE1-MYSQL-5.tnc.mydomain.cc)(SYNCED) as donor.  
2023-01-28T09:01:31.290105Z 0 [Note] WSREP: Shifting PRIMARY → JOINER (TO: 419162860)  
2023-01-28T09:01:31.290165Z 2 [Note] WSREP: Requesting state transfer: success, donor: 2  
2023-01-28T09:01:31.290199Z 2 [Note] WSREP: GCache history reset: 5f19668b-6ebd-11ec-a091-bbe5ff26e53d:0 → 5f19668b-6ebd-11ec-a091-bbe5ff26e53d:419162852  
2023-01-28T09:01:31.686103Z 0 [Note] WSREP: 2.0 (SITE1-MYSQL-5.tnc.mydomain.cc): State transfer to 1.0 (SITE1-MYSQL-4.tnc.mydomain.cc) complete.  
2023-01-28T09:01:31.686590Z 0 [Note] WSREP: Member 2.0 (SITE1-MYSQL-5.tnc.mydomain.cc) synced with group.  
2023-01-28T09:01:31.766275Z WSREP\_SST: [INFO] xtrabackup\_ist received from donor: Running IST  
2023-01-28T09:01:31.772165Z WSREP\_SST: [INFO] Galera co-ords from recovery: 5f19668b-6ebd-11ec-a091-bbe5ff26e53d:419124785  
2023-01-28T09:01:31.824147Z 0 [Note] WSREP: SST complete, seqno: 419124785  
2023-01-28T09:01:31.827656Z 0 [Note] InnoDB: PUNCH HOLE support available  
2023-01-28T09:01:31.827718Z 0 [Note] InnoDB: Mutexes and rw\_locks use GCC atomic builtins  
2023-01-28T09:01:31.827745Z 0 [Note] InnoDB: Uses event mutexes  
2023-01-28T09:01:31.827766Z 0 [Note] InnoDB: GCC builtin \_\_atomic\_thread\_fence() is used for memory barrier  
2023-01-28T09:01:31.827788Z 0 [Note] InnoDB: Compressed tables use zlib 1.2.3  
2023-01-28T09:01:31.827810Z 0 [Note] InnoDB: Using Linux native AIO  
2023-01-28T09:01:31.829247Z 0 [Note] InnoDB: Number of pools: 1  
2023-01-28T09:01:31.829571Z 0 [Note] InnoDB: Using CPU crc32 instructions  
2023-01-28T09:01:31.834981Z 0 [Note] InnoDB: Initializing buffer pool, total size = 42G, instances = 16, chunk size = 128M  
2023-01-28T09:01:32.097270Z 0 [Note] WSREP: (59e27d70, ‘tcp://0.0.0.0:4567’) turning message relay requesting off  
2023-01-28T09:01:33.323292Z 0 [Note] InnoDB: Completed initialization of buffer pool  
2023-01-28T09:01:36.278818Z 0 [Note] InnoDB: If the mysqld execution user is authorized, page cleaner thread priority can be changed. See the man page of setpriority().  
2023-01-28T09:01:36.347110Z 0 [Note] InnoDB: Recovering partial pages from the parallel doublewrite buffer at /var/lib/mysql/data/xb\_doublewrite  
2023-01-28T09:01:36.977359Z 0 [Note] InnoDB: Opened 5 undo tablespaces  
2023-01-28T09:01:36.977413Z 0 [Note] InnoDB: 5 undo tablespaces made active  
2023-01-28T09:01:36.977725Z 0 [Note] InnoDB: Highest supported file format is Barracuda.  
2023-01-28T09:01:37.157712Z 0 [Note] InnoDB: Log scan progressed past the checkpoint lsn 7671537132046  
2023-01-28T09:01:37.157777Z 0 [Note] InnoDB: Doing recovery: scanned up to log sequence number 7671537132055  
2023-01-28T09:01:37.157794Z 0 [Note] InnoDB: Database was not shutdown normally!  
2023-01-28T09:01:37.157808Z 0 [Note] InnoDB: Starting crash recovery.  
2023-01-28T09:01:37.433016Z 0 [Note] InnoDB: Created parallel doublewrite buffer at /var/lib/mysql/data/xb\_doublewrite, size 62914560 bytes  
2023-01-28T09:01:38.955040Z 0 [Note] InnoDB: Last MySQL binlog file position 0 4468567, file name bin.018336  
2023-01-28T09:01:55.081547Z 0 [Note] InnoDB: Successfully reset 19 pre-5.7.2 rseg slots.  
2023-01-28T09:01:55.081772Z 0 [Note] InnoDB: Removed temporary tablespace data file: “ibtmp1”  
2023-01-28T09:01:55.081796Z 0 [Note] InnoDB: Creating shared tablespace for temporary tables  
2023-01-28T09:01:55.082015Z 0 [Note] InnoDB: Setting file ‘./ibtmp1’ size to 12 MB. Physically writing the file full; Please wait …  
2023-01-28T09:01:55.111772Z 0 [Note] InnoDB: File ‘./ibtmp1’ size is now 12 MB.  
2023-01-28T09:01:55.112248Z 0 [Warning] InnoDB: The parameter innodb\_undo\_logs is deprecated and may be removed in future releases. Please use innodb\_rollback\_segments instead. See [http://dev.mysql.com/doc/refman/5.7/en/innodb-undo-logs.html](http://dev.mysql.com/doc/refman/5.7/en/innodb-undo-logs.html)  
2023-01-28T09:01:55.113038Z 0 [Note] InnoDB: 1 redo rollback segment(s) found. 1 redo rollback segment(s) are active.  
2023-01-28T09:01:55.113062Z 0 [Note] InnoDB: 32 non-redo rollback segment(s) are active.  
2023-01-28T09:01:55.113242Z 0 [Note] InnoDB: page\_cleaner: 1000ms intended loop took 18834ms. The settings might not be optimal. (flushed=0, during the time.)  
2023-01-28T09:01:55.119349Z 0 [Note] InnoDB: Percona XtraDB ([http://www.percona.com](http://www.percona.com)) 5.7.36-39 started; log sequence number 7671537132055  
2023-01-28T09:01:55.119598Z 0 [Note] InnoDB: Loading buffer pool(s) from /var/lib/mysql/data/ib\_buffer\_pool  
2023-01-28T09:01:55.119681Z 0 [ERROR] InnoDB: Cannot open ‘/var/lib/mysql/data/ib\_buffer\_pool’ for reading: No such file or directory  
2023-01-28T09:01:55.120039Z 0 [Note] Plugin ‘FEDERATED’ is disabled.  
2023-01-28T09:01:55.128639Z 0 [Note] Recovering after a crash using /var/lib/mysql/bin/bin  
2023-01-28T09:01:55.128674Z 0 [Note] WSREP: Before binlog recovery (wsrep position 5f19668b-6ebd-11ec-a091-bbe5ff26e53d:419124785)  
2023-01-28T09:01:55.128719Z 0 [Note] Starting crash recovery…  
2023-01-28T09:01:55.128771Z 0 [Note] Crash recovery finished.  
2023-01-28T09:01:55.128792Z 0 [Note] WSREP: After binlog recovery (wsrep position 5f19668b-6ebd-11ec-a091-bbe5ff26e53d:419124785)  
2023-01-28T09:01:55.139788Z 0 [Note] Skipping generation of SSL certificates as options related to SSL are specified.  
2023-01-28T09:01:55.139822Z 0 [Warning] A deprecated TLS version TLSv1 is enabled. Please use TLSv1.2 or higher.  
2023-01-28T09:01:55.139845Z 0 [Warning] A deprecated TLS version TLSv1.1 is enabled. Please use TLSv1.2 or higher.  
2023-01-28T09:01:55.140168Z 0 [Warning] Failed to set up SSL because of the following SSL library error: SSL\_CTX\_set\_default\_verify\_paths failed  
2023-01-28T09:01:55.140203Z 0 [Note] Skipping generation of RSA key pair as key files are present in data directory.  
2023-01-28T09:01:55.140530Z 0 [Note] Server hostname (bind-address): ‘0.0.0.0’; port: 3306  
2023-01-28T09:01:55.140570Z 0 [Note] - ‘0.0.0.0’ resolves to ‘0.0.0.0’;  
2023-01-28T09:01:55.140626Z 0 [Note] Server socket created on IP: ‘0.0.0.0’.  
2023-01-28T09:01:55.213481Z 0 [Note] Failed to start slave threads for channel ‘’  
2023-01-28T09:01:55.231864Z 0 [Note] Event Scheduler: Loaded 0 events  
2023-01-28T09:01:55.232059Z 0 [Note] WSREP: Signalling provider to continue on SST completion.  
2023-01-28T09:01:55.232095Z 0 [Note] WSREP: Initialized wsrep sidno 6  
2023-01-28T09:01:55.232130Z 0 [Note] WSREP: SST received: 5f19668b-6ebd-11ec-a091-bbe5ff26e53d:419124785  
2023-01-28T09:01:55.235785Z 2 [Note] WSREP: Receiving IST: 38067 writesets, seqnos 419124785-419162852  
2023-01-28T09:01:55.236151Z 0 [Note] WSREP: Receiving IST… 0.0% ( 0/38067 events) complete.  
2023-01-28T09:01:55.237437Z 21 [ERROR] Error in Log\_event::read\_log\_event(): ‘Found invalid event in binary log’, data\_len: 44, event\_type: 33  
2023-01-28T09:01:55.237458Z 20 [ERROR] Error in Log\_event::read\_log\_event(): ‘Found invalid event in binary log’, data\_len: 44, event\_type: 33  
2023-01-28T09:01:55.237679Z 20 [ERROR] WSREP: Applier could not read binlog event, seqno: 419124787, len: 518  
2023-01-28T09:01:55.237589Z 21 [ERROR] WSREP: Applier could not read binlog event, seqno: 419124786, len: 468  
2023-01-28T09:01:55.237742Z 22 [ERROR] Error in Log\_event::read\_log\_event(): ‘Found invalid event in binary log’, data\_len: 44, event\_type: 33  
2023-01-28T09:01:55.237776Z 22 [ERROR] WSREP: Applier could not read binlog event, seqno: 419124788, len: 13615  
2023-01-28T09:01:55.237802Z 23 [ERROR] Error in Log\_event::read\_log\_event(): ‘Found invalid event in binary log’, data\_len: 44, event\_type: 33  
2023-01-28T09:01:55.237818Z 23 [ERROR] WSREP: Applier could not read binlog event, seqno: 419124789, len: 509  
2023-01-28T09:01:55.238157Z 0 [Note] /usr/sbin/mysqld: ready for connections.  
Version: ‘5.7.36-39-57-log’ socket: ‘/var/lib/mysql/mysql.sock’ port: 3306 Percona XtraDB Cluster (GPL), Release rel39, Revision 5197785, WSREP version 31.55, wsrep\_31.55  
2023-01-28T09:01:55.238649Z 20 [Warning] WSREP: Failed to apply app buffer: seqno: 419124787, status: 1  
at galera/src/trx\_handle.cpp:apply():353  
Retrying 2th time  
2023-01-28T09:01:55.238667Z 22 [Warning] WSREP: Failed to apply app buffer: seqno: 419124788, status: 1  
at galera/src/trx\_handle.cpp:apply():353  
Retrying 2th time  
2023-01-28T09:01:55.238677Z 20 [ERROR] Error in Log\_event::read\_log\_event(): ‘Found invalid event in binary log’, data\_len: 44, event\_type: 33  
2023-01-28T09:01:55.238743Z 20 [ERROR] WSREP: Applier could not read binlog event, seqno: 419124787, len: 518  
2023-01-28T09:01:55.238677Z 21 [Warning] WSREP: Failed to apply app buffer: seqno: 419124786, status: 1  
at galera/src/trx\_handle.cpp:apply():353  
Retrying 2th time  
2023-01-28T09:01:55.238799Z 21 [ERROR] Error in Log\_event::read\_log\_event(): ‘Found invalid event in binary log’, data\_len: 44, event\_type: 33  
2023-01-28T09:01:55.238813Z 21 [ERROR] WSREP: Applier could not read binlog event, seqno: 419124786, len: 468  
2023-01-28T09:01:55.238837Z 26 [ERROR] Error in Log\_event::read\_log\_event(): ‘Found invalid event in binary log’, data\_len: 44, event\_type: 33  
2023-01-28T09:01:55.238862Z 26 [ERROR] WSREP: Applier could not read binlog event, seqno: 419124790, len: 510  
2023-01-28T09:01:55.238676Z 23 [Warning] WSREP: Failed to apply app buffer: seqno: 419124789, status: 1  
at galera/src/trx\_handle.cpp:apply():353  
Retrying 2th time  
2023-01-28T09:01:55.238714Z 22 [ERROR] Error in Log\_event::read\_log\_event(): ‘Found invalid event in binary log’, data\_len: 44, event\_type: 33  
2023-01-28T09:01:55.238948Z 20 [Warning] WSREP: Failed to apply app buffer: seqno: 419124787, status: 1  
at galera/src/trx\_handle.cpp:apply():353  
Retrying 3th time  
2023-01-28T09:01:55.238871Z 25 [ERROR] Error in Log\_event::read\_log\_event(): ‘Found invalid event in binary log’, data\_len: 44, event\_type: 33  
2023-01-28T09:01:55.239004Z 25 [ERROR] WSREP: Applier could not read binlog event, seqno: 419124791, len: 515  
2023-01-28T09:01:55.239061Z 21 [Warning] WSREP: Failed to apply app buffer: seqno: 419124786, status: 1  
at galera/src/trx\_handle.cpp:apply():353  
Retrying 3th time  
2023-01-28T09:01:55.239095Z 21 [ERROR] Error in Log\_event::read\_log\_event(): ‘Found invalid event in binary log’, data\_len: 44, event\_type: 33  
2023-01-28T09:01:55.239121Z 21 [ERROR] WSREP: Applier could not read binlog event, seqno: 419124786, len: 468  
2023-01-28T09:01:55.238967Z 22 [ERROR] WSREP: Applier could not read binlog event, seqno: 419124788, len: 13615  
2023-01-28T09:01:55.239070Z 2 [ERROR] Error in Log\_event::read\_log\_event(): ‘Found invalid event in binary log’, data\_len: 44, event\_type: 33  
2023-01-28T09:01:55.238943Z 23 [ERROR] Error in Log\_event::read\_log\_event(): ‘Found invalid event in binary log’, data\_len: 44, event\_type: 33  
2023-01-28T09:01:55.239257Z 23 [ERROR] WSREP: Applier could not read binlog event, seqno: 419124789, len: 509  
2023-01-28T09:01:55.239271Z 26 [Warning] WSREP: Failed to apply app buffer: seqno: 419124790, status: 1  
at galera/src/trx\_handle.cpp:apply():353  
Retrying 2th time  
2023-01-28T09:01:55.238980Z 20 [ERROR] Error in Log\_event::read\_log\_event(): ‘Found invalid event in binary log’, data\_len: 44, event\_type: 33  
2023-01-28T09:01:55.239323Z 20 [ERROR] WSREP: Applier could not read binlog event, seqno: 419124787, len: 518  
2023-01-28T09:01:55.238973Z 19 [ERROR] Error in Log\_event::read\_log\_event(): ‘Found invalid event in binary log’, data\_len: 44, event\_type: 33  
2023-01-28T09:01:55.239518Z 19 [ERROR] WSREP: Applier could not read binlog event, seqno: 419124792, len: 4066  
2023-01-28T09:01:55.239296Z 26 [ERROR] Error in Log\_event::read\_log\_event(): ‘Found invalid event in binary log’, data\_len: 44, event\_type: 33  
2023-01-28T09:01:55.239230Z 2 [ERROR] WSREP: Applier could not read binlog event, seqno: 419124794, len: 513

--------Log end -------

Thanks in advance

---

<div class="post-metadata">

**Author:** ![Michael\_Coburn](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/michael_coburn/32/18_2.png) [@Michael\_Coburn](https://forums.percona.com/u/Michael_Coburn)\
**Post date:** [January 28, 2023, 5:19pm UTC](https://forums.percona.com/t/unable-to-upgrade-from-percona-xtradb-cluster-5-6-to-5-7/19806/2 "2023-01-28T17:19:47Z")

</div>

Hi @pravingrane welcome back to the Percona forums!

The errors you have seem related to the upgrade from 5.6 to 5.7 at the `mysqld` level, outside of `wsrep`. Did you do step #6 where you start up the upgraded node with `wsrep` disabled so you can then execute `mysql_upgrade` ?

---

<div class="post-metadata">

**Author:** ![Pep\_Pla](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/pep_pla/32/9735_2.png) [@Pep\_Pla](https://forums.percona.com/u/Pep_Pla)\
**Post date:** [January 29, 2023, 5:59am UTC](https://forums.percona.com/t/unable-to-upgrade-from-percona-xtradb-cluster-5-6-to-5-7/19806/3 "2023-01-29T05:59:17Z")

</div>

Hi @pravingrane

The log event 33 corresponds to a GTID\_LOG\_EVENT. This should be a supported event in 5.7. Is it possible that some old library is still installed?

Could you run this command and post the results?

`yum list installed | grep -i -E 'percona|mysql|mariadb'`

Thanks

---

<div class="post-metadata">

**Author:** ![pravingrane](https://avatars.discourse-cdn.com/v4/letter/p/5f8ce5/32.png) [@pravingrane](https://forums.percona.com/u/pravingrane)\
**Post date:** [January 29, 2023, 4:43pm UTC](https://forums.percona.com/t/unable-to-upgrade-from-percona-xtradb-cluster-5-6-to-5-7/19806/4 "2023-01-29T16:43:21Z")

</div>

You are right.  
I had enabled GTID on all 3 nodes for async remote replica. I disabled GTID on all 3 nodes and upgrade work without any issues .  
I am going to replace underlaying OS with Ubuntu next and then enable GTID again for remote async replica.

Thanks.
