# Unable to start second node in cluster once xtrabackup is installed

**URL:** <https://forums.percona.com/t/unable-to-start-second-node-in-cluster-once-xtrabackup-is-installed/5448>\
**Category:** Percona XtraBackup\
**Created:** [February 27, 2017, 12:44pm UTC](https://forums.percona.com/t/unable-to-start-second-node-in-cluster-once-xtrabackup-is-installed/5448 "2017-02-27T12:44:05Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![YeeP](https://avatars.discourse-cdn.com/v4/letter/y/41988e/32.png) [@YeeP](https://forums.percona.com/u/YeeP)\
**Post date:** [February 27, 2017, 12:44pm UTC](https://forums.percona.com/t/unable-to-start-second-node-in-cluster-once-xtrabackup-is-installed/5448/1 "2017-02-27T12:44:05Z")

</div>

I have installed percona-xtrabackup package: percona-xtrabackup-24-2.4.6-1.el7.x86\_64 , along with its’ dependencies. The “Master” for the cluster starts just fine, but when I try to start up the second node, I get the following errors in the log:

```auto
170227 10:50:14 [ERROR] WSREP: Process completed with error: wsrep_sst_xtrabackup-v2 --role 'joiner' --address '10.0.0.11' --datadir '/var/lib/mysql/' --defaults-file '/etc/my.cnf' --parent '7513': 1 (Operation not permitted)
170227 10:50:14 [ERROR] WSREP: Failed to read uuid:seqno from joiner script.
170227 10:50:14 [ERROR] WSREP: SST failed: 1 (Operation not permitted)
170227 10:50:14 [ERROR] Aborting

170227 10:50:16 [Note] WSREP: Closing send monitor...
170227 10:50:16 [Note] WSREP: Closed send monitor.
170227 10:50:16 [Note] WSREP: gcomm: terminating thread
170227 10:50:16 [Note] WSREP: gcomm: joining thread
170227 10:50:16 [Note] WSREP: gcomm: closing backend
170227 10:50:17 [Note] WSREP: view(view_id(NON_PRIM,26c4b390,18) memb {
26c4b390,0
} joined {
} left {
} partitioned {
830b1639,0
})
170227 10:50:17 [Note] WSREP: view((empty))
170227 10:50:17 [Note] WSREP: gcomm: closed
170227 10:50:17 [Note] WSREP: New COMPONENT: primary = no, bootstrap = no, my_idx = 0, memb_num = 1
170227 10:50:17 [Note] WSREP: Flow-control interval: [16, 16]
170227 10:50:17 [Note] WSREP: Received NON-PRIMARY.
170227 10:50:17 [Note] WSREP: Shifting JOINER -> OPEN (TO: 0)
170227 10:50:17 [Note] WSREP: Received self-leave message.
170227 10:50:17 [Note] WSREP: Flow-control interval: [0, 0]
170227 10:50:17 [Note] WSREP: Received SELF-LEAVE. Closing connection.
170227 10:50:17 [Note] WSREP: Shifting OPEN -> CLOSED (TO: 0)
170227 10:50:17 [Note] WSREP: RECV thread exiting 0: Success
170227 10:50:17 [Note] WSREP: recv_thread() joined.
170227 10:50:17 [Note] WSREP: Closing replication queue.
170227 10:50:17 [Note] WSREP: Closing slave action queue.
170227 10:50:17 [Note] WSREP: Service disconnected.
170227 10:50:17 [Note] WSREP: rollbacker thread exiting
170227 10:50:18 [Note] WSREP: Some threads may fail to exit.
170227 10:50:18 [Note] /usr/sbin/mysqld: Shutdown complete

Error in my_thread_global_end(): 1 threads didn't exit
170227 10:50:23 mysqld_safe mysqld from pid file /var/lib/mysql/b.pid ended

```

The server.cnf file on both servers is very similar, here are the relevant settings:

```auto
[galera]
binlog_format=ROW
default-storage-engine=innodb
innodb_autoinc_lock_mode=2
innodb_locks_unsafe_for_binlog=1
query_cache_size=0
query_cache_type=0
bind-address=0.0.0.0
datadir=/var/lib/mysql
innodb_file_per_table
innodb_flush_log_at_trx_commit=2
wsrep_provider=/usr/lib64/galera/libgalera_smm.so
wsrep_cluster_address="gcomm://10.0.0.10,10.0.0.11,10.0.0.12"
wsrep_cluster_name='galera_cluster'
wsrep_node_address='10.0.0.11'
wsrep_node_name='db2'
wsrep_sst_method=xtrabackup-v2
wsrep_sst_auth=sst_user:dbpass

[xtrabackup]
target_dir=/data/mysql

```

Any suggestions would be much appreciated.

---

<div class="post-metadata">

**Author:** ![mirfan](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/mirfan/32/16890_2.png) [@mirfan](https://forums.percona.com/u/mirfan)\
**Post date:** [March 22, 2017, 2:18am UTC](https://forums.percona.com/t/unable-to-start-second-node-in-cluster-once-xtrabackup-is-installed/5448/2 "2017-03-22T02:18:44Z")

</div>

Can you please post backup log should be in data directory. And also post donor error log.
