# Unable to start mysql service.

**URL:** https://forums.percona.com/t/unable-to-start-mysql-service/4414
**Category:** Percona XtraDB Cluster 5.x
**Created:** [September 23, 2015, 9:29pm UTC](https://forums.percona.com/t/unable-to-start-mysql-service/4414 "2015-09-23T21:29:07Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![anirudha](https://avatars.discourse-cdn.com/v4/letter/a/9d8465/32.png) [@anirudha](https://forums.percona.com/u/anirudha)
#### Post date: [September 23, 2015, 9:29pm UTC](https://forums.percona.com/t/unable-to-start-mysql-service/4414/1 "2015-09-23T21:29:07Z")

</div>

I have followed all the steps from “[Percona Documentation](https://www.percona.com/doc/percona-xtradb-cluster/5.6/installation.html#installation)” to install Percona XtraDB on my CentOS6.5 x64bit host. But when tried to start the mysql service it failed with below error,

==== [INDENT][root@localhost ~]# service mysql status  
Redirecting to /bin/systemctl status mysql.service  
mysql.service - Percona XtraDB Cluster  
Loaded: loaded (/usr/lib/systemd/system/mysql.service; disabled)  
Active: failed (Result: exit-code) since Wed 2015-09-23 22:44:44 EDT; 6min ago  
Process: 3379 ExecStopPost=/usr/bin/mysql-systemd stop-post (code=exited, status=0/SUCCESS)  
Process: 3352 ExecStop=/usr/bin/mysql-systemd stop (code=exited, status=2)  
Process: 2894 ExecStartPost=/usr/bin/mysql-systemd start-post $MAINPID (code=exited, status=1/FAILURE)  
Process: 2893 ExecStart=/usr/bin/mysqld\_safe --basedir=/usr (code=exited, status=0/SUCCESS)  
Process: 2849 ExecStartPre=/usr/bin/mysql-systemd start-pre (code=exited, status=0/SUCCESS)  
Main PID: 2893 (code=exited, status=0/SUCCESS)  
CGroup: /system.slice/mysql.service

Sep 23 22:44:44 localhost.localdomain mysql-systemd[2894]: /usr/bin/mysql-systemd: line 134: kill: (2893) - No such process  
Sep 23 22:44:44 localhost.localdomain mysql-systemd[2894]: ERROR! mysqld\_safe with PID 2893 has already exited: FAILURE  
Sep 23 22:44:44 localhost.localdomain systemd[1]: mysql.service: control process exited, code=exited status=1  
Sep 23 22:44:44 localhost.localdomain mysql-systemd[3352]: WARNING: mysql pid file /run/mysqld/mysql.pid empty or not readable  
Sep 23 22:44:44 localhost.localdomain mysql-systemd[3352]: ERROR! mysql already dead  
Sep 23 22:44:44 localhost.localdomain systemd[1]: mysql.service: control process exited, code=exited status=2  
Sep 23 22:44:44 localhost.localdomain mysql-systemd[3379]: WARNING: mysql pid file /run/mysqld/mysql.pid empty or not readable  
Sep 23 22:44:44 localhost.localdomain mysql-systemd[3379]: WARNING: mysql may be already dead  
Sep 23 22:44:44 localhost.localdomain systemd[1]: Failed to start Percona XtraDB Cluster.  
Sep 23 22:44:44 localhost.localdomain systemd[1]: Unit mysql.service entered failed state.  
[root@localhost ~]#[/INDENT] ====

Here is my my.cnf file,

==== [INDENT][root@localhost ~]# cat /etc/my.cnf

# Template my.cnf for PXC

# Edit to your requirements.

[mysqld]

log\_bin

binlog\_format = ROW  
innodb\_buffer\_pool\_size = 100M  
innodb\_flush\_log\_at\_trx\_commit = 0  
innodb\_flush\_method = O\_DIRECT  
innodb\_log\_files\_in\_group = 2  
innodb\_log\_file\_size = 20M  
innodb\_file\_per\_table = 1  
default\_storage\_engine = InnoDB  
datadir = /var/lib/mysql

wsrep\_cluster\_address = gcomm://10.1.135.27  
wsrep\_provider = /usr/lib64/galera3/libgalera\_smm.so

wsrep\_slave\_threads = 8  
wsrep\_cluster\_name = Cluster  
wsrep\_node\_name = Node1  
wsrep\_node\_address = 10.1.135.27  
wsrep\_sst\_method = rsync  
wsrep\_sst\_auth = “sstuser:s3cret”

innodb\_locks\_unsafe\_for\_binlog = 1  
innodb\_autoinc\_lock\_mode = 2

[mysqld\_safe]  
pid-file = /run/mysqld/mysql.pid  
syslog

!includedir /etc/my.cnf.d[/INDENT] ====

Any idea how can I debug this?

---

<div class="post-metadata">

### Author: ![dendress](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/dendress/32/1091_2.png) [@dendress](https://forums.percona.com/u/dendress)
#### Post date: [September 23, 2015, 10:37pm UTC](https://forums.percona.com/t/unable-to-start-mysql-service/4414/2 "2015-09-23T22:37:27Z")

</div>

Check the ownership and permissions of the directory the .pid file is being written.

Also, please sanitize your post. Removing auth info from any posting is a good idea.

---

<div class="post-metadata">

### Author: ![rolls](https://avatars.discourse-cdn.com/v4/letter/r/a6a055/32.png) [@rolls](https://forums.percona.com/u/rolls)
#### Post date: [September 25, 2015, 10:09am UTC](https://forums.percona.com/t/unable-to-start-mysql-service/4414/3 "2015-09-25T10:09:02Z")

</div>

make chonw -R mysql:mysql on your database directory (/var/lib/mysql)

then start the server with #service mysql bootstrap-pxc
