# Unable to start mysql after innobackupex-1.5.1

**URL:** <https://forums.percona.com/t/unable-to-start-mysql-after-innobackupex-1-5-1/2215>\
**Category:** Percona XtraBackup\
**Created:** [March 2, 2012, 12:39am UTC](https://forums.percona.com/t/unable-to-start-mysql-after-innobackupex-1-5-1/2215 "2012-03-02T00:39:04Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![aaron08544](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/aaron08544/32/866_2.png) [@aaron08544](https://forums.percona.com/u/aaron08544)\
**Post date:** [March 2, 2012, 12:39am UTC](https://forums.percona.com/t/unable-to-start-mysql-after-innobackupex-1-5-1/2215/1 "2012-03-02T00:39:04Z")

</div>

innobackupex-1.5.1 --copy-back /tmp/backup/2012-03-01\_21-53-41/

We are getting the following stack trace after starting the server from a restore, any idea?

120302 03:53:16 mysqld\_safe Starting mysqld daemon with databases from /var/lib/mysql  
120302 3:53:16 [Warning] ‘for replication startup options’ is deprecated and will be removed in a future release. Please use ‘‘CHANGE MASTER’’ instead.  
120302 3:53:16 [Warning] ‘–default-character-set’ is deprecated and will be removed in a future release. Please use ‘–character-set-server’ instead.  
120302 3:53:16 [Warning] ‘–log-long-format’ is deprecated and will be removed in a future release. Please use ‘–log-short-format’ instead.  
120302 3:53:16 [Note] Flashcache bypass: disabled  
120302 3:53:16 [Note] Flashcache setup error is : ioctl failed

120302 3:53:16 [Note] Plugin ‘FEDERATED’ is disabled.  
120302 3:53:16 [Warning] option ‘innodb-buffer-pool-size’: signed value 16777216 adjusted to 33554432  
InnoDB: The InnoDB memory heap is disabled  
InnoDB: Mutexes and rw\_locks use GCC atomic builtins  
InnoDB: Compressed tables use zlib 1.2.3.3  
120302 3:53:16 InnoDB: Initializing buffer pool, size = 32.0M  
120302 3:53:16 InnoDB: Completed initialization of buffer pool  
120302 3:53:16 InnoDB: highest supported file format is Barracuda.  
InnoDB: The log sequence number in ibdata files does not match  
InnoDB: the log sequence number in the ib\_logfiles!  
120302 3:53:16 InnoDB: Database was not shut down normally!  
InnoDB: Starting crash recovery.  
InnoDB: Reading tablespace information from the .ibd files…  
InnoDB: Restoring possible half-written data pages from the doublewrite  
InnoDB: buffer…  
120302 3:53:16 InnoDB: Error: page 0 log sequence number 115776432396  
InnoDB: is in the future! Current system log sequence number 115775869964.  
InnoDB: Your database may be corrupt or you may have copied the InnoDB  
InnoDB: tablespace but not the InnoDB log files. See  
InnoDB: [http://dev.mysql.com/doc/refman/5.1/en/forcing-innodb-recove](http://dev.mysql.com/doc/refman/5.1/en/forcing-innodb-recove) ry.html  
InnoDB: for more information.  
120302 3:53:16 InnoDB: Error: page 868409 log sequence number 115778311048  
InnoDB: is in the future! Current system log sequence number 115775869964.  
InnoDB: Your database may be corrupt or you may have copied the InnoDB  
InnoDB: tablespace but not the InnoDB log files. See  
InnoDB: [http://dev.mysql.com/doc/refman/5.1/en/forcing-innodb-recove](http://dev.mysql.com/doc/refman/5.1/en/forcing-innodb-recove) ry.html  
InnoDB: for more information.  
120302 3:53:16 InnoDB: Error: page 868353 log sequence number 115777529019  
InnoDB: is in the future! Current system log sequence number 115775869964.  
InnoDB: Your database may be corrupt or you may have copied the InnoDB  
InnoDB: tablespace but not the InnoDB log files. See  
InnoDB: [http://dev.mysql.com/doc/refman/5.1/en/forcing-innodb-recove](http://dev.mysql.com/doc/refman/5.1/en/forcing-innodb-recove) ry.html  
InnoDB: for more information.  
120302 3:53:16 InnoDB: Error: page 1032192 log sequence number 115778312183  
InnoDB: is in the future! Current system log sequence number 115775869964.  
InnoDB: Your database may be corrupt or you may have copied the InnoDB  
InnoDB: tablespace but not the InnoDB log files. See  
InnoDB: [http://dev.mysql.com/doc/refman/5.1/en/forcing-innodb-recove](http://dev.mysql.com/doc/refman/5.1/en/forcing-innodb-recove) ry.html  
InnoDB: for more information.  
120302 3:53:16 InnoDB: Error: page 1032193 log sequence number 115778366656  
InnoDB: is in the future! Current system log sequence number 115775869964.  
InnoDB: Your database may be corrupt or you may have copied the InnoDB  
InnoDB: tablespace but not the InnoDB log files. See  
InnoDB: [http://dev.mysql.com/doc/refman/5.1/en/forcing-innodb-recove](http://dev.mysql.com/doc/refman/5.1/en/forcing-innodb-recove) ry.html  
InnoDB: for more information.  
120302 3:53:16 InnoDB: Error: page 4 log sequence number 115776431938  
InnoDB: is in the future! Current system log sequence number 115775871298.  
InnoDB: Your database may be corrupt or you may have copied the InnoDB  
InnoDB: tablespace but not the InnoDB log files. See  
InnoDB: [http://dev.mysql.com/doc/refman/5.1/en/forcing-innodb-recove](http://dev.mysql.com/doc/refman/5.1/en/forcing-innodb-recove) ry.html  
InnoDB: for more information.  
120302 3:53:16 InnoDB: Error: page 65537 log sequence number 115776130608  
InnoDB: is in the future! Current system log sequence number 115775871298.  
InnoDB: Your database may be corrupt or you may have copied the InnoDB  
InnoDB: tablespace but not the InnoDB log files. See  
InnoDB: [http://dev.mysql.com/doc/refman/5.1/en/forcing-innodb-recove](http://dev.mysql.com/doc/refman/5.1/en/forcing-innodb-recove) ry.html  
InnoDB: for more information.  
120302 3:53:16 InnoDB: Error: page 5 log sequence number 115776432381  
InnoDB: is in the future! Current system log sequence number 115775871298.  
InnoDB: Your database may be corrupt or you may have copied the InnoDB  
InnoDB: tablespace but not the InnoDB log files. See  
InnoDB: [http://dev.mysql.com/doc/refman/5.1/en/forcing-innodb-recove](http://dev.mysql.com/doc/refman/5.1/en/forcing-innodb-recove) ry.html  
InnoDB: for more information.  
120302 3:53:16 InnoDB: Error: page 6 log sequence number 115776432371  
InnoDB: is in the future! Current system log sequence number 115775871298.  
InnoDB: Your database may be corrupt or you may have copied the InnoDB  
InnoDB: tablespace but not the InnoDB log files. See  
InnoDB: [http://dev.mysql.com/doc/refman/5.1/en/forcing-innodb-recove](http://dev.mysql.com/doc/refman/5.1/en/forcing-innodb-recove) ry.html  
InnoDB: for more information.  
120302 3:53:16 InnoDB: Assertion failure in thread 140507111261952 in file ./include/fut0lst.ic line 83  
InnoDB: Failing assertion: addr.page == FIL\_NULL || addr.boffset \>= FIL\_PAGE\_DATA  
InnoDB: We intentionally generate a memory trap.  
InnoDB: Submit a detailed bug report to [http://bugs.mysql.com](http://bugs.mysql.com).  
InnoDB: If you get repeated assertion failures or crashes, even  
InnoDB: immediately after the mysqld startup, there may be  
InnoDB: corruption in the InnoDB tablespace. Please refer to  
InnoDB: [http://dev.mysql.com/doc/refman/5.1/en/forcing-innodb-recove](http://dev.mysql.com/doc/refman/5.1/en/forcing-innodb-recove) ry.html  
InnoDB: about forcing recovery.  
03:53:16 UTC - mysqld got signal 6 ;  
This could be because you hit a bug. It is also possible that this binary  
or one of the libraries it was linked against is corrupt, improperly built,  
or misconfigured. This error can also be caused by malfunctioning hardware.  
We will try our best to scrape up some info that will hopefully help  
diagnose the problem, but since we have already crashed,  
something is definitely wrong and this may fail.

key\_buffer\_size=8384512  
read\_buffer\_size=131072  
max\_used\_connections=0  
max\_threads=151  
thread\_count=0  
connection\_count=0  
It is possible that mysqld could use up to  
key\_buffer\_size + (read\_buffer\_size + sort\_buffer\_size)\*max\_threads = 338433 K bytes of memory  
Hope that’s ok; if not, decrease some variables in the equation.

Thread pointer: 0x0  
Attempting backtrace. You can use the following information to find out  
where mysqld died. If you see no messages after this, something went  
terribly wrong…  
stack\_bottom = 0 thread\_stack 0x40000  
/usr/sbin/mysqld(my\_print\_stacktrace+0x35)[0x8cfef5]  
/usr/sbin/mysqld(handle\_fatal\_signal+0x40b)[0x6c713b]  
/lib/libpthread.so.0(+0xf8f0)[0x7fca5c3288f0]  
/lib/libc.so.6(gsignal+0x35)[0x7fca5b0c5a75]  
/lib/libc.so.6(abort+0x180)[0x7fca5b0c95c0]  
/usr/sbin/mysqld[0x7f8ddf]  
/usr/sbin/mysqld[0x7ebf9c]  
/usr/sbin/mysqld[0x7ec274]  
/usr/sbin/mysqld[0x7ee288]  
/usr/sbin/mysqld[0x7da3cc]  
/usr/sbin/mysqld[0x7600e2]  
/usr/sbin/mysqld(\_Z24ha\_initialize\_handlertonP13st\_plugin\_in t+0x38)[0x6ba458]  
/usr/sbin/mysqld[0x73d527]  
/usr/sbin/mysqld(\_Z11plugin\_initPiPPci+0x66d)[0x73f73d]  
/usr/sbin/mysqld[0x5d793e]  
/usr/sbin/mysqld(main+0x1fe)[0x5d9fce]  
/lib/libc.so.6(\_\_libc\_start\_main+0xfd)[0x7fca5b0b0c4d]  
/usr/sbin/mysqld[0x51c259]  
The manual page at [URL][http://dev.mysql.com/doc/mysql/en/crashing.html[/URL]](http://dev.mysql.com/doc/mysql/en/crashing.html%5B/URL%5D) contains  
information that should help you find out what is causing the crash.  
120302 03:53:16 mysqld\_safe mysqld from pid file /var/run/mysqld/mysqld.pid ended

---

<div class="post-metadata">

**Author:** ![xaprb](https://avatars.discourse-cdn.com/v4/letter/x/49beb7/32.png) [@xaprb](https://forums.percona.com/u/xaprb)\
**Post date:** [March 2, 2012, 4:35pm UTC](https://forums.percona.com/t/unable-to-start-mysql-after-innobackupex-1-5-1/2215/2 "2012-03-02T16:35:55Z")

</div>

It looks like your backup wasn’t prepared before it was restored. Please check the manual if you didn’t do that.

This is off topic, but you really do need to pay attention to the warning about having replication options set in your my.cnf file. The only words that can describe how badly this can hurt you are words I can’t use in a public place. Remove those options now or you will regret it!
