# Unable to install Percona

**URL:** <https://forums.percona.com/t/unable-to-install-percona/1778>\
**Category:** Other MySQL® Questions\
**Created:** [March 16, 2012, 1:40am UTC](https://forums.percona.com/t/unable-to-install-percona/1778 "2012-03-16T01:40:22Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![fewds](https://avatars.discourse-cdn.com/v4/letter/f/ccd318/32.png) [@fewds](https://forums.percona.com/u/fewds)\
**Post date:** [March 16, 2012, 1:40am UTC](https://forums.percona.com/t/unable-to-install-percona/1778/1 "2012-03-16T01:40:22Z")

</div>

I have a strange issue not sure what is happening. I have used Percona on many servers in the past and this one just will not install it. I’m running Debian 6 64bit, Dual 6 core, 12GB ram, and 240GB SSD.

Output of my issue:  
Setting up libmysqlclient18 (5.5.20-rel24.1-217.squeeze) …  
Setting up percona-server-common-5.5 (5.5.20-rel24.1-217.squeeze) …  
Setting up percona-server-client-5.5 (5.5.20-rel24.1-217.squeeze) …  
Setting up percona-server-server-5.5 (5.5.20-rel24.1-217.squeeze) …  
Stopping MySQL (Percona Server): mysqld.  
Starting MySQL (Percona Server) database server: mysqld . . . . . . . . . . . . . . failed!  
invoke-rc.d: initscript mysql, action “start” failed.  
dpkg: error processing percona-server-server-5.5 (–configure):  
subprocess installed post-installation script returned error exit status 1  
configured to not write apport reports  
Errors were encountered while processing:  
percona-server-server-5.5  
E: Sub-process /usr/bin/dpkg returned an error code (1)

Any help would be great!

P.S. Trying to fix the install using apt-get -f install doesn’t fix it either and will still show the same issue.

---

<div class="post-metadata">

**Author:** ![przemek](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/przemek/32/3_2.png) [@przemek](https://forums.percona.com/u/przemek)\
**Post date:** [March 16, 2012, 2:19am UTC](https://forums.percona.com/t/unable-to-install-percona/1778/2 "2012-03-16T02:19:25Z")

</div>

Is this fresh install or was there already MySQL server running before?

First of all check if mysqld really didn’t start, since the init.d script gives it only 14 seconds by default after it reports “failed” which is often not long enough.  
And most important - read the mysql error log.

If mysqld is starting longer but successfully then just set the time longer to make the apt-get succeed:  
edit /etc/init.d/mysql

for i in 1 2 3 4 5 6 7 8 9 10 11 12 13 14; do

to e.g.

for i in `seq 1 90`; do

---

<div class="post-metadata">

**Author:** ![fewds](https://avatars.discourse-cdn.com/v4/letter/f/ccd318/32.png) [@fewds](https://forums.percona.com/u/fewds)\
**Post date:** [March 16, 2012, 2:29am UTC](https://forums.percona.com/t/unable-to-install-percona/1778/3 "2012-03-16T02:29:37Z")

</div>

BTW meant to mention this is a brand new fresh clean install of Debian 6 64bit (no previous mysql packages installed that I know about) also there is absolutely nothing in the mysql logs, which I thought was strange. However there is some stuff in the syslog, just not sure if it would help figure out what is wrong.

Mar 16 03:58:15 steven mysqld\_safe[25395]: #007/usr/sbin/mysqld: Can’t create/write to file ‘/tmp/ibVMew5n’ (Errcode: 13)  
Mar 16 03:58:15 steven mysqld\_safe[25395]: 120316 7:58:15 InnoDB: Error: unable to create temporary file; errno: 13  
Mar 16 03:58:15 steven mysqld\_safe[25395]: 120316 7:58:15 [ERROR] Plugin ‘InnoDB’ init function returned error.  
Mar 16 03:58:15 steven mysqld\_safe[25395]: 120316 7:58:15 [ERROR] Plugin ‘InnoDB’ registration as a STORAGE ENGINE failed.  
Mar 16 03:58:15 steven mysqld\_safe[25395]: 120316 7:58:15 [ERROR] Unknown/unsupported storage engine: InnoDB  
Mar 16 03:58:15 steven mysqld\_safe[25395]: 120316 7:58:15 [ERROR] Aborting  
Mar 16 03:58:15 steven mysqld\_safe[25395]:  
Mar 16 03:58:15 steven mysqld\_safe[25395]: 120316 7:58:15 [Note] /usr/sbin/mysqld: Shutdown complete  
Mar 16 03:58:15 steven mysqld\_safe[25395]:  
Mar 16 03:58:15 steven mysqld\_safe[25399]: 120316 7:58:15 [Note] Flashcache bypass: disabled  
Mar 16 03:58:15 steven mysqld\_safe[25399]: 120316 7:58:15 [Note] Flashcache setup error is : ioctl failed  
Mar 16 03:58:15 steven mysqld\_safe[25399]:  
Mar 16 03:58:15 steven mysqld\_safe[25399]: 120316 7:58:15 [Note] Plugin ‘FEDERATED’ is disabled.  
Mar 16 03:58:15 steven mysqld\_safe[25399]: 120316 7:58:15 InnoDB: The InnoDB memory heap is disabled  
Mar 16 03:58:15 steven mysqld\_safe[25399]: 120316 7:58:15 InnoDB: Mutexes and rw\_locks use GCC atomic builtins  
Mar 16 03:58:15 steven mysqld\_safe[25399]: 120316 7:58:15 InnoDB: Compressed tables use zlib 1.2.3  
Mar 16 03:58:15 steven mysqld\_safe[25399]: 120316 7:58:15 InnoDB: Using Linux native AIO  
Mar 16 03:58:15 steven mysqld\_safe[25399]: #007/usr/sbin/mysqld: Can’t create/write to file ‘/tmp/ib7GzNTr’ (Errcode: 13)  
Mar 16 03:58:15 steven mysqld\_safe[25399]: 120316 7:58:15 InnoDB: Error: unable to create temporary file; errno: 13  
Mar 16 03:58:15 steven mysqld\_safe[25399]: 120316 7:58:15 [ERROR] Plugin ‘InnoDB’ init function returned error.  
Mar 16 03:58:15 steven mysqld\_safe[25399]: 120316 7:58:15 [ERROR] Plugin ‘InnoDB’ registration as a STORAGE ENGINE failed.  
Mar 16 03:58:15 steven mysqld\_safe[25399]: 120316 7:58:15 [ERROR] Unknown/unsupported storage engine: InnoDB  
Mar 16 03:58:15 steven mysqld\_safe[25399]: 120316 7:58:15 [ERROR] Aborting  
Mar 16 03:58:15 steven mysqld\_safe[25399]:  
Mar 16 03:58:15 steven mysqld\_safe[25399]: 120316 7:58:15 [Note] /usr/sbin/mysqld: Shutdown complete  
Mar 16 03:58:15 steven mysqld\_safe[25399]:  
Mar 16 03:59:46 steven /etc/init.d/mysql[26505]: 0 processes alive and ‘/usr/bin/mysqladmin --defaults-file=/etc/mysql/debian.cnf ping’ resulted in  
Mar 16 03:59:46 steven /etc/init.d/mysql[26505]: #007/usr/bin/mysqladmin: connect to server at ‘localhost’ failed  
Mar 16 03:59:46 steven /etc/init.d/mysql[26505]: error: ‘Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (2)’  
Mar 16 03:59:46 steven /etc/init.d/mysql[26505]: Check that mysqld is running and that the socket: ‘/var/run/mysqld/mysqld.sock’ exists!  
Mar 16 03:59:46 steven /etc/init.d/mysql[26505]:

---

<div class="post-metadata">

**Author:** ![fewds](https://avatars.discourse-cdn.com/v4/letter/f/ccd318/32.png) [@fewds](https://forums.percona.com/u/fewds)\
**Post date:** [March 16, 2012, 2:31am UTC](https://forums.percona.com/t/unable-to-install-percona/1778/4 "2012-03-16T02:31:04Z")

</div>

I tried to increase the time limit using this code however it had no effect. Thanks though anything else you might think could be causing this?
