# Unable to bootstrap Node 1 of Pecona XtraDB cluster 8.0

**URL:** <https://forums.percona.com/t/unable-to-bootstrap-node-1-of-pecona-xtradb-cluster-8-0/8134>\
**Category:** Percona XtraDB Cluster 5.x\
**Tags:** troubleshooting, mysql, percona\
**Created:** [October 13, 2020, 5:35pm UTC](https://forums.percona.com/t/unable-to-bootstrap-node-1-of-pecona-xtradb-cluster-8-0/8134 "2020-10-13T17:35:03Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![salman253](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/salman253/32/1416_2.png) [@salman253](https://forums.percona.com/u/salman253)\
**Post date:** [October 13, 2020, 5:35pm UTC](https://forums.percona.com/t/unable-to-bootstrap-node-1-of-pecona-xtradb-cluster-8-0/8134/1 "2020-10-13T17:35:03Z")

</div>

Hi,

I have installed PXC 8.0 on 2 nodes (Ubuntu 20). After sufficient configuration to my.cnf file I am trying to bootstrap Node 1 as below:

systemctl start mysql@bootstrap.service

The command stuck for 1-2 mins and while looking into logs from another terminal it shows that node is now synced and ready for connection. But after 2-3 mins the command gets failed with below error:

Job for mysql@bootstrap.service failed because a timeout was exceeded.

See “systemctl status mysql@bootstrap.service” and “journalctl -xe” for details.

And log shows “Received shutdown signal” and then it shutdown completely.

I tried disabling MySQL Apparmor profile also, but no luck. I am not getting where is the issue.

Please help!

Below is the status check for failed service command:

systemctl status mysql@bootstrap.service

- mysql@bootstrap.service - Percona XtraDB Cluster with config /etc/default/mysql.bootstrap

Oct 13 17:03:55 [db1.xyz.com](http://db1.xyz.com) systemd[1]: Starting Percona XtraDB Cluster with config /etc/default/mysql.bootstrap…

Oct 13 17:05:26 [db1.xyz.com](http://db1.xyz.com) systemd[1]: mysql@bootstrap.service: start operation timed out. Terminating.

Oct 13 17:05:41 [db1.xyz.com](http://db1.xyz.com) mysql-systemd[430666]: WARNING: mysql pid file /var/lib/mysql/mysqld.pid empty or not readable

Oct 13 17:05:41 [db1.xyz.com](http://db1.xyz.com) mysql-systemd[430666]: WARNING: mysql may be already dead

Oct 13 17:05:41 [db1.xyz.com](http://db1.xyz.com) systemd[1]: mysql@bootstrap.service: Failed with result ‘timeout’.

Oct 13 17:05:41 [db1.xyz.com](http://db1.xyz.com) systemd[1]: Failed to start Percona XtraDB Cluster with config /etc/default/mysql.bootstrap.

---

<div class="post-metadata">

**Author:** ![Nethe](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/nethe/32/1430_2.png) [@Nethe](https://forums.percona.com/u/Nethe)\
**Post date:** [October 24, 2020, 12:12pm UTC](https://forums.percona.com/t/unable-to-bootstrap-node-1-of-pecona-xtradb-cluster-8-0/8134/2 "2020-10-24T12:12:07Z")

</div>

Hello,

I had similar issues while I was testing the cluster on LXC.

check the configuration variables in _/etc/mysql/my.cnf_ -

- _wsrep\_node\_address, wsrep\_cluster\_name, wsrep\_node\_name_
- check if the machines are reachable to each other

check the listening IP/port of the nodes (_netstat -apn_, for example) and its reachability machine \<-\> machine (use telnet

- for example)

if you are testing on LXC/LXD, please try to set security nesting to containers (on LXDlxc config set sql5 security.nesting true

- and restart the containers)

If it is was not helpful, can you please post full /etc/mysql/my.cnf and the output of cat /var/log/mysql/error.log?

Regards,

Martin
