# TokuDB storage engine in Percona Server 8.0.28

**URL:** <https://forums.percona.com/t/tokudb-storage-engine-in-percona-server-8-0-28/17139>\
**Category:** Percona Server for MySQL 8.0\
**Tags:** mysql, percona\
**Created:** [August 24, 2022, 9:24am UTC](https://forums.percona.com/t/tokudb-storage-engine-in-percona-server-8-0-28/17139 "2022-08-24T09:24:30Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Dodon\_Angin\_Wiyono](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/dodon_angin_wiyono/32/7278_2.png) [@Dodon\_Angin\_Wiyono](https://forums.percona.com/u/Dodon_Angin_Wiyono)\
**Post date:** [August 24, 2022, 9:24am UTC](https://forums.percona.com/t/tokudb-storage-engine-in-percona-server-8-0-28/17139/1 "2022-08-24T09:24:30Z")

</div>

after update to 8.0.28 my database cannot start service because i forgot migrate table from tokudb to innodb

2022-08-24T09:16:23.449323Z 1 [ERROR] [MY-048034] [Server] Table ‘xxx.xxx’ requires the ‘TokuDB’ storage engine, which was removed in Percona Server 8.0.28  
2022-08-24T09:16:23.449463Z 1 [ERROR] [MY-048034] [Server] Table ‘xxx.xxx’ requires the ‘TokuDB’ storage engine, which was removed in Percona Server 8.0.28  
2022-08-24T09:16:23.600732Z 0 [ERROR] [MY-010020] [Server] Data Dictionary initialization failed.  
2022-08-24T09:16:23.600916Z 0 [ERROR] [MY-010119] [Server] Aborting

---

<div class="post-metadata">

**Author:** ![matthewb](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/matthewb/32/34_2.png) [@matthewb](https://forums.percona.com/u/matthewb)\
**Post date:** [August 24, 2022, 2:17pm UTC](https://forums.percona.com/t/tokudb-storage-engine-in-percona-server-8-0-28/17139/2 "2022-08-24T14:17:35Z")

</div>

Downgrade to previous version of Percona Server, alter the tables, then upgrade back to 8.0.28. It has been well documented and blogged for over a year that TokuDB was deprecated and would be removed.

---

<div class="post-metadata">

**Author:** ![Marcello\_Verona](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/marcello_verona/32/3145_2.png) [@Marcello\_Verona](https://forums.percona.com/u/Marcello_Verona)\
**Post date:** [November 18, 2022, 11:22pm UTC](https://forums.percona.com/t/tokudb-storage-engine-in-percona-server-8-0-28/17139/3 "2022-11-18T23:22:32Z")

</div>

Hi, I have the same problem, but after downgrading to 8.0.27 the tokudb package isn’t available.

I’m on Centos 7. I tried with `yum install percona-server-tokudb` but yum tried to upgrade percona-server-server to 8.0.29.  
So I tried with the RPM, but seems there are a lot of dependencies not resolved.

I have one only table (a log table).

How can I recover my DB?  
I cannot drop the table and I cannot drop the db…

Thank you for your help
