# Toku Hot Backup 5.7.35-38 fails with copier.cc:174 copy error fname=/mysql/proc.MYD r=28

**URL:** <https://forums.percona.com/t/toku-hot-backup-5-7-35-38-fails-with-copier-cc-174-copy-error-fname-mysql-proc-myd-r-28/13484>\
**Category:** Percona Server for MySQL 5.7\
**Tags:** community, percona\
**Created:** [December 15, 2021, 9:55am UTC](https://forums.percona.com/t/toku-hot-backup-5-7-35-38-fails-with-copier-cc-174-copy-error-fname-mysql-proc-myd-r-28/13484 "2021-12-15T09:55:11Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![zentavr](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/zentavr/32/869_2.png) [@zentavr](https://forums.percona.com/u/zentavr)\
**Post date:** [December 15, 2021, 9:55am UTC](https://forums.percona.com/t/toku-hot-backup-5-7-35-38-fails-with-copier-cc-174-copy-error-fname-mysql-proc-myd-r-28/13484/1 "2021-12-15T09:55:11Z")

</div>

Suddenly TokuDB Hot Backup started to fail at one of our servers. While we set up `set tokudb_backup_dir='/home/bacula/mysql/2021-12-14_22-08-49/';` in the MySQL console and some time pass - somewhere at 30…39% the process fails with:

```auto
Toku Hot Backup: Started: <the date here>
/mnt/workspace/percona-server-5.7-debian-binary-rocks-new/label_exp/min-xenial-x64/test/percona-server-5.7-5.7.35-38/plugin/tokudb-backup-plugin/Percona-TokuBackup/backup/copier.cc:174 copy error fname=/mysql/proc.MYD r=28
Toku Hot Backup: <another date here>

```

At the beginning it was 33%, now it is 39%, but fails all the time at `copier.cc:174 copy error fname=/mysql/proc.MYD`.

I’d tried to copy these tables manually and no error happen.

What might be the issue?

---

<div class="post-metadata">

**Author:** ![zentavr](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/zentavr/32/869_2.png) [@zentavr](https://forums.percona.com/u/zentavr)\
**Post date:** [December 15, 2021, 10:14am UTC](https://forums.percona.com/t/toku-hot-backup-5-7-35-38-fails-with-copier-cc-174-copy-error-fname-mysql-proc-myd-r-28/13484/2 "2021-12-15T10:14:51Z")

</div>

Seems like it stopped one time at the binary log:

```auto
root@central:/var/log/mysql# grep -v Note error.log

Toku Hot Backup: Started: Tue Dec 14 02:58:15 2021

Tue Dec 14 03:03:24 2021 PerconaFT file system space is low
/mnt/workspace/percona-server-5.7-debian-binary-rocks-new/label_exp/min-xenial-x64/test/percona-server-5.7-5.7.35-38/plugin/tokudb-backup-plugin/Percona-TokuBackup/backup/copier.cc:174 copy error fname=/mysql/proc.MYD r=28
Toku Hot Backup: Finished: Tue Dec 14 09:26:16 2021

Toku Hot Backup: Started: Tue Dec 14 11:58:22 2021

/mnt/workspace/percona-server-5.7-debian-binary-rocks-new/label_exp/min-xenial-x64/test/percona-server-5.7-5.7.35-38/plugin/tokudb-backup-plugin/Percona-TokuBackup/backup/copier.cc:174 copy error fname=/log-bin.000086 r=1152
Toku Hot Backup: Finished: Tue Dec 14 12:00:00 2021

Toku Hot Backup: Started: Tue Dec 14 12:01:24 2021

/mnt/workspace/percona-server-5.7-debian-binary-rocks-new/label_exp/min-xenial-x64/test/percona-server-5.7-5.7.35-38/plugin/tokudb-backup-plugin/Percona-TokuBackup/backup/copier.cc:174 copy error fname=/mysql/proc.MYD r=28
Toku Hot Backup: Finished: Tue Dec 14 18:46:27 2021

Toku Hot Backup: Started: Tue Dec 14 22:57:03 2021

/mnt/workspace/percona-server-5.7-debian-binary-rocks-new/label_exp/min-xenial-x64/test/percona-server-5.7-5.7.35-38/plugin/tokudb-backup-plugin/Percona-TokuBackup/backup/copier.cc:174 copy error fname=/mysql/proc.MYD r=28
Toku Hot Backup: Finished: Wed Dec 15 06:05:06 2021

```
