# the yum repo is currently broken

**URL:** <https://forums.percona.com/t/the-yum-repo-is-currently-broken/2683>\
**Category:** Other MySQL® Questions\
**Created:** [May 15, 2013, 6:52am UTC](https://forums.percona.com/t/the-yum-repo-is-currently-broken/2683 "2013-05-15T06:52:35Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![starkers](https://avatars.discourse-cdn.com/v4/letter/s/50afbb/32.png) [@starkers](https://forums.percona.com/u/starkers)\
**Post date:** [May 15, 2013, 6:52am UTC](https://forums.percona.com/t/the-yum-repo-is-currently-broken/2683/1 "2013-05-15T06:52:35Z")

</div>

Hey guys, I was in the processes of creating a slave (on centos6.3 64bit) but it seems the repo is no longer inline with the files provided at [URL=“[Percona Repo](http://repo.percona.com/centos/6/os/x86_64/)”][http://repo.percona.com/centos/6/os/x86\_64/[/URL=“http://repo.percona.com/centos/6/os/x86\_64/”]](http://repo.percona.com/centos/6/os/x86_64/%5B/URL=%22http://repo.percona.com/centos/6/os/x86_64/%22%5D)

I can see that its now .509 and this is trying to pull .508, the timestamps are today so I’m sure this is temporary but if someone could bump the repo please I’d be most grateful!

Side note: thanks for an excellent product, as a sysadmin I’m having a great time migrating all our old solaris coolstack mysqls to centos+percona and look forward to having them all done soon!

per: [url][Percona Server for MySQL 8.0 - Documentation — Percona Server 8.0 Documentation](http://www.percona.com/doc/percona-server/5.5/installation/yum_repo.html%5B/url%5D)

Retrieving [URL=“[Percona – The Database Performance Experts](http://www.percona.com/downloads/percona-release/percona-release-0.0-1.x86_64.rpm)”][http://www.percona.com/downloads/per...0-1.x86\_64.rpm[/URL=“http://www.percona.com/downloads/percona-release/percona-release-0.0-1.x86\_64.rpm”]](http://www.percona.com/downloads/per...0-1.x86_64.rpm%5B/URL=%22http://www.percona.com/downloads/percona-release/percona-release-0.0-1.x86_64.rpm%22%5D)  
Preparing… ########################################### [100%]  
1:percona-release ########################################### [100%]  
[root@ludwig2 ~]# yum install -y Percona-Server-server-55 Percona-Server-client-55 Percona-Server-shared-compat  
Loaded plugins: fastestmirror, presto  
Loading mirror speeds from cached hostfile

- base: [mirror.rmg.io](http://mirror.rmg.io)
- epel: [mirror.nl.leaseweb.net](http://mirror.nl.leaseweb.net)
- extras: [mirror.rmg.io](http://mirror.rmg.io)
- updates: [mirror.stshosting.co.uk](http://mirror.stshosting.co.uk)  
Setting up Install Process  
Resolving Dependencies  
 → Running transaction check  
—\> Package Percona-Server-client-55.x86\_64 0:5.5.30-rel30.2.508.rhel6 will be installed  
 → Processing Dependency: Percona-Server-shared-55 for package: Percona-Server-client-55-5.5.30-rel30.2.508.rhel6.x86\_64  
—\> Package Percona-Server-server-55.x86\_64 0:5.5.30-rel30.2.508.rhel6 will be installed  
—\> Package Percona-Server-shared-compat.x86\_64 0:5.5.30-rel30.2.508.rhel6 will be installed  
 → Running transaction check  
—\> Package Percona-Server-shared-55.x86\_64 0:5.5.30-rel30.2.508.rhel6 will be installed  
 → Finished Dependency Resolution

Dependencies Resolved

================================================== ================================================== ================================================== ====================  
Package Arch Version Repository Size  
================================================== ================================================== ================================================== ====================  
Installing:  
Percona-Server-client-55 x86\_64 5.5.30-rel30.2.508.rhel6 percona 6.1 M  
Percona-Server-server-55 x86\_64 5.5.30-rel30.2.508.rhel6 percona 15 M  
Percona-Server-shared-compat x86\_64 5.5.30-rel30.2.508.rhel6 percona 3.4 M  
Installing for dependencies:  
Percona-Server-shared-55 x86\_64 5.5.30-rel30.2.508.rhel6 percona 663 k

Transaction Summary  
================================================== ================================================== ================================================== ====================  
Install 4 Package(s)

Total download size: 25 M  
Installed size: 106 M  
Downloading Packages:  
Setting up and reading Presto delta metadata  
Processing delta metadata  
Package(s) data still to download: 25 M  
[URL=“[http://repo.percona.com/centos/6/os/x86\_64/Percona-Server-client-55-5.5.30-rel30.2.508.rhel6.x86\_64.rpm:](http://repo.percona.com/centos/6/os/x86_64/Percona-Server-client-55-5.5.30-rel30.2.508.rhel6.x86_64.rpm:)”][http://repo.percona.com/centos/6/os/...l6.x86\_64.rpm:[/URL=“http://repo.percona.com/centos/6/os/x86\_64/Percona-Server-client-55-5.5.30-rel30.2.508.rhel6.x86\_64.rpm:”]](http://repo.percona.com/centos/6/os/...l6.x86_64.rpm:%5B/URL=%22http://repo.percona.com/centos/6/os/x86_64/Percona-Server-client-55-5.5.30-rel30.2.508.rhel6.x86_64.rpm:%22%5D) [Errno 14] PYCURL ERROR 22 - “The requested URL returned error: 404 Not Found”  
Trying other mirror.  
[URL=“[http://repo.percona.com/centos/6/os/x86\_64/Percona-Server-server-55-5.5.30-rel30.2.508.rhel6.x86\_64.rpm:](http://repo.percona.com/centos/6/os/x86_64/Percona-Server-server-55-5.5.30-rel30.2.508.rhel6.x86_64.rpm:)”][http://repo.percona.com/centos/6/os/...l6.x86\_64.rpm:[/URL=“http://repo.percona.com/centos/6/os/x86\_64/Percona-Server-server-55-5.5.30-rel30.2.508.rhel6.x86\_64.rpm:”]](http://repo.percona.com/centos/6/os/...l6.x86_64.rpm:%5B/URL=%22http://repo.percona.com/centos/6/os/x86_64/Percona-Server-server-55-5.5.30-rel30.2.508.rhel6.x86_64.rpm:%22%5D) [Errno 14] PYCURL ERROR 22 - “The requested URL returned error: 404 Not Found”  
Trying other mirror.  
[URL=“[http://repo.percona.com/centos/6/os/x86\_64/Percona-Server-shared-55-5.5.30-rel30.2.508.rhel6.x86\_64.rpm:](http://repo.percona.com/centos/6/os/x86_64/Percona-Server-shared-55-5.5.30-rel30.2.508.rhel6.x86_64.rpm:)”][http://repo.percona.com/centos/6/os/...l6.x86\_64.rpm:[/URL=“http://repo.percona.com/centos/6/os/x86\_64/Percona-Server-shared-55-5.5.30-rel30.2.508.rhel6.x86\_64.rpm:”]](http://repo.percona.com/centos/6/os/...l6.x86_64.rpm:%5B/URL=%22http://repo.percona.com/centos/6/os/x86_64/Percona-Server-shared-55-5.5.30-rel30.2.508.rhel6.x86_64.rpm:%22%5D) [Errno 14] PYCURL ERROR 22 - “The requested URL returned error: 404 Not Found”  
Trying other mirror.  
(4/4): Percona-Server-shared-compat-5.5.30-rel30.2.508.rhel6.x86\_64.rpm | 3.4 MB 00:01

Error Downloading Packages:  
Percona-Server-client-55-5.5.30-rel30.2.508.rhel6.x86\_64: failure: Percona-Server-client-55-5.5.30-rel30.2.508.rhel6.x86\_64.rpm from percona: [Errno 256] No more mirrors to try.  
Percona-Server-shared-55-5.5.30-rel30.2.508.rhel6.x86\_64: failure: Percona-Server-shared-55-5.5.30-rel30.2.508.rhel6.x86\_64.rpm from percona: [Errno 256] No more mirrors to try.  
Percona-Server-server-55-5.5.30-rel30.2.508.rhel6.x86\_64: failure: Percona-Server-server-55-5.5.30-rel30.2.508.rhel6.x86\_64.rpm from percona: [Errno 256] No more mirrors to try.

---

<div class="post-metadata">

**Author:** ![revin](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/revin/32/824_2.png) [@revin](https://forums.percona.com/u/revin)\
**Post date:** [May 16, 2013, 3:32am UTC](https://forums.percona.com/t/the-yum-repo-is-currently-broken/2683/2 "2013-05-16T03:32:23Z")

</div>

Looks like the binaries were updated from 508 to 509, can you do a yum update and try again?

---

<div class="post-metadata">

**Author:** ![starkers](https://avatars.discourse-cdn.com/v4/letter/s/50afbb/32.png) [@starkers](https://forums.percona.com/u/starkers)\
**Post date:** [May 16, 2013, 4:18am UTC](https://forums.percona.com/t/the-yum-repo-is-currently-broken/2683/3 "2013-05-16T04:18:18Z")

</div>

Thats what I said LOL, did an update, repo still broken

---

<div class="post-metadata">

**Author:** ![starkers](https://avatars.discourse-cdn.com/v4/letter/s/50afbb/32.png) [@starkers](https://forums.percona.com/u/starkers)\
**Post date:** [May 16, 2013, 11:34am UTC](https://forums.percona.com/t/the-yum-repo-is-currently-broken/2683/4 "2013-05-16T11:34:16Z")

</div>

Just ran another update and this has been fixed thanks
