# The binary installation of Percona-XtraDB-Cluster\_8.0.33 reports an error when starting the second node.

**URL:** <https://forums.percona.com/t/the-binary-installation-of-percona-xtradb-cluster-8-0-33-reports-an-error-when-starting-the-second-node/38888>\
**Category:** Percona XtraDB Cluster 8.x\
**Created:** [July 30, 2025, 10:17am UTC](https://forums.percona.com/t/the-binary-installation-of-percona-xtradb-cluster-8-0-33-reports-an-error-when-starting-the-second-node/38888 "2025-07-30T10:17:13Z")\
**Posts on this page:** 15\
**Page:** 1

<div class="post-metadata">

**Author:** ![iconvnet\_iconvnet](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/iconvnet_iconvnet/32/20734_2.png) [@iconvnet\_iconvnet](https://forums.percona.com/u/iconvnet_iconvnet)\
**Post date:** [July 30, 2025, 10:17am UTC](https://forums.percona.com/t/the-binary-installation-of-percona-xtradb-cluster-8-0-33-reports-an-error-when-starting-the-second-node/38888/1 "2025-07-30T10:17:13Z")

</div>

2025-07-30T09:49:43.527627Z 0 [Note] [MY-000000] [Galera] Flow-control interval: [141, 141]  
2025-07-30T09:49:43.527636Z 0 [Note] [MY-000000] [Galera] Shifting OPEN → PRIMARY (TO: 4)  
2025-07-30T09:49:43.527903Z 1 [Note] [MY-000000] [Galera] ####### processing CC 4, local, ordered  
2025-07-30T09:49:43.527927Z 1 [Note] [MY-000000] [Galera] Maybe drain monitors from -1 upto current CC event 4 upto:-1  
2025-07-30T09:49:43.527940Z 1 [Note] [MY-000000] [Galera] Drain monitors from -1 up to -1  
2025-07-30T09:49:43.527952Z 1 [Note] [MY-000000] [Galera] Process first view: 052579f3-6d28-11f0-9acd-53a01cf00a02 my uuid: 845d61f7-6d2a-11f0-8d8b-9e337ef25f73  
2025-07-30T09:49:43.527971Z 1 [Note] [MY-000000] [Galera] Server ptt5 connected to cluster at position 052579f3-6d28-11f0-9acd-53a01cf00a02:4 with ID 845d61f7-6d2a-11f0-8d8b-9e337ef25f73  
2025-07-30T09:49:43.527983Z 1 [Note] [MY-000000] [WSREP] Server status change disconnected → connected  
2025-07-30T09:49:43.528002Z 1 [Note] [MY-000000] [WSREP] wsrep\_notify\_cmd is not defined, skipping notification.  
2025-07-30T09:49:43.528029Z 1 [Note] [MY-000000] [Galera] ####### My UUID: 845d61f7-6d2a-11f0-8d8b-9e337ef25f73  
2025-07-30T09:49:43.528041Z 1 [Note] [MY-000000] [Galera] Cert index reset to 00000000-0000-0000-0000-000000000000:-1 (proto: 10), state transfer needed: yes  
2025-07-30T09:49:43.528137Z 0 [Note] [MY-000000] [Galera] Service thread queue flushed.  
2025-07-30T09:49:43.528194Z 1 [Note] [MY-000000] [Galera] ####### Assign initial position for certification: 00000000-0000-0000-0000-000000000000:-1, protocol version: -1  
2025-07-30T09:49:43.528219Z 1 [Note] [MY-000000] [Galera] State transfer required:  
Group state: 052579f3-6d28-11f0-9acd-53a01cf00a02:4  
Local state: 00000000-0000-0000-0000-000000000000:-1  
2025-07-30T09:49:43.528231Z 1 [Note] [MY-000000] [WSREP] Server status change connected → joiner  
2025-07-30T09:49:43.528241Z 1 [Note] [MY-000000] [WSREP] wsrep\_notify\_cmd is not defined, skipping notification.  
2025-07-30T09:49:43.528442Z 0 [Note] [MY-000000] [WSREP] Initiating SST/IST transfer on JOINER side (wsrep\_sst\_xtrabackup-v2 --role ‘joiner’ --address ‘172.16.57.14’ --datadir ‘/home/pxc80/data/’ --basedir ‘/home/pxc80/’ --plugindir ‘/home/pxc80/lib/plugin/’ --defaults-file ‘/home/pxc80/etc/my.cnf’ --defaults-group-suffix ‘’ --parent ‘66954’ --mysqld-version ‘8.0.33-25.1’ ‘’ )  
2025-07-30T09:49:44.098768Z 0 [Warning] [MY-000000] [WSREP-SST] Found a stale sst\_in\_progress file: /home/pxc80/data//sst\_in\_progress  
2025-07-30T09:49:44.134044Z 0 [ERROR] [MY-000000] [WSREP] Failed to read ‘ready ’ from: wsrep\_sst\_xtrabackup-v2 --role ‘joiner’ --address ‘172.16.57.14’ --datadir ‘/home/pxc80/data/’ --basedir ‘/home/pxc80/’ --plugindir ‘/home/pxc80/lib/plugin/’ --defaults-file ‘/home/pxc80/etc/my.cnf’ --defaults-group-suffix ‘’ --parent ‘66954’ --mysqld-version ‘8.0.33-25.1’ ‘’  
Read: ‘(null)’  
2025-07-30T09:49:44.134100Z 0 [ERROR] [MY-000000] [WSREP] Process completed with error: wsrep\_sst\_xtrabackup-v2 --role ‘joiner’ --address ‘172.16.57.14’ --datadir ‘/home/pxc80/data/’ --basedir ‘/home/pxc80/’ --plugindir ‘/home/pxc80/lib/plugin/’ --defaults-file ‘/home/pxc80/etc/my.cnf’ --defaults-group-suffix ‘’ --parent ‘66954’ --mysqld-version ‘8.0.33-25.1’ ‘’ : 1 (Operation not permitted)  
2025-07-30T09:49:44.134172Z 1 [ERROR] [MY-000000] [WSREP] Failed to prepare for ‘xtrabackup-v2’ SST. Unrecoverable.  
2025-07-30T09:49:44.134339Z 1 [ERROR] [MY-000000] [Galera] SST request callback failed. This is unrecoverable, restart required.  
2025-07-30T09:49:44.134355Z 1 [Note] [MY-000000] [Galera] ReplicatorSMM::abort()  
2025-07-30T09:49:44.134365Z 1 [Note] [MY-000000] [Galera] Closing send monitor…  
2025-07-30T09:49:44.134374Z 1 [Note] [MY-000000] [Galera] Closed send monitor.  
2025-07-30T09:49:44.134383Z 1 [Note] [MY-000000] [Galera] gcomm: terminating thread  
2025-07-30T09:49:44.134429Z 1 [Note] [MY-000000] [Galera] gcomm: joining thread  
2025-07-30T09:49:44.134529Z 1 [Note] [MY-000000] [Galera] gcomm: closing backend  
2025-07-30T09:49:45.136505Z 1 [Note] [MY-000000] [Galera] Current view of cluster as seen by this node  
view (view\_id(NON\_PRIM,0523041a-b0d9,4)  
memb {  
845d61f7-8d8b,0  
}  
joined {  
}  
left {  
}  
partitioned {  
0523041a-b0d9,0  
}  
)  
2025-07-30T09:49:45.136602Z 1 [Note] [MY-000000] [Galera] PC protocol downgrade 1 → 0  
2025-07-30T09:49:45.136627Z 1 [Note] [MY-000000] [Galera] Current view of cluster as seen by this node  
view ((empty))  
2025-07-30T09:49:45.136803Z 1 [Note] [MY-000000] [Galera] gcomm: closed  
2025-07-30T09:49:45.136854Z 0 [Note] [MY-000000] [Galera] New COMPONENT: primary = no, bootstrap = no, my\_idx = 0, memb\_num = 1  
2025-07-30T09:49:45.136897Z 0 [Note] [MY-000000] [Galera] Flow-control interval: [100, 100]  
2025-07-30T09:49:45.136907Z 0 [Note] [MY-000000] [Galera] Received NON-PRIMARY.  
2025-07-30T09:49:45.136914Z 0 [Note] [MY-000000] [Galera] Shifting PRIMARY → OPEN (TO: 4)  
2025-07-30T09:49:45.136923Z 0 [Note] [MY-000000] [Galera] New SELF-LEAVE.  
2025-07-30T09:49:45.136937Z 0 [Note] [MY-000000] [Galera] Flow-control interval: [0, 0]  
2025-07-30T09:49:45.136944Z 0 [Note] [MY-000000] [Galera] Received SELF-LEAVE. Closing connection.  
2025-07-30T09:49:45.136951Z 0 [Note] [MY-000000] [Galera] Shifting OPEN → CLOSED (TO: 4)  
2025-07-30T09:49:45.136959Z 0 [Note] [MY-000000] [Galera] RECV thread exiting 0: Success  
2025-07-30T09:49:45.137035Z 1 [Note] [MY-000000] [Galera] recv\_thread() joined.  
2025-07-30T09:49:45.137049Z 1 [Note] [MY-000000] [Galera] Closing replication queue.  
2025-07-30T09:49:45.137056Z 1 [Note] [MY-000000] [Galera] Closing slave action queue.  
2025-07-30T09:49:45.137077Z 1 [Note] [MY-000000] [Galera] /home/pxc80/bin/mysqld: Terminated.  
2025-07-30T09:49:45.137089Z 1 [Note] [MY-000000] [WSREP] Initiating SST cancellation

---

<div class="post-metadata">

**Author:** ![Vadim\_Yalovets](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/vadim_yalovets/32/43_2.png) [@Vadim\_Yalovets](https://forums.percona.com/u/Vadim_Yalovets)\
**Post date:** [July 30, 2025, 11:35am UTC](https://forums.percona.com/t/the-binary-installation-of-percona-xtradb-cluster-8-0-33-reports-an-error-when-starting-the-second-node/38888/2 "2025-07-30T11:35:08Z")

</div>

Hi @iconvnet_iconvnet

Could you share used my.cnf file on the second node?

---

<div class="post-metadata">

**Author:** ![Abhinav\_Gupta](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/abhinav_gupta/32/6262_2.png) [@Abhinav\_Gupta](https://forums.percona.com/u/Abhinav_Gupta)\
**Post date:** [July 30, 2025, 1:50pm UTC](https://forums.percona.com/t/the-binary-installation-of-percona-xtradb-cluster-8-0-33-reports-an-error-when-starting-the-second-node/38888/3 "2025-07-30T13:50:23Z")

</div>

Please ensure both your joiner and donor nodes have the “Percona XtraBackup 8.0.33-27” installed.

---

<div class="post-metadata">

**Author:** ![matthewb](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/matthewb/32/34_2.png) [@matthewb](https://forums.percona.com/u/matthewb)\
**Post date:** [July 30, 2025, 2:09pm UTC](https://forums.percona.com/t/the-binary-installation-of-percona-xtradb-cluster-8-0-33-reports-an-error-when-starting-the-second-node/38888/4 "2025-07-30T14:09:54Z")

</div>

Hello @iconvnet_iconvnet,

You have not given much information. You did not tell us the OS, or share the my.cnf file. Do you have SELinux enabled? Have you opened all the proper ports between nodes? Have you tested connectivity using telent, or socat? What do the logs on the donor node say?

---

<div class="post-metadata">

**Author:** ![iconvnet\_iconvnet](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/iconvnet_iconvnet/32/20734_2.png) [@iconvnet\_iconvnet](https://forums.percona.com/u/iconvnet_iconvnet)\
**Post date:** [July 31, 2025, 2:43am UTC](https://forums.percona.com/t/the-binary-installation-of-percona-xtradb-cluster-8-0-33-reports-an-error-when-starting-the-second-node/38888/5 "2025-07-31T02:43:24Z")

</div>

```auto

```

```auto
Template my.cnf for PXC

```

```auto
Edit to your requirements.

```

```auto
[client]socket=/home/pxc80/mysql.sock

```

```auto
[mysqld]port=14543server-id=1datadir=/home/pxc80/datasocket=/home/pxc80/mysql.socklog-error=/home/pxc80/logs/mysqld.logpid-file=/home/pxc80/mysqld.pidlog-binlog_slave_updatesexpire_logs_days=7max_connections=3000slow_query_log=1slow_query_log_file=/home/pxc80/logs/slow.loglong_query_time=2#sql_mode = “STRICT_TRANS_TABLES,NO_ZERO_IN_DATE,NO_ZERO_DATE,ERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION”sql_mode = “NO_ENGINE_SUBSTITUTION,STRICT_TRANS_TABLES”innodb_buffer_pool_size = 4Gexpire_logs_days = 1log_error_verbosity = 3

```

```auto
Disabling symbolic-links is recommended to prevent assorted security risks

```

```auto
symbolic-links=0

```

```auto
wsrep_provider=/usr/lib/libgalera_smm.sowsrep_cluster_address=gcomm://172.16.57.15,172.16.57.14,172.16.57.13binlog_format=ROWdefault_storage_engine=InnoDBwsrep_slave_threads=30wsrep_log_conflictsinnodb_autoinc_lock_mode=2wsrep_node_address=172.16.57.14wsrep_cluster_name=pxc-clusterwsrep_node_name=ptt5pxc_strict_mode=PERMISSIVE

```

```auto
SST method

```

```auto
wsrep_sst_method=xtrabackup-v2xtrabackup_bin=/usr/bin/xtrabackup#wsrep_sst_method=mysqldump#wsrep_provider_options=“socket.ssl_key=server-key.pem;socket.ssl_cert=server-cert.pem;socket.ssl_ca=ca.pem”[sst]encrypt=4ssl-key=server-key.pemssl-ca=ca.pemssl-cert=server-cert.pe

```

Matthew Boehm via Percona Community Forum \<[notifications@percona1.discoursemail.com](mailto:notifications@percona1.discoursemail.com)\> 于2025年7月30日周三 22:10写道：

---

<div class="post-metadata">

**Author:** ![iconvnet\_iconvnet](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/iconvnet_iconvnet/32/20734_2.png) [@iconvnet\_iconvnet](https://forums.percona.com/u/iconvnet_iconvnet)\
**Post date:** [July 31, 2025, 2:44am UTC](https://forums.percona.com/t/the-binary-installation-of-percona-xtradb-cluster-8-0-33-reports-an-error-when-starting-the-second-node/38888/6 "2025-07-31T02:44:23Z")

</div>

My operating system is Ubuntu 24.04, and Selinux is not enabled

iconvnet iconvnet \<[inricomapapi@gmail.com](mailto:inricomapapi@gmail.com)\> 于2025年7月31日周四 10:43写道：

---

<div class="post-metadata">

**Author:** ![iconvnet\_iconvnet](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/iconvnet_iconvnet/32/20734_2.png) [@iconvnet\_iconvnet](https://forums.percona.com/u/iconvnet_iconvnet)\
**Post date:** [July 31, 2025, 2:47am UTC](https://forums.percona.com/t/the-binary-installation-of-percona-xtradb-cluster-8-0-33-reports-an-error-when-starting-the-second-node/38888/7 "2025-07-31T02:47:32Z")

</div>

All ports between servers are open

iconvnet iconvnet \<[inricomapapi@gmail.com](mailto:inricomapapi@gmail.com)\> 于2025年7月31日周四 10:46写道：

---

<div class="post-metadata">

**Author:** ![iconvnet\_iconvnet](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/iconvnet_iconvnet/32/20734_2.png) [@iconvnet\_iconvnet](https://forums.percona.com/u/iconvnet_iconvnet)\
**Post date:** [July 31, 2025, 2:55am UTC](https://forums.percona.com/t/the-binary-installation-of-percona-xtradb-cluster-8-0-33-reports-an-error-when-starting-the-second-node/38888/8 "2025-07-31T02:55:57Z")

</div>

At the beginning, xtrabackup version 8.0.35-33 was installed, but synchronization failed. Later, I changed the version of the second node to xtrabackup version 8.0.33-28, but it still failed

---

<div class="post-metadata">

**Author:** ![Abhinav\_Gupta](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/abhinav_gupta/32/6262_2.png) [@Abhinav\_Gupta](https://forums.percona.com/u/Abhinav_Gupta)\
**Post date:** [July 31, 2025, 3:23pm UTC](https://forums.percona.com/t/the-binary-installation-of-percona-xtradb-cluster-8-0-33-reports-an-error-when-starting-the-second-node/38888/9 "2025-07-31T15:23:13Z")

</div>

Before PXC 8.0.34, it was required to use matching versions of both the database and `xtrabackup`. Please ensure that all nodes in the cluster are running the same versions of MySQL and `xtrabackup`.

If the issue persists, review the `innobackupex` log on the donor node to verify whether the backup process starts correctly, and if it fails, check for the specific error message reported.

> **[Percona XtraBackup - Supported versions](https://docs.percona.com/percona-xtrabackup/8.0/supported-versions.html)**
>
> Percona XtraBackup 8.0.35-33 supports backing up databases compatible with server version 8.0.34 and later. Percona XtraBackup 8.0.35-33 can create backups of older server versions when you override the server version check and enable specific...

> **[Percona XtraBackup - Percona XtraBackup 8.0.34-29 (2023-08-21)](https://docs.percona.com/percona-xtrabackup/8.0/release-notes/8.0/8.0.34-29.0.html#release-highlights)**
>
> Get started with Quickstart Guide for Percona XtraBackup.

---

<div class="post-metadata">

**Author:** ![iconvnet\_iconvnet](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/iconvnet_iconvnet/32/20734_2.png) [@iconvnet\_iconvnet](https://forums.percona.com/u/iconvnet_iconvnet)\
**Post date:** [August 2, 2025, 2:50am UTC](https://forums.percona.com/t/the-binary-installation-of-percona-xtradb-cluster-8-0-33-reports-an-error-when-starting-the-second-node/38888/10 "2025-08-02T02:50:53Z")

</div>

I have now switched to the same version and the following error is reported.

2025-08-02T03:14:10.804730Z 0 [Note] [MY-000000] [Galera] STATE EXCHANGE: got state msg: c219d7b7-6f4e-11f0-8941-3e0b760d9869 from 0 (ptt7)  
2025-08-02T03:14:10.805051Z 2 [Note] [MY-000000] [WSREP] Starting rollbacker thread 2  
2025-08-02T03:14:10.805203Z 0 [Note] [MY-000000] [Galera] STATE EXCHANGE: got state msg: c219d7b7-6f4e-11f0-8941-3e0b760d9869 from 1 (ptt5)  
2025-08-02T03:14:10.805220Z 0 [Note] [MY-000000] [Galera] Quorum results:  
version = 6,  
component = PRIMARY,  
conf\_id = 1,  
members = 1/2 (primary/total),  
act\_id = 1,  
last\_appl. = 0,  
protocols = 2/10/4 (gcs/repl/appl),  
vote policy= 0,  
group UUID = 5cc84d7a-6f4a-11f0-8828-a2acfcf3bd92  
2025-08-02T03:14:10.805276Z 0 [Note] [MY-000000] [Galera] Flow-control interval: [141, 141]  
2025-08-02T03:14:10.805285Z 0 [Note] [MY-000000] [Galera] Shifting OPEN → PRIMARY (TO: 2)  
2025-08-02T03:14:10.805406Z 1 [Note] [MY-000000] [WSREP] Starting applier thread 1  
2025-08-02T03:14:10.805450Z 1 [Note] [MY-000000] [Galera] ####### processing CC 2, local, ordered  
2025-08-02T03:14:10.805484Z 1 [Note] [MY-000000] [Galera] Maybe drain monitors from -1 upto current CC event 2 upto:-1  
2025-08-02T03:14:10.805508Z 1 [Note] [MY-000000] [Galera] Drain monitors from -1 up to -1  
2025-08-02T03:14:10.805539Z 1 [Note] [MY-000000] [Galera] Process first view: 5cc84d7a-6f4a-11f0-8828-a2acfcf3bd92 my uuid: c1cc7f94-6f4e-11f0-a271-262e614fc5af  
2025-08-02T03:14:10.805574Z 1 [Note] [MY-000000] [Galera] Server ptt5 connected to cluster at position 5cc84d7a-6f4a-11f0-8828-a2acfcf3bd92:2 with ID c1cc7f94-6f4e-11f0-a271-262e614fc5af  
2025-08-02T03:14:10.805600Z 1 [Note] [MY-000000] [WSREP] Server status change disconnected → connected  
2025-08-02T03:14:10.805654Z 1 [Note] [MY-000000] [WSREP] wsrep\_notify\_cmd is not defined, skipping notification.  
2025-08-02T03:14:10.805706Z 1 [Note] [MY-000000] [Galera] ####### My UUID: c1cc7f94-6f4e-11f0-a271-262e614fc5af  
2025-08-02T03:14:10.805739Z 1 [Note] [MY-000000] [Galera] Cert index reset to 00000000-0000-0000-0000-000000000000:-1 (proto: 10), state transfer needed: yes  
2025-08-02T03:14:10.805839Z 0 [Note] [MY-000000] [Galera] Service thread queue flushed.  
2025-08-02T03:14:10.805945Z 1 [Note] [MY-000000] [Galera] ####### Assign initial position for certification: 00000000-0000-0000-0000-000000000000:-1, protocol version: -1  
2025-08-02T03:14:10.805973Z 1 [Note] [MY-000000] [Galera] State transfer required:  
Group state: 5cc84d7a-6f4a-11f0-8828-a2acfcf3bd92:2  
Local state: 00000000-0000-0000-0000-000000000000:-1  
2025-08-02T03:14:10.806009Z 1 [Note] [MY-000000] [WSREP] Server status change connected → joiner  
2025-08-02T03:14:10.806032Z 1 [Note] [MY-000000] [WSREP] wsrep\_notify\_cmd is not defined, skipping notification.  
2025-08-02T03:14:10.806209Z 0 [Note] [MY-000000] [WSREP] Initiating SST/IST transfer on JOINER side (wsrep\_sst\_xtrabackup-v2 --role ‘joiner’ --address ‘172.16.57.14’ --datadir ‘/home/pxc80/data/’ --basedir ‘/home/pxc80/’ --plugindir ‘/home/pxc80/lib/plugin/’ --defaults-file ‘/home/pxc80/etc/my.cnf’ --defaults-group-suffix ‘’ --parent ‘191237’ --mysqld-version ‘8.0.33-25.1’ ‘’ )  
2025-08-02T03:14:11.741145Z 0 [ERROR] [MY-000000] [WSREP] Failed to read ‘ready ’ from: wsrep\_sst\_xtrabackup-v2 --role ‘joiner’ --address ‘172.16.57.14’ --datadir ‘/home/pxc80/data/’ --basedir ‘/home/pxc80/’ --plugindir ‘/home/pxc80/lib/plugin/’ --defaults-file ‘/home/pxc80/etc/my.cnf’ --defaults-group-suffix ‘’ --parent ‘191237’ --mysqld-version ‘8.0.33-25.1’ ‘’  
Read: ‘(null)’  
2025-08-02T03:14:11.741215Z 0 [ERROR] [MY-000000] [WSREP] Process completed with error: wsrep\_sst\_xtrabackup-v2 --role ‘joiner’ --address ‘172.16.57.14’ --datadir ‘/home/pxc80/data/’ --basedir ‘/home/pxc80/’ --plugindir ‘/home/pxc80/lib/plugin/’ --defaults-file ‘/home/pxc80/etc/my.cnf’ --defaults-group-suffix ‘’ --parent ‘191237’ --mysqld-version ‘8.0.33-25.1’ ‘’ : 1 (Operation not permitted)  
2025-08-02T03:14:11.741283Z 1 [ERROR] [MY-000000] [WSREP] Failed to prepare for ‘xtrabackup-v2’ SST. Unrecoverable.  
2025-08-02T03:14:11.748150Z 1 [ERROR] [MY-000000] [Galera] SST request callback failed. This is unrecoverable, restart required.  
2025-08-02T03:14:11.748193Z 1 [Note] [MY-000000] [Galera] ReplicatorSMM::abort()  
2025-08-02T03:14:11.748205Z 1 [Note] [MY-000000] [Galera] Closing send monitor…  
2025-08-02T03:14:11.748213Z 1 [Note] [MY-000000] [Galera] Closed send monitor.  
2025-08-02T03:14:11.748222Z 1 [Note] [MY-000000] [Galera] gcomm: terminating thread  
2025-08-02T03:14:11.748241Z 1 [Note] [MY-000000] [Galera] gcomm: joining thread  
2025-08-02T03:14:11.748361Z 1 [Note] [MY-000000] [Galera] gcomm: closing backend  
2025-08-02T03:14:12.750473Z 1 [Note] [MY-000000] [Galera] Current view of cluster as seen by this node  
view (view\_id(NON\_PRIM,5cc7ed6c-b5f7,2)  
memb {  
c1cc7f94-a271,0  
}  
joined {  
}  
left {  
}  
partitioned {  
5cc7ed6c-b5f7,0  
}  
)  
2025-08-02T03:14:12.750575Z 1 [Note] [MY-000000] [Galera] PC protocol downgrade 1 → 0  
2025-08-02T03:14:12.750590Z 1 [Note] [MY-000000] [Galera] Current view of cluster as seen by this node  
view ((empty))  
2025-08-02T03:14:12.750769Z 1 [Note] [MY-000000] [Galera] gcomm: closed  
2025-08-02T03:14:12.750818Z 0 [Note] [MY-000000] [Galera] New COMPONENT: primary = no, bootstrap = no, my\_idx = 0, memb\_num = 1  
2025-08-02T03:14:12.750898Z 0 [Note] [MY-000000] [Galera] Flow-control interval: [100, 100]  
2025-08-02T03:14:12.750910Z 0 [Note] [MY-000000] [Galera] Received NON-PRIMARY.  
2025-08-02T03:14:12.750917Z 0 [Note] [MY-000000] [Galera] Shifting PRIMARY → OPEN (TO: 2)  
2025-08-02T03:14:12.750927Z 0 [Note] [MY-000000] [Galera] New SELF-LEAVE.  
2025-08-02T03:14:12.750941Z 0 [Note] [MY-000000] [Galera] Flow-control interval: [0, 0]  
2025-08-02T03:14:12.750949Z 0 [Note] [MY-000000] [Galera] Received SELF-LEAVE. Closing connection.  
2025-08-02T03:14:12.750955Z 0 [Note] [MY-000000] [Galera] Shifting OPEN → CLOSED (TO: 2)  
2025-08-02T03:14:12.750963Z 0 [Note] [MY-000000] [Galera] RECV thread exiting 0: Success  
2025-08-02T03:14:12.751148Z 1 [Note] [MY-000000] [Galera] recv\_thread() joined.  
2025-08-02T03:14:12.751172Z 1 [Note] [MY-000000] [Galera] Closing replication queue.  
2025-08-02T03:14:12.751181Z 1 [Note] [MY-000000] [Galera] Closing slave action queue.  
2025-08-02T03:14:12.751196Z 1 [Note] [MY-000000] [Galera] /home/pxc80/bin/mysqld: Terminated.  
2025-08-02T03:14:12.751204Z 1 [Note] [MY-000000] [WSREP] Initiating SST cancellation

---

<div class="post-metadata">

**Author:** ![matthewb](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/matthewb/32/34_2.png) [@matthewb](https://forums.percona.com/u/matthewb)\
**Post date:** [August 2, 2025, 3:03am UTC](https://forums.percona.com/t/the-binary-installation-of-percona-xtradb-cluster-8-0-33-reports-an-error-when-starting-the-second-node/38888/11 "2025-08-02T03:03:56Z")

</div>

The gcomm:// URI is missing port information. Please add back port information on node1 and restart it. Then add ports to gcomm on node2 and start.

---

<div class="post-metadata">

**Author:** ![iconvnet\_iconvnet](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/iconvnet_iconvnet/32/20734_2.png) [@iconvnet\_iconvnet](https://forums.percona.com/u/iconvnet_iconvnet)\
**Post date:** [August 2, 2025, 3:18am UTC](https://forums.percona.com/t/the-binary-installation-of-percona-xtradb-cluster-8-0-33-reports-an-error-when-starting-the-second-node/38888/12 "2025-08-02T03:18:10Z")

</div>

**This is the log of the donated server**

# =================================================

2025-08-02T03:14:12.753596Z 1 [Note] [MY-000000] [WSREP] wsrep\_notify\_cmd is not defined, skipping notification.  
2025-08-02T03:14:12.756275Z 1 [Note] [MY-000000] [Galera] Recording CC from group: 3  
2025-08-02T03:14:12.756312Z 1 [Note] [MY-000000] [Galera] Lowest cert index boundary for CC from group: 3  
2025-08-02T03:14:12.756324Z 1 [Note] [MY-000000] [Galera] Min available from gcache for CC from group: 1  
2025-08-02T03:14:13.021290Z 0 [Note] [MY-000000] [Galera] (5cc7ed6c-b5f7, ‘ssl://0.0.0.0:4567’) turning message relay requesting off  
2025-08-02T03:14:18.021806Z 0 [Note] [MY-000000] [Galera] cleaning up c1cc7f94-a271 (ssl://172.16.57.14:4567)  
2025-08-02T03:17:07.746461Z 0 [Note] [MY-000000] [Galera] (5cc7ed6c-b5f7, ‘ssl://0.0.0.0:4567’) connection established to 2bdb1c6f-9225 ssl://172.16.57.14:4567  
2025-08-02T03:17:07.746898Z 0 [Note] [MY-000000] [Galera] (5cc7ed6c-b5f7, ‘ssl://0.0.0.0:4567’) turning message relay requesting on, nonlive peers:  
2025-08-02T03:17:07.765881Z 0 [Note] [MY-000000] [Galera] declaring 2bdb1c6f-9225 at ssl://172.16.57.14:4567 stable  
2025-08-02T03:17:07.766221Z 0 [Note] [MY-000000] [Galera] Node 5cc7ed6c-b5f7 state primary  
2025-08-02T03:17:07.767954Z 0 [Note] [MY-000000] [Galera] Current view of cluster as seen by this node  
view (view\_id(PRIM,2bdb1c6f-9225,4)  
memb {  
2bdb1c6f-9225,0  
5cc7ed6c-b5f7,0  
}  
joined {  
}  
left {  
}  
partitioned {  
}  
)  
2025-08-02T03:17:07.768016Z 0 [Note] [MY-000000] [Galera] Save the discovered primary-component to disk  
2025-08-02T03:17:07.769151Z 0 [Note] [MY-000000] [Galera] New COMPONENT: primary = yes, bootstrap = no, my\_idx = 1, memb\_num = 2  
2025-08-02T03:17:07.769201Z 0 [Note] [MY-000000] [Galera] STATE EXCHANGE: Waiting for state UUID.  
2025-08-02T03:17:08.241415Z 0 [Note] [MY-000000] [Galera] STATE EXCHANGE: sent state msg: 2c27b09d-6f4f-11f0-9f24-d62068d8eecf  
2025-08-02T03:17:08.241701Z 0 [Note] [MY-000000] [Galera] STATE EXCHANGE: got state msg: 2c27b09d-6f4f-11f0-9f24-d62068d8eecf from 0 (ptt5)  
2025-08-02T03:17:08.241749Z 0 [Note] [MY-000000] [Galera] STATE EXCHANGE: got state msg: 2c27b09d-6f4f-11f0-9f24-d62068d8eecf from 1 (ptt7)  
2025-08-02T03:17:08.241766Z 0 [Note] [MY-000000] [Galera] Quorum results:  
version = 6,  
component = PRIMARY,  
conf\_id = 3,  
members = 1/2 (primary/total),  
act\_id = 3,  
last\_appl. = 0,  
protocols = 2/10/4 (gcs/repl/appl),  
vote policy= 0,  
group UUID = 5cc84d7a-6f4a-11f0-8828-a2acfcf3bd92  
2025-08-02T03:17:08.241834Z 0 [Note] [MY-000000] [Galera] Flow-control interval: [141, 141]  
2025-08-02T03:17:08.242027Z 1 [Note] [MY-000000] [Galera] ####### processing CC 4, local, ordered  
2025-08-02T03:17:08.242056Z 1 [Note] [MY-000000] [Galera] Maybe drain monitors from 3 upto current CC event 4 upto:3  
2025-08-02T03:17:08.242068Z 1 [Note] [MY-000000] [Galera] Drain monitors from 3 up to 3  
2025-08-02T03:17:08.242080Z 1 [Note] [MY-000000] [Galera] ####### My UUID: 5cc7ed6c-6f4a-11f0-b5f7-23483fc52e4a  
2025-08-02T03:17:08.242090Z 1 [Note] [MY-000000] [Galera] Skipping cert index reset  
2025-08-02T03:17:08.242099Z 1 [Note] [MY-000000] [Galera] REPL Protocols: 10 (5)  
2025-08-02T03:17:08.242108Z 1 [Note] [MY-000000] [Galera] ####### Adjusting cert position: 3 → 4  
2025-08-02T03:17:08.242145Z 0 [Note] [MY-000000] [Galera] Service thread queue flushed.  
2025-08-02T03:17:08.243662Z 1 [Note] [MY-000000] [Galera] ================================================  
View:  
id: 5cc84d7a-6f4a-11f0-8828-a2acfcf3bd92:4  
status: primary  
protocol\_version: 4  
capabilities: MULTI-MASTER, CERTIFICATION, PARALLEL\_APPLYING, REPLAY, ISOLATION, PAUSE, CAUSAL\_READ, INCREMENTAL\_WS, UNORDERED, PREORDERED, STREAMING, NBO  
final: no  
own\_index: 1  
members(2):  
0: 2bdb1c6f-6f4f-11f0-9225-5716298992bf, ptt5  
1: 5cc7ed6c-6f4a-11f0-b5f7-23483fc52e4a, ptt7

# 2025-08-02T03:17:08.243722Z 1 [Note] [MY-000000] [WSREP] wsrep\_notify\_cmd is not defined, skipping notification.

2025-08-02T03:17:08.246816Z 1 [Note] [MY-000000] [Galera] Recording CC from group: 4  
2025-08-02T03:17:08.246849Z 1 [Note] [MY-000000] [Galera] Lowest cert index boundary for CC from group: 4  
2025-08-02T03:17:08.246860Z 1 [Note] [MY-000000] [Galera] Min available from gcache for CC from group: 1  
2025-08-02T03:17:09.969169Z 0 [Note] [MY-000000] [Galera] Deferred close timer started for socket with remote endpoint: ssl://172.16.57.14:40082  
2025-08-02T03:17:09.969240Z 0 [Note] [MY-000000] [Galera] forgetting 2bdb1c6f-9225 (ssl://172.16.57.14:4567)  
2025-08-02T03:17:09.969273Z 0 [Note] [MY-000000] [Galera] Node 5cc7ed6c-b5f7 state primary  
2025-08-02T03:17:09.969295Z 0 [Note] [MY-000000] [Galera] Current view of cluster as seen by this node  
view (view\_id(PRIM,5cc7ed6c-b5f7,5)  
memb {  
5cc7ed6c-b5f7,0  
}  
joined {  
}  
left {  
}  
partitioned {  
2bdb1c6f-9225,0  
}  
)  
2025-08-02T03:17:09.969313Z 0 [Note] [MY-000000] [Galera] Save the discovered primary-component to disk  
2025-08-02T03:17:09.970807Z 0 [Note] [MY-000000] [Galera] forgetting 2bdb1c6f-9225 (ssl://172.16.57.14:4567)  
2025-08-02T03:17:09.970825Z 0 [Note] [MY-000000] [Galera] New COMPONENT: primary = yes, bootstrap = no, my\_idx = 0, memb\_num = 1  
2025-08-02T03:17:09.970964Z 0 [Note] [MY-000000] [Galera] STATE\_EXCHANGE: sent state UUID: 2d300d9d-6f4f-11f0-ba7d-cba82116552e  
2025-08-02T03:17:09.971025Z 0 [Note] [MY-000000] [Galera] STATE EXCHANGE: sent state msg: 2d300d9d-6f4f-11f0-ba7d-cba82116552e  
2025-08-02T03:17:09.971056Z 0 [Note] [MY-000000] [Galera] STATE EXCHANGE: got state msg: 2d300d9d-6f4f-11f0-ba7d-cba82116552e from 0 (ptt7)  
2025-08-02T03:17:09.971087Z 0 [Note] [MY-000000] [Galera] Deferred close timer handle\_wait Operation aborted. for 0x753810015920  
2025-08-02T03:17:09.971092Z 0 [Note] [MY-000000] [Galera] Quorum results:  
version = 6,  
component = PRIMARY,  
conf\_id = 4,  
members = 1/1 (primary/total),  
act\_id = 4,  
last\_appl. = 0,  
protocols = 2/10/4 (gcs/repl/appl),  
vote policy= 0,  
group UUID = 5cc84d7a-6f4a-11f0-8828-a2acfcf3bd92  
2025-08-02T03:17:09.971152Z 0 [Note] [MY-000000] [Galera] Deferred close timer destruct  
2025-08-02T03:17:09.971221Z 0 [Note] [MY-000000] [Galera] Flow-control interval: [100, 100]  
2025-08-02T03:17:09.971431Z 1 [Note] [MY-000000] [Galera] ####### processing CC 5, local, ordered  
2025-08-02T03:17:09.971466Z 1 [Note] [MY-000000] [Galera] Maybe drain monitors from 4 upto current CC event 5 upto:4  
2025-08-02T03:17:09.971492Z 1 [Note] [MY-000000] [Galera] Drain monitors from 4 up to 4  
2025-08-02T03:17:09.971506Z 1 [Note] [MY-000000] [Galera] ####### My UUID: 5cc7ed6c-6f4a-11f0-b5f7-23483fc52e4a  
2025-08-02T03:17:09.971516Z 1 [Note] [MY-000000] [Galera] Skipping cert index reset  
2025-08-02T03:17:09.971525Z 1 [Note] [MY-000000] [Galera] REPL Protocols: 10 (5)  
2025-08-02T03:17:09.971534Z 1 [Note] [MY-000000] [Galera] ####### Adjusting cert position: 4 → 5  
2025-08-02T03:17:09.971588Z 0 [Note] [MY-000000] [Galera] Service thread queue flushed.  
2025-08-02T03:17:09.972617Z 1 [Note] [MY-000000] [Galera] ================================================  
View:  
id: 5cc84d7a-6f4a-11f0-8828-a2acfcf3bd92:5  
status: primary  
protocol\_version: 4  
capabilities: MULTI-MASTER, CERTIFICATION, PARALLEL\_APPLYING, REPLAY, ISOLATION, PAUSE, CAUSAL\_READ, INCREMENTAL\_WS, UNORDERED, PREORDERED, STREAMING, NBO  
final: no  
own\_index: 0  
members(1):  
0: 5cc7ed6c-6f4a-11f0-b5f7-23483fc52e4a, ptt7

2025-08-02T03:17:09.972679Z 1 [Note] [MY-000000] [WSREP] wsrep\_notify\_cmd is not defined, skipping notification.  
2025-08-02T03:17:09.975253Z 1 [Note] [MY-000000] [Galera] Recording CC from group: 5  
2025-08-02T03:17:09.975288Z 1 [Note] [MY-000000] [Galera] Lowest cert index boundary for CC from group: 5  
2025-08-02T03:17:09.975308Z 1 [Note] [MY-000000] [Galera] Min available from gcache for CC from group: 1  
2025-08-02T03:17:11.040483Z 0 [Note] [MY-000000] [Galera] (5cc7ed6c-b5f7, ‘ssl://0.0.0.0:4567’) turning message relay requesting off  
2025-08-02T03:17:15.040900Z 0 [Note] [MY-000000] [Galera] cleaning up 2bdb1c6f-9225 (ssl://172.16.57.14:4567)

---

<div class="post-metadata">

**Author:** ![matthewb](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/matthewb/32/34_2.png) [@matthewb](https://forums.percona.com/u/matthewb)\
**Post date:** [August 2, 2025, 2:52pm UTC](https://forums.percona.com/t/the-binary-installation-of-percona-xtradb-cluster-8-0-33-reports-an-error-when-starting-the-second-node/38888/13 "2025-08-02T14:52:25Z")

</div>

You have SSL enabled. If the certificates are not the same on node1 and node2, then SST will fail. Please read the documentation on PXC+SSL

> **[Percona XtraDB Cluster - Encrypt PXC traffic](https://docs.percona.com/percona-xtradb-cluster/8.0/encrypt-traffic.html#ssl-automatic-configuration)**
>
> There are two kinds of traffic in Percona XtraDB Cluster:

---

<div class="post-metadata">

**Author:** ![iconvnet\_iconvnet](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/iconvnet_iconvnet/32/20734_2.png) [@iconvnet\_iconvnet](https://forums.percona.com/u/iconvnet_iconvnet)\
**Post date:** [August 4, 2025, 6:35am UTC](https://forums.percona.com/t/the-binary-installation-of-percona-xtradb-cluster-8-0-33-reports-an-error-when-starting-the-second-node/38888/14 "2025-08-04T06:35:39Z")

</div>

The certificates for my second node have been copied from the first one

---

<div class="post-metadata">

**Author:** ![iconvnet\_iconvnet](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/iconvnet_iconvnet/32/20734_2.png) [@iconvnet\_iconvnet](https://forums.percona.com/u/iconvnet_iconvnet)\
**Post date:** [August 4, 2025, 8:28am UTC](https://forums.percona.com/t/the-binary-installation-of-percona-xtradb-cluster-8-0-33-reports-an-error-when-starting-the-second-node/38888/15 "2025-08-04T08:28:53Z")

</div>

I can install it online, but it doesn’t work with binary package installation. Is there a missing configuration or dependency?
