# Systemctl command on Percona cluster nodes

**URL:** <https://forums.percona.com/t/systemctl-command-on-percona-cluster-nodes/13554>\
**Category:** Percona XtraDB Cluster 8.x\
**Tags:** closed-no-reply\
**Created:** [December 19, 2021, 4:27pm UTC](https://forums.percona.com/t/systemctl-command-on-percona-cluster-nodes/13554 "2021-12-19T16:27:20Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![l33kr3w](https://avatars.discourse-cdn.com/v4/letter/l/e8c25b/32.png) [@l33kr3w](https://forums.percona.com/u/l33kr3w)\
**Post date:** [December 19, 2021, 4:27pm UTC](https://forums.percona.com/t/systemctl-command-on-percona-cluster-nodes/13554/1 "2021-12-19T16:27:20Z")

</div>

How can I enable all nodes to start automatically in every reboot? I tried “sudo systemctl mysql” command but it does not work.

bootstrap (node1) server status

```auto
● mysql@bootstrap.service - Percona XtraDB Cluster with config /etc/default/mysql.bootstrap
     Loaded: loaded (/lib/systemd/system/mysql@.service; disabled; vendor preset: enabled)
     Active: inactive (dead)

Dec 19 19:17:28 db01 systemd[1]: /lib/systemd/system/mysql@.service:36: Unknown key name 'Require' in section 'Unit', ignoring.

```

node02 system status

```auto
● mysql.service - Percona XtraDB Cluster
     Loaded: loaded (/lib/systemd/system/mysql.service; enabled; vendor preset: enabled)
     Active: failed (Result: exit-code) since Sun 2021-12-19 19:17:14 +03; 7min ago
    Process: 664 ExecStartPre=/usr/bin/mysql-systemd start-pre (code=exited, status=0/SUCCESS)
    Process: 756 ExecStartPre=/usr/bin/mysql-systemd check-grastate (code=exited, status=1/FAILURE)
    Process: 789 ExecStopPost=/usr/bin/mysql-systemd stop-post (code=exited, status=0/SUCCESS)

Dec 19 19:17:12 db02 systemd[1]: Starting Percona XtraDB Cluster...
Dec 19 19:17:14 db02 mysql-systemd[756]: WARNING: Node has been rebooted, /var/lib/mysql/grastate.dat: seqno = -1, mysql service has not been started auto>
Dec 19 19:17:14 db02 systemd[1]: mysql.service: Control process exited, code=exited, status=1/FAILURE
Dec 19 19:17:14 db02 mysql-systemd[789]: WARNING: mysql pid file /var/run/mysqld/mysqld.pid empty or not readable
Dec 19 19:17:14 db02 mysql-systemd[789]: WARNING: mysql may be already dead
Dec 19 19:17:14 db02 systemd[1]: mysql.service: Failed with result 'exit-code'.
Dec 19 19:17:14 db02 systemd[1]: Failed to start Percona XtraDB Cluster.

```

I just want these nodes to start automatically (without any manual intervention)
