# Strange error (At least for me).

**URL:** <https://forums.percona.com/t/strange-error-at-least-for-me/7441>\
**Category:** Percona XtraBackup\
**Created:** [February 21, 2020, 12:39pm UTC](https://forums.percona.com/t/strange-error-at-least-for-me/7441 "2020-02-21T12:39:40Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Claudio](https://avatars.discourse-cdn.com/v4/letter/c/7cd45c/32.png) [@Claudio](https://forums.percona.com/u/Claudio)\
**Post date:** [February 21, 2020, 12:39pm UTC](https://forums.percona.com/t/strange-error-at-least-for-me/7441/1 "2020-02-21T12:39:40Z")

</div>

Hello everybody, I hope you can help me (and anybody else facing a similar error). When I attempt to use the xtrabackup, after all my databases are dumped the process fails with the following error:  
Error: failed to execute query ‘SET SESSION lock\_wait\_timeout=31536000’: 2006 (HY000) MySQL server has gone away.

If I check the timeout variables, 2 of them show this value:  
| lock\_wait\_timeout | 31536000 |  
| rpl\_stop\_slave\_timeout | 31536000 |

Our databases are roughly 400GB big, I wonder if we are hitting one of these timeouts in the backup process or if this is a known bug.  
xtrabackup is 2.4.18, and MySQL is 5.7.26

Any help will be really appreciated since we are trying to avoid locking the tables when dumping our data.

---

<div class="post-metadata">

**Author:** ![lorraine.pocklington](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/lorraine.pocklington/32/37_2.png) [@lorraine.pocklington](https://forums.percona.com/u/lorraine.pocklington)\
**Post date:** [February 24, 2020, 4:12am UTC](https://forums.percona.com/t/strange-error-at-least-for-me/7441/2 "2020-02-24T04:12:25Z")

</div>

Hello Claudio  
Percona XtraBackup won’t lock InnoDB tables, only MyISAM and other storage engines that don’t use a redo log.  
Are you using MyISAM or other storage engines?  
If you get that info to me, along with any error logs that are being recorded (if there’s anything beyond that error message) I’ll see if I can get you more advice.  
This is a standalone database, is that right?

---

<div class="post-metadata">

**Author:** ![matthewb](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/matthewb/32/34_2.png) [@matthewb](https://forums.percona.com/u/matthewb)\
**Post date:** [January 13, 2021, 5:51pm UTC](https://forums.percona.com/t/strange-error-at-least-for-me/7441/3 "2021-01-13T17:51:58Z")

</div>

@Claudio Can you show us the command you are using to execute xtrabackup? Are all of your tables InnoDB?
