# State Transfer Problem

**URL:** <https://forums.percona.com/t/state-transfer-problem/2681>\
**Category:** Percona XtraDB Cluster 5.x\
**Created:** [May 14, 2013, 11:12am UTC](https://forums.percona.com/t/state-transfer-problem/2681 "2013-05-14T11:12:44Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![finnthehuman](https://avatars.discourse-cdn.com/v4/letter/f/3d9bf3/32.png) [@finnthehuman](https://forums.percona.com/u/finnthehuman)\
**Post date:** [May 14, 2013, 11:12am UTC](https://forums.percona.com/t/state-transfer-problem/2681/1 "2013-05-14T11:12:44Z")

</div>

Percona XtraDB Cluster from the Percona repo (percona-xtradb-cluster-server-5.5/5.5.27-23.6-356.oneiric) on Ubuntu 11.10 64-bit.

Error is “[ERROR] WSREP: async IST sender failed to serve tcp://x.x.x.x:4568: ist send failed: 1’, asio error ‘Connection reset by peer’: 104 (Connection reset by peer) at galera/src/ist.cpp:send():740”. Node fails to fall back to full state transfer and mysql service fails to start. No innobackup or sst error logs are created after failure.

---

<div class="post-metadata">

**Author:** ![revin](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/revin/32/824_2.png) [@revin](https://forums.percona.com/u/revin)\
**Post date:** [May 14, 2013, 11:51pm UTC](https://forums.percona.com/t/state-transfer-problem/2681/2 "2013-05-14T23:51:24Z")

</div>

@finnthehuman,

When the original problem happens again, can you post the contents of the innobackup.backup.log from the donor. This is found within the data directory.

---

<div class="post-metadata">

**Author:** ![revin](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/revin/32/824_2.png) [@revin](https://forums.percona.com/u/revin)\
**Post date:** [May 16, 2013, 3:28am UTC](https://forums.percona.com/t/state-transfer-problem/2681/3 "2013-05-16T03:28:49Z")

</div>

@finnthehuman,

From this log on the donor [url][http://pastebin.com/YVinfUeM[/url]](http://pastebin.com/YVinfUeM%5B/url%5D) I see the below, so it may have the log file available. Let us know what you find out 🙂

```auto
130513 19:01:41 [ERROR] WSREP: Failed to read from: wsrep_sst_xtrabackup 'donor' '10.7.3.53:4444/xtrabackup_sst' '(null)' '/var/lib/mysql/' '/etc/mysql/my.cnf' '3214b7d4-8b59-11e2-0800-fde78b56d029' '109567765' '1'
130513 19:01:41 [ERROR] WSREP: Process completed with error: wsrep_sst_xtrabackup 'donor' '10.7.3.53:4444/xtrabackup_sst' '(null)' '/var/lib/mysql/' '/etc/mysql/my.cnf' '3214b7d4-8b59-11e2-0800-fde78b56d029' '109567765' '1': 1 (Operation not permitted)
130513 19:01:41 [Warning] WSREP: 0 (db-2): State transfer to 1 (db-3) failed: -1 (Operation not permitted)

```

---

<div class="post-metadata">

**Author:** ![finnthehuman](https://avatars.discourse-cdn.com/v4/letter/f/3d9bf3/32.png) [@finnthehuman](https://forums.percona.com/u/finnthehuman)\
**Post date:** [May 16, 2013, 3:24pm UTC](https://forums.percona.com/t/state-transfer-problem/2681/4 "2013-05-16T15:24:33Z")

</div>

After upgrade to 5.5.30-rel30.2 initial start/joining the cluster state transfer failed with “InnoDB: Error: io\_setup() failed with EAGAIN after 5 attempts.” More information is available at this URL: [URL=“[http://elenst.ru/pensieve/it-bits/aio-max-nr-in-general-and-innodb-error-io\_setup-failed-with-eagain-in-particular/](http://elenst.ru/pensieve/it-bits/aio-max-nr-in-general-and-innodb-error-io_setup-failed-with-eagain-in-particular/)”][http://elenst.ru/pensieve/it-bits/ai...in-particular/[/URL]](http://elenst.ru/pensieve/it-bits/ai...in-particular/%5B/URL%5D). Increased the fs.aio-max-nr in sysctl.conf and the transfer worked on the next try.

---

<div class="post-metadata">

**Author:** ![finnthehuman](https://avatars.discourse-cdn.com/v4/letter/f/3d9bf3/32.png) [@finnthehuman](https://forums.percona.com/u/finnthehuman)\
**Post date:** [May 22, 2013, 3:24pm UTC](https://forums.percona.com/t/state-transfer-problem/2681/5 "2013-05-22T15:24:19Z")

</div>

Just wanted to say that I have upgraded all of my nodes/clusters to 5.5.30-rel30.2 I have not had a single problem since so there is clearly something wrong with the old version. If anyone is still running on 5.5.27 you should probably upgrade as soon as you can.
