# Starting TokuDB with missing recovery log

**URL:** <https://forums.percona.com/t/starting-tokudb-with-missing-recovery-log/4705>\
**Category:** Other MySQL® Questions\
**Created:** [February 8, 2016, 5:12am UTC](https://forums.percona.com/t/starting-tokudb-with-missing-recovery-log/4705 "2016-02-08T05:12:46Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![kasthack](https://avatars.discourse-cdn.com/v4/letter/k/a88e4f/32.png) [@kasthack](https://forums.percona.com/u/kasthack)\
**Post date:** [February 8, 2016, 5:12am UTC](https://forums.percona.com/t/starting-tokudb-with-missing-recovery-log/4705/1 "2016-02-08T05:12:46Z")

</div>

Hello.  
I’ve lost TokuDB recovery log(HDD has died) and TokuDB won’t even start complaining about missing recovery log:

```auto

/var/log/mysql/error.log:
...
[ERROR] TokuDB: Recovery log is missing (persistent environment information is present)
[ERROR] TokuDB unknown error 2
[ERROR] Plugin 'TokuDB' init function returned error.
[ERROR] Plugin 'TokuDB' registration as a STORAGE ENGINE failed.
...

```

According to [documentation](https://github.com/percona/tokudb-engine/wiki/TokuDB-Files-and-File-Descriptors#tokudb-storage-engine-files):

> [@](#):
>
> The TokuDB recovery log stores the transactional state of the active transactions and is used to recover from crashes

By the time of the crash the database was in read-only mode for about a month, so, I guess, there was nothing important in the recovery log.

I have a backup but loading it into a new database and building indexes will take days if not weeks.

Is there any way to make TokuDB work in this situation / extract data without starting / etc?

---

<div class="post-metadata">

**Author:** ![George\_Lorch](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/george_lorch/32/1108_2.png) [@George\_Lorch](https://forums.percona.com/u/George_Lorch)\
**Post date:** [February 22, 2016, 10:19pm UTC](https://forums.percona.com/t/starting-tokudb-with-missing-recovery-log/4705/2 "2016-02-22T22:19:30Z")

</div>

Currently, if you lose your PerconaFT recovery log, you lose your entire FT data store.

We are looking into implementing some functionality similar to th innodb\_force\_recovery but due to the nature and current implementation of PerconaFT and its transactional behaviour it is quite a delicate and difficult task.

There may be some hacky way to trick the PerconaFT recovery process by hand building a new recovery log but that would require some internals knowledge and info on the current state of the FT data set, but that would very likely take longer and be more problematic than restoring from a backup.

–  
George O. Lorch III  
Software Engineer, Percona
