# SST failing please help

**URL:** <https://forums.percona.com/t/sst-failing-please-help/4857>\
**Category:** Percona XtraDB Cluster 5.x\
**Created:** [April 22, 2016, 11:22am UTC](https://forums.percona.com/t/sst-failing-please-help/4857 "2016-04-22T11:22:15Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![nathan](https://avatars.discourse-cdn.com/v4/letter/n/c5a1d2/32.png) [@nathan](https://forums.percona.com/u/nathan)\
**Post date:** [April 22, 2016, 11:22am UTC](https://forums.percona.com/t/sst-failing-please-help/4857/1 "2016-04-22T11:22:15Z")

</div>

Hello,

When trying to join a new node into my bootstrapped cluster it fails. I am using mariadb 10 with galera.  
The error i am seeing on the joining node is as follows:

WSREP\_SST: [INFO] Evaluating innobackupex --defaults-file=/etc/my.cnf --defaults-group=mysqld --no-version-check --move-back --force-non-empty-directories ${DATA} &\>${DATA}/innobackup.move.log (20160422 11:02:42.807)  
WSREP\_SST: [ERROR] Cleanup after exit with status:1 (20160422 11:02:42.881)  
160422 11:02:42 [ERROR] WSREP: Process completed with error: wsrep\_sst\_xtrabackup-v2 --role ‘joiner’ --address ‘107.xxx.xxx.xxx’ --datadir ‘/var/lib/mysql/’ --defaults-file ‘/etc/my.cnf’ --defaults-group-suffix ‘’ --parent ‘15553’ ‘’ : 1 (Operation not permitted)  
160422 11:02:42 [ERROR] WSREP: Failed to read uuid:seqno from joiner script.  
160422 11:02:42 [ERROR] WSREP: SST failed: 1 (Operation not permitted)  
160422 11:02:42 [ERROR] Aborting

My config file on the bootstrapped node looks like this:

# 

# These groups are read by MariaDB server.

# Use it for options that only the server (but not clients) should see

# 

# See the examples of server my.cnf files in /usr/share/mysql/

# 

# this is read by the standalone daemon and embedded servers

[server]

# this is only for the mysqld standalone daemon

[mysqld]

max\_connections = 1500  
max\_allowed\_packet = 64M  
max\_connect\_errors = 1000000  
default\_storage\_engine = InnoDB

query\_cache\_type = 0  
#query\_cache\_size = 64M

thread\_cache\_size = 75

sort\_buffer\_size = 2M  
tmp\_table\_size = 32M

read\_buffer\_size = 128k  
read\_rnd\_buffer\_size = 256k  
join\_buffer\_size = 128k

table\_definition\_cache = 400  
table\_open\_cache = 400

max\_heap\_table\_size = 32M

innodb\_buffer\_pool\_size = 27G  
innodb\_flush\_method = O\_DIRECT  
innodb\_write\_io\_threads = 8  
innodb\_io\_capacity = 1000  
innodb\_buffer\_pool\_instances = 40

# 

# \* Galera-related settings

# 

[galera]

# this is only for embedded server

[embedded]

# This group is only read by MariaDB servers, not by MySQL.

# If you use the same .cnf file for MySQL and MariaDB,

# you can put MariaDB-only options here

[mariadb]

# This group is only read by MariaDB-10.0 servers.

# If you use the same .cnf file for MariaDB of different versions,

# use this group for options that older servers don’t understand

[mariadb-10.0]

binlog\_format=ROW  
default-storage-engine=innodb  
innodb\_autoinc\_lock\_mode=2  
innodb\_locks\_unsafe\_for\_binlog=1  
bind-address=0.0.0.0

datadir=/var/lib/mysql  
innodb\_log\_file\_size=100M  
innodb\_file\_per\_table  
innodb\_flush\_log\_at\_trx\_commit=2

wsrep\_provider=/usr/lib64/galera/libgalera\_smm.so  
wsrep\_provider\_options=“evs.keepalive\_period = PT3S;evs.suspect\_timeout = PT30S;evs.inactive\_timeout = PT1M;evs.install\_timeout = PT1M;gmcast.segment=1”  
wsrep\_cluster\_address=“gcomm://107.xxx.xxx.xxx,107.xxx.xxx.xxx,107.xxx.xxx.xxx”  
wsrep\_cluster\_name=‘ecs-orlando-staging’  
wsrep\_node\_address='107.xxx.xxx.xxx  
wsrep\_node\_name=‘[ecs10-db.orl.rootleveltech.com](http://ecs10-db.orl.rootleveltech.com)’  
wsrep\_sst\_method=xtrabackup-v2  
wsrep\_sst\_auth=sst\_user:secret

The joining node config looks like this

# 

# These groups are read by MariaDB server.

# Use it for options that only the server (but not clients) should see

# 

# See the examples of server my.cnf files in /usr/share/mysql/

# 

# this is read by the standalone daemon and embedded servers

[server]

# this is only for the mysqld standalone daemon

[mysqld]

max\_connections = 1500  
max\_allowed\_packet = 64M  
max\_connect\_errors = 1000000  
default\_storage\_engine = InnoDB

query\_cache\_type = 0  
#query\_cache\_size = 64M

thread\_cache\_size = 75

sort\_buffer\_size = 2M  
tmp\_table\_size = 32M

read\_buffer\_size = 128k  
read\_rnd\_buffer\_size = 256k  
join\_buffer\_size = 128k

table\_definition\_cache = 400  
table\_open\_cache = 400

max\_heap\_table\_size = 32M

innodb\_buffer\_pool\_size = 27G  
innodb\_flush\_method = O\_DIRECT  
innodb\_write\_io\_threads = 8  
innodb\_io\_capacity = 1000  
innodb\_buffer\_pool\_instances = 40

# 

# \* Galera-related settings

# 

[galera]

# this is only for embedded server

[embedded]

# This group is only read by MariaDB servers, not by MySQL.

# If you use the same .cnf file for MySQL and MariaDB,

# you can put MariaDB-only options here

[mariadb]

# This group is only read by MariaDB-10.0 servers.

# If you use the same .cnf file for MariaDB of different versions,

# use this group for options that older servers don’t understand

[mariadb-10.0]

binlog\_format=ROW  
default-storage-engine=innodb  
innodb\_autoinc\_lock\_mode=2  
innodb\_locks\_unsafe\_for\_binlog=1  
bind-address=0.0.0.0

datadir=/var/lib/mysql  
innodb\_log\_file\_size=100M  
innodb\_file\_per\_table  
innodb\_flush\_log\_at\_trx\_commit=2

wsrep\_provider=/usr/lib64/galera/libgalera\_smm.so  
wsrep\_provider\_options=“evs.keepalive\_period = PT3S;evs.suspect\_timeout = PT30S;evs.inactive\_timeout = PT1M;evs.install\_timeout = PT1M;gmcast.segment=1”  
wsrep\_cluster\_address=“gcomm://107.xxx.xxx.xxx,107.xxx.xxx.xxx,107.xxx.xxx.xxx”  
wsrep\_cluster\_name=‘ecs-orlando-staging’  
wsrep\_node\_address=‘107.xxx.xxx.xxx’  
wsrep\_node\_name=‘[ecs13-db.orl.rootleveltech.com](http://ecs13-db.orl.rootleveltech.com)’  
wsrep\_sst\_method=xtrabackup-v2  
wsrep\_sst\_auth=sst\_user:secret

I cant figure it out. Any help would be great;y appreciated

---

<div class="post-metadata">

**Author:** ![zozo6015](https://avatars.discourse-cdn.com/v4/letter/z/57b2e6/32.png) [@zozo6015](https://forums.percona.com/u/zozo6015)\
**Post date:** [April 22, 2016, 4:19pm UTC](https://forums.percona.com/t/sst-failing-please-help/4857/2 "2016-04-22T16:19:02Z")

</div>

It seam like you don’t have the rights to replicate. Try adding this to all the nodes in the my.cfg  
s3cret

then run this on the first node:
