# SSL with CA issued certs - errors

**URL:** <https://forums.percona.com/t/ssl-with-ca-issued-certs-errors/3470>\
**Category:** Other MySQL® Questions\
**Created:** [May 13, 2014, 8:08am UTC](https://forums.percona.com/t/ssl-with-ca-issued-certs-errors/3470 "2014-05-13T08:08:12Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![NealC](https://avatars.discourse-cdn.com/v4/letter/n/aca169/32.png) [@NealC](https://forums.percona.com/u/NealC)\
**Post date:** [May 13, 2014, 8:08am UTC](https://forums.percona.com/t/ssl-with-ca-issued-certs-errors/3470/1 "2014-05-13T08:08:12Z")

</div>

Hi.

Release: percona-server-server-5.5 1:5.5.37-rel35.0-657.precise  
Openssl: openssl 1.0.1-4ubuntu5.13

We’re setting up MySQL for eventual ODBC connections, security requirement is over SSL. This tests correctly with self-generated certs but switching to real ISP generated certs errors. Simplest we should be able to do is;

ssl-ca=/etc/mysql/certs/intermediate.pem - the CA’s interm cert  
ssl-cert=/etc/mysql/certs/our\_realcert.pem - our real signed cert  
ssl-key=/etc/mysql/certs/our\_realcert\_key.pem - real certs key

The cert & key’s MD5 sums are both correct & the whole chain has been verified in an Apache setup  
We’re testing correct connection with workbench initially , the real certs error with “SSL connection error: ASN: bad other signature confirmation” & self generated certs are OK.

Does anyone have experience of ‘real’ certs or can illuminate this error?

Thanks  
Neal

---

<div class="post-metadata">

**Author:** ![NealC](https://avatars.discourse-cdn.com/v4/letter/n/aca169/32.png) [@NealC](https://forums.percona.com/u/NealC)\
**Post date:** [May 15, 2014, 2:31am UTC](https://forums.percona.com/t/ssl-with-ca-issued-certs-errors/3470/2 "2014-05-15T02:31:19Z")

</div>

Resolved, switching back to standard MySQL with the identical configuration works.  
Can only assume an issue with percona-server-server-5.5 1:5.5.37-rel35.0-657.precise or the client
