# Second node don't sync neigther xtrabackup nor rsync

**URL:** <https://forums.percona.com/t/second-node-dont-sync-neigther-xtrabackup-nor-rsync/3036>\
**Category:** Percona XtraDB Cluster 5.x\
**Created:** [October 26, 2013, 7:25am UTC](https://forums.percona.com/t/second-node-dont-sync-neigther-xtrabackup-nor-rsync/3036 "2013-10-26T07:25:43Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Suhanko](https://avatars.discourse-cdn.com/v4/letter/s/b487fb/32.png) [@Suhanko](https://forums.percona.com/u/Suhanko)\
**Post date:** [October 26, 2013, 7:25am UTC](https://forums.percona.com/t/second-node-dont-sync-neigther-xtrabackup-nor-rsync/3036/1 "2013-10-26T07:25:43Z")

</div>

Hello, everybody.  
I’m trying change from MySQL master-master to Percona multi-master setup. The first node (donor) is starting ok, but second node doesn’t up. I can see their IP with show status like ‘wsrep\_incoming\_addresses’, but some timer after the second node go down.

In my log I found some information, but isn’t clear to me. I pasted below only must important info found in my log:  
…  
removed `/database/mysql/ibdata1’  
WSREP\_SST: [INFO] Evaluating socat -u TCP-LISTEN:4444,reuseaddr stdio | xbstream -x; RC=( ${PIPESTATUS[@]} ) (20131026 12:37:17.290)  
WSREP\_SST: [ERROR] xtrabackup process ended without creating ‘/database/mysql//xtrabackup\_galera\_info’ (20131026 12:37:26.969)  
WSREP\_SST: [INFO] Contents of datadir (20131026 12:37:26.972)  
WSREP\_SST: [INFO] -rw------- 1 mysql mysql 134219048 Oct 26 12:37 /database/mysql//galera.cache  
-rw-rw---- 1 mysql mysql 104 Oct 26 12:37 /database/mysql//grastate.dat  
-rw-rw---- 1 mysql mysql 0 Oct 26 12:37 /database/mysql//sst\_in\_progress (20131026 12:37:26.978)  
WSREP\_SST: [ERROR] Cleanup after exit with status:32 (20131026 12:37:26.981)  
WSREP\_SST: [INFO] Removing the sst\_in\_progress file (20131026 12:37:26.984)  
131026 12:37:26 [ERROR] WSREP: Process completed with error: wsrep\_sst\_xtrabackup --role ‘joiner’ --address ‘192.168.1.230’ --auth ‘replication:replication’ --datadir ‘/database/mysql/’ --defaults-file ‘/etc/mysql/my.cnf’ --parent ‘24611’: 32 (Broken pipe)  
131026 12:37:26 [ERROR] WSREP: Failed to read uuid:seqno from joiner script.  
131026 12:37:26 [ERROR] WSREP: SST failed: 32 (Broken pipe)  
131026 12:37:26 [ERROR] Aborting

131026 12:37:26 [Warning] WSREP: 1 (oldVaio): State transfer to 0 (perolaNegra) failed: -1 (Operation not permitted)  
131026 12:37:26 [ERROR] WSREP: gcs/src/gcs\_group.c:gcs\_group\_handle\_join\_msg():719: Will never receive state. Need to abort.  
…

I did ‘grant all privileges on _._ to replication@’%’ identified by ‘replication’ (that is a lab environment, I don’t care with security for now), so I think the permissions are ok.  
I changed many permissions to 777 in directories and 666 in many files to avoid any restriction, but I have no idea what I can to do anymore.  
My cnf files are below:  
NODE01:

[mysqld]  
#Performance schema  
#performance\_schema = OFF

#General  
datadir = /database/mysql  
socket = /database/mysqld.sock  
pid\_file = /database/mysqld.pid  
user = mysql  
port = 3306

#InnoDB  
innodb\_flush\_log\_at\_trx\_commit = 2  
innodb\_buffer\_pool\_size = 2G  
innodb\_buffer\_pool\_instances = 1  
innodb\_log\_file\_size = 64M  
innodb\_file\_per\_table = 1  
innodb\_flush\_method = O\_DIRECT

#MyISAM  
key\_buffer\_size = 200M  
myisam\_block\_size = 4096  
myisam\_sort\_buffer\_size = 256M

#logging  
log\_bin = mysql-bin  
log\_error = /database/mysql-error.log  
long\_query\_time = 10  
slow\_query\_log = ON  
slow\_query\_log\_file = /database/mysql-slow.log

#Others  
bind-address = 0.0.0.0  
tmp\_table\_size = 32M  
max\_heap\_table\_size = 32M  
query\_cache\_type = 0  
query\_cache\_size = 0  
max\_connections = 100  
thread\_cache\_size = 20  
open\_files\_limit = 65535  
skip\_name\_resolve = OFF

#galera  
binlog\_format = ROW  
wsrep\_provider = /usr/lib/libgalera\_smm.so  
wsrep\_cluster\_address = gcomm:// #192.168.1.230,192.168.1.235,192.168.1.240  
default\_storage\_engine = InnoDB  
innodb\_locks\_unsafe\_for\_binlog = 1  
innodb\_autoinc\_lock\_mode = 2  
wsrep\_node\_address = 192.168.1.235  
wsrep\_sst\_method = rsync #xtrabackup  
wsrep\_cluster\_name = axiros\_lab  
wsrep\_sst\_auth = “replication:replication”

[client]  
socket = /var/lib/mysql/mysql.sock  
port = 3306

* * *

* * *

NODE02

All configurations are the same, so I will paste just the galera configuration block:  
#galera  
binlog\_format = ROW  
wsrep\_provider = /usr/lib/libgalera\_smm.so  
wsrep\_cluster\_address = gcomm://192.168.1.230,192.168.1.235  
#wsrep\_cluster\_address = gcomm://  
default\_storage\_engine = InnoDB  
innodb\_locks\_unsafe\_for\_binlog = 1  
innodb\_autoinc\_lock\_mode = 2  
wsrep\_node\_address = 192.168.1.230  
wsrep\_sst\_method = xtrabackup  
wsrep\_cluster\_name = axiros\_lab  
wsrep\_sst\_auth = “replication:replication”

====================================  
How you can see, I’m trying avoid any problem in the first setup to see everything running. I will add a third node when my problems are solved.  
I have no firewall rules, I’m using 3 notebooks to create a cluster to test.  
My operating system are Debian Wheezy in all nodes. The packages was downloaded via percona repository.  
All notebooks and systems are 64bits.

Please, do someone have suggestions?

---

<div class="post-metadata">

**Author:** ![Suhanko](https://avatars.discourse-cdn.com/v4/letter/s/b487fb/32.png) [@Suhanko](https://forums.percona.com/u/Suhanko)\
**Post date:** [October 26, 2013, 6:37pm UTC](https://forums.percona.com/t/second-node-dont-sync-neigther-xtrabackup-nor-rsync/3036/2 "2013-10-26T18:37:57Z")

</div>

After many hours crying and trying, I changed sst tool. With rsync the things are running now so, seems to be a bug with xtrabackup tool.  
The logs are terrible, aren’t clear to understand problems. I’m feeling afraid to continue trying. In lab I passed many hours of hard work to discover this problem; I’m thinking if I have some problem in production…

---

<div class="post-metadata">

**Author:** ![marko\_s](https://avatars.discourse-cdn.com/v4/letter/m/ebca7d/32.png) [@marko\_s](https://forums.percona.com/u/marko_s)\
**Post date:** [October 28, 2013, 2:09am UTC](https://forums.percona.com/t/second-node-dont-sync-neigther-xtrabackup-nor-rsync/3036/3 "2013-10-28T02:09:34Z")

</div>

Can you check the contents of the innobackup.backup.log on donor node for errors?

---

<div class="post-metadata">

**Author:** ![Suhanko](https://avatars.discourse-cdn.com/v4/letter/s/b487fb/32.png) [@Suhanko](https://forums.percona.com/u/Suhanko)\
**Post date:** [October 29, 2013, 7:22pm UTC](https://forums.percona.com/t/second-node-dont-sync-neigther-xtrabackup-nor-rsync/3036/4 "2013-10-29T19:22:39Z")

</div>

Sorry my delay.  
I will do in the next setup, sorry. I don’t have this log because I’m running in a chroot with no rsyslog.
