# runtime error: index out of range

**URL:** https://forums.percona.com/t/runtime-error-index-out-of-range/6071
**Category:** PMM 1.x
**Created:** [December 11, 2017, 10:15am UTC](https://forums.percona.com/t/runtime-error-index-out-of-range/6071 "2017-12-11T10:15:45Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![daniel.kaatz](https://avatars.discourse-cdn.com/v4/letter/d/97f17d/32.png) [@daniel.kaatz](https://forums.percona.com/u/daniel.kaatz)
#### Post date: [December 11, 2017, 10:15am UTC](https://forums.percona.com/t/runtime-error-index-out-of-range/6071/1 "2017-12-11T10:15:45Z")

</div>

Hi,  
I have installed the virtual appliance of pmm 1.5.2. So far everthings works as expected.

I configured a named user with “grafana admin” rights and tried to login at [url][http://mygrafana/graph/login[/url]](http://mygrafana/graph/login%5B/url%5D). I get this message and no hints in the logs:

Server side error ☹  
runtime error: index out of range  
Check the Grafana server logs for the detailed error message.

Does anybody got an idea about the cause and how to fix it?

regards

---

<div class="post-metadata">

### Author: ![Peter](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/peter/32/2_2.png) [@Peter](https://forums.percona.com/u/Peter)
#### Post date: [December 24, 2017, 9:25pm UTC](https://forums.percona.com/t/runtime-error-index-out-of-range/6071/2 "2017-12-24T21:25:27Z")

</div>

Daniel,  
Were you able to check Grafana Server Logs as message instructs you ? Percona Monitoring and Management includes complete Grafana, including its logs.  
Also this issue looks like Grafana related more help might be available on Grafana Forums

[url][https://community.grafana.com/[/url]](https://community.grafana.com/%5B/url%5D)
