# Read-only users display Access denied when switching pages

**URL:** <https://forums.percona.com/t/read-only-users-display-access-denied-when-switching-pages/8240>\
**Category:** PMM 2.x\
**Created:** [November 5, 2020, 4:10am UTC](https://forums.percona.com/t/read-only-users-display-access-denied-when-switching-pages/8240 "2020-11-05T04:10:33Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![fiend](https://avatars.discourse-cdn.com/v4/letter/f/34f0e0/32.png) [@fiend](https://forums.percona.com/u/fiend)\
**Post date:** [November 5, 2020, 4:10am UTC](https://forums.percona.com/t/read-only-users-display-access-denied-when-switching-pages/8240/1 "2020-11-05T04:10:33Z")

</div>

Hello，

This error pops up when I log in as a read-only user and switch pages,See screenshot

 ![图片.png](https://us1.discourse-cdn.com/flex019/uploads/percona1/original/1X/c526ee54d950e7dfb40026c801e5719b12aa75e5.png)

except for this warning, everything is fine

How to block this output?

Server version:2.11.1

---

<div class="post-metadata">

**Author:** ![fiend](https://avatars.discourse-cdn.com/v4/letter/f/34f0e0/32.png) [@fiend](https://forums.percona.com/u/fiend)\
**Post date:** [November 5, 2020, 10:02pm UTC](https://forums.percona.com/t/read-only-users-display-access-denied-when-switching-pages/8240/2 "2020-11-05T22:02:29Z")

</div>

![pmmm.png](https://us1.discourse-cdn.com/flex019/uploads/percona1/original/1X/e886a94bc58b2e4b181b944a4744c2e694712361.png)

Is it a warning that a read-only user does not have permission to the /v1/Settings/Get ？Is there a way to block this warning？

---

<div class="post-metadata">

**Author:** ![Vadim\_Yalovets](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/vadim_yalovets/32/43_2.png) [@Vadim\_Yalovets](https://forums.percona.com/u/Vadim_Yalovets)\
**Post date:** [November 6, 2020, 3:18am UTC](https://forums.percona.com/t/read-only-users-display-access-denied-when-switching-pages/8240/3 "2020-11-06T03:18:30Z")

</div>

Hi Fiend,

It looks like the issue has already been reported in this ticket [https://jira.percona.com/browse/PMM-6865](https://jira.percona.com/browse/PMM-6865)As a solution you may downgrade the used percona-grafana package.

```auto
yum -y remove percona-grafana
yum -y install percona-grafana-7.1.3-1.el7 
supervisorctl restart grafana

```

---

<div class="post-metadata">

**Author:** ![fiend](https://avatars.discourse-cdn.com/v4/letter/f/34f0e0/32.png) [@fiend](https://forums.percona.com/u/fiend)\
**Post date:** [November 6, 2020, 4:22am UTC](https://forums.percona.com/t/read-only-users-display-access-denied-when-switching-pages/8240/4 "2020-11-06T04:22:27Z")

</div>

Hi [adivinho](https://forums.percona.com/profile/adivinho)

Thank you for your answer, the problem is solved
