# Re-instating the bootstrap node after a crash

**URL:** https://forums.percona.com/t/re-instating-the-bootstrap-node-after-a-crash/4541
**Category:** Percona XtraDB Cluster 5.x
**Created:** [November 23, 2015, 4:06pm UTC](https://forums.percona.com/t/re-instating-the-bootstrap-node-after-a-crash/4541 "2015-11-23T16:06:36Z")
**Posts on this page:** 7
**Page:** 1

<div class="post-metadata">

### Author: ![axalanh](https://avatars.discourse-cdn.com/v4/letter/a/258eb7/32.png) [@axalanh](https://forums.percona.com/u/axalanh)
#### Post date: [November 23, 2015, 4:06pm UTC](https://forums.percona.com/t/re-instating-the-bootstrap-node-after-a-crash/4541/1 "2015-11-23T16:06:36Z")

</div>

We have a 3 node cluster. One of the node which happened to be the bootstrapped node crash and we needed to reinstall. Is there a way to add it back to the cluster without bringing down the cluster? Thank you!

---

<div class="post-metadata">

### Author: ![sanjay92](https://avatars.discourse-cdn.com/v4/letter/s/b9e5f3/32.png) [@sanjay92](https://forums.percona.com/u/sanjay92)
#### Post date: [November 23, 2015, 5:14pm UTC](https://forums.percona.com/t/re-instating-the-bootstrap-node-after-a-crash/4541/2 "2015-11-23T17:14:02Z")

</div>

you can simply start mysql service ) service mysql start ( It will join cluster). If you get issues like PID file exists, you move PID file anf then restart mysql

---

<div class="post-metadata">

### Author: ![axalanh](https://avatars.discourse-cdn.com/v4/letter/a/258eb7/32.png) [@axalanh](https://forums.percona.com/u/axalanh)
#### Post date: [November 23, 2015, 6:40pm UTC](https://forums.percona.com/t/re-instating-the-bootstrap-node-after-a-crash/4541/3 "2015-11-23T18:40:05Z")

</div>

Thanks Sanjay92! I did that but mysql failed to start with the below error in the logs

2015-11-23 22:58:46 6234 [Warning] WSREP: 0.0 (ip-10-196-43-250.ec2.internal): State transfer to 2.0 (ebppvmifsdb01a) failed: -255 (Unknown error 255)  
2015-11-23 22:58:46 6234 [ERROR] WSREP: gcs/src/gcs\_group.cpp:gcs\_group\_handle\_join\_msg():731: Will never receive state. Need to abort.

I stopped Iptables on all the nodes to rule out communication issue. I did verified that the sst user exist on the donor and wsrep\_sst\_auth is set correctly on the joiner.

---

<div class="post-metadata">

### Author: ![sanjay92](https://avatars.discourse-cdn.com/v4/letter/s/b9e5f3/32.png) [@sanjay92](https://forums.percona.com/u/sanjay92)
#### Post date: [November 24, 2015, 7:48pm UTC](https://forums.percona.com/t/re-instating-the-bootstrap-node-after-a-crash/4541/4 "2015-11-24T19:48:32Z")

</div>

[COLOR=#4070A0]What is your setting for [COLOR=#4070A0]wsrep\_sst\_method ?  
[COLOR=#4070A0]wsrep\_sst\_method = [COLOR=#4070A0]xtrabackup-v2 I have read some where it mention that there are some files under .sst folder so delete all files and then restart it, however I don’t know which location .sst folder exists.

---

<div class="post-metadata">

### Author: ![axalanh](https://avatars.discourse-cdn.com/v4/letter/a/258eb7/32.png) [@axalanh](https://forums.percona.com/u/axalanh)
#### Post date: [November 25, 2015, 1:15pm UTC](https://forums.percona.com/t/re-instating-the-bootstrap-node-after-a-crash/4541/5 "2015-11-25T13:15:09Z")

</div>

We have

wsrep\_sst\_method=rsync

Cheers,

---

<div class="post-metadata">

### Author: ![sanjay92](https://avatars.discourse-cdn.com/v4/letter/s/b9e5f3/32.png) [@sanjay92](https://forums.percona.com/u/sanjay92)
#### Post date: [November 25, 2015, 5:06pm UTC](https://forums.percona.com/t/re-instating-the-bootstrap-node-after-a-crash/4541/6 "2015-11-25T17:06:50Z")

</div>

may be trying changing to [COLOR=#4070A0]

---

<div class="post-metadata">

### Author: ![axalanh](https://avatars.discourse-cdn.com/v4/letter/a/258eb7/32.png) [@axalanh](https://forums.percona.com/u/axalanh)
#### Post date: [November 30, 2015, 12:22am UTC](https://forums.percona.com/t/re-instating-the-bootstrap-node-after-a-crash/4541/7 "2015-11-30T00:22:41Z")

</div>

Tried changing to xtrabackup-v2 but no luck.

I think I was able to fix it though. The new rebuilt host has a different hostname than the previous. I changed the hostname to reflect the same as the previous and it joined the cluster. So the IP change didn’t matter as long as the hostname is the same. Is that an expected behavior?

Thanks Sanjay for the assist!
