# QAN fails to load when RDS in different region/availability zone

**URL:** https://forums.percona.com/t/qan-fails-to-load-when-rds-in-different-region-availability-zone/5332
**Category:** PMM 1.x
**Created:** [January 5, 2017, 12:13pm UTC](https://forums.percona.com/t/qan-fails-to-load-when-rds-in-different-region-availability-zone/5332 "2017-01-05T12:13:26Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![percona\_questions](https://avatars.discourse-cdn.com/v4/letter/p/ea5d25/32.png) [@percona\_questions](https://forums.percona.com/u/percona_questions)
#### Post date: [January 5, 2017, 12:13pm UTC](https://forums.percona.com/t/qan-fails-to-load-when-rds-in-different-region-availability-zone/5332/1 "2017-01-05T12:13:26Z")

</div>

mysql:queries data appears to stop loading after a period of time when the pmm server is in a different region or different availability zone within the same region of the RDS server.

It starts logging the following warnings and errors repeatedly when it stops loading (partial logs).

2017/01/05 15:51:00.001149 WARNING qan-analyzer-e4b1835d Skipping interval ‘14 2017-01-05 15:50:00 UTC to 2017-01-05 15:51:00 UTC (0-0)’ because interval ‘13 2017-01-05 15:49:00 UTC to 2017-01-05 15:50:00 UTC (0-0)’ is still being parsed  
2017/01/05 15:50:03.073172 ERROR qan-analyzer-e4b1835d-worker Got class twice: …  
2017/01/05 15:54:00.001206 WARNING qan-analyzer-e4b1835d-worker Interval out of sequence: got 17, expected 16

I have set METRICS\_RESOLUTION=5s to attempt to mitigate, but it still appears to occur.

The only solution I have found is to deploy the server within the same availability zone as the RDS. Are there any additional methods or future releases that will correct this issue (at least for instances within the same region)?

Thanks

---

<div class="post-metadata">

### Author: ![Mykola](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/mykola/32/30_2.png) [@Mykola](https://forums.percona.com/u/Mykola)
#### Post date: [January 6, 2017, 4:15am UTC](https://forums.percona.com/t/qan-fails-to-load-when-rds-in-different-region-availability-zone/5332/2 "2017-01-06T04:15:01Z")

</div>

It is need to understand that Amazon availability zones in different regions connected via public internet channels (see [guide](https://docs.aws.amazon.com/AWSEC2/latest/UserGuide/using-regions-availability-zones.html#concepts-regions-availability-zones)), in result they have regular delays and connectivity issues as in public internet.  
PMM server has very high resolution, so network connectivity can become an issue.

Can you change collect interval for qan-analyzer from 1 minute to 5 minutes?  
It is needed to login to Percona Query Analytics Web Interface, press “SETTINGS” button and change “Collect interval” value".

![Screenshot 2016-12-29 12.01.33 copy2.png](https://us1.discourse-cdn.com/flex019/uploads/percona1/original/2X/a/a36e42831133eb62a4092cf5df4ec6b270a4786e.jpeg)

---

<div class="post-metadata">

### Author: ![percona\_questions](https://avatars.discourse-cdn.com/v4/letter/p/ea5d25/32.png) [@percona\_questions](https://forums.percona.com/u/percona_questions)
#### Post date: [January 10, 2017, 1:43pm UTC](https://forums.percona.com/t/qan-fails-to-load-when-rds-in-different-region-availability-zone/5332/3 "2017-01-10T13:43:33Z")

</div>

Thanks - I’m not sure why I missed this setting. I’m still testing with different values, but this appears to have mitigated the problem.
