# Pxc cluster node can't join cluster after restart

**URL:** https://forums.percona.com/t/pxc-cluster-node-cant-join-cluster-after-restart/21246
**Category:** Percona XtraDB Cluster 8.x
**Created:** [April 7, 2023, 1:50pm UTC](https://forums.percona.com/t/pxc-cluster-node-cant-join-cluster-after-restart/21246 "2023-04-07T13:50:04Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![atimonin](https://avatars.discourse-cdn.com/v4/letter/a/ad7895/32.png) [@atimonin](https://forums.percona.com/u/atimonin)
#### Post date: [April 7, 2023, 1:50pm UTC](https://forums.percona.com/t/pxc-cluster-node-cant-join-cluster-after-restart/21246/1 "2023-04-07T13:50:04Z")

</div>

I have a problem with joining a node to a cluster after total shutdown.  
I started first node as bootstrap, looks OK.  
But second node didn’t start. I see following in log:  
023-04-07T12:05:48.774701Z 0 [Note] [MY-000000] [Galera] announce period timed out (pc.announce\_timeout)  
2023-04-07T12:05:48.774782Z 0 [Note] [MY-000000] [Galera] EVS version upgrade 0 → 1  
2023-04-07T12:05:48.774801Z 0 [Note] [MY-000000] [Galera] PC protocol upgrade 0 → 1  
2023-04-07T12:05:48.774823Z 0 [Warning] [MY-000000] [Galera] no nodes coming from prim view, prim not possible  
2023-04-07T12:05:48.774852Z 0 [Note] [MY-000000] [Galera] Current view of cluster as seen by this node  
view (view\_id(NON\_PRIM,86fb5048-ae07,1)  
memb {  
86fb5048-ae07,0  
}  
joined {  
}  
left {  
}  
partitioned {  
}  
)  
2023-04-07T12:05:49.275105Z 0 [Warning] [MY-000000] [Galera] last inactive check more than PT1.5S (3\*evs.inactive\_check\_period) ago (PT3.50212S),  
skipping check  
2023-04-07T12:06:18.782654Z 0 [Note] [MY-000000] [Galera] PC protocol downgrade 1 → 0  
2023-04-07T12:06:18.782710Z 0 [Note] [MY-000000] [Galera] Current view of cluster as seen by this node  
view ((empty))  
2023-04-07T12:06:18.782784Z 0 [ERROR] [MY-000000] [Galera] failed to open gcomm backend connection: 110: failed to reach primary view (pc.wait\_prim\_timeout): 110 (Connection timed out)  
at gcomm/src/pc.cpp:connect():161  
2023-04-07T12:06:18.782800Z 0 [ERROR] [MY-000000] [Galera] gcs/src/gcs\_core.cpp:gcs\_core\_open():219: Failed to open backend connection: -110 (Connection timed out)  
2023-04-07T12:06:19.782987Z 0 [Note] [MY-000000] [Galera] gcomm: terminating thread  
2023-04-07T12:06:19.783038Z 0 [Note] [MY-000000] [Galera] gcomm: joining thread  
2023-04-07T12:06:19.783164Z 0 [ERROR] [MY-000000] [Galera] gcs/src/gcs.cpp:gcs\_open():1811: Failed to open channel ‘preview-pxc-cluster’ at ‘gcomm://172.17.242.2,172.17.242.3,172.17.254.2’: -110 (Connection timed out)  
2023-04-07T12:06:19.783184Z 0 [ERROR] [MY-000000] [Galera] gcs connect failed: Connection timed out  
2023-04-07T12:06:19.783199Z 0 [ERROR] [MY-000000] [WSREP] Provider/Node (gcomm://172.17.242.2,172.17.242.3,172.17.254.2) failed to establish connection with cluster (reason: 7)  
2023-04-07T12:06:19.783255Z 0 [ERROR] [MY-010119] [Server] Aborting  
2023-04-07T12:06:19.783519Z 0 [System] [MY-010910] [Server] /usr/sbin/mysqld: Shutdown complete (mysqld 8.0.29-21.1) Percona XtraDB Cluster (GPL), Release rel21, Revision 250bc93, WSREP version 26.4.3.  
2023-04-07T12:06:19.784661Z 0 [Note] [MY-000000] [Galera] dtor state: CLOSED  
2023-04-07T12:06:19.784714Z 0 [Note] [MY-000000] [Galera] MemPool(TrxHandleSlave): hit ratio: 0, misses: 0, in use: 0, in pool: 0  
2023-04-07T12:06:19.786396Z 0 [Note] [MY-000000] [Galera] apply mon: entered 0

On primary node only suspicios in logs is  
2023-04-07T13:44:11.702271Z 122877 [ERROR] [MY-000000] [WSREP] Failed to create write-set from binlog, data\_len: 0

Where to look for root cause and how to repair?

---

<div class="post-metadata">

### Author: ![matthewb](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/matthewb/32/34_2.png) [@matthewb](https://forums.percona.com/u/matthewb)
#### Post date: [April 10, 2023, 2:56pm UTC](https://forums.percona.com/t/pxc-cluster-node-cant-join-cluster-after-restart/21246/2 "2023-04-10T14:56:44Z")

</div>

> [@atimonin](#):
>
> gcs connect failed: Connection timed out

You have network issues. Ensure all proper ports are open between all nodes. Use `ss` or `nc` or `telnet` to verify you can connect to all nodes, from all nodes on 3306, 4444, 4567, 4568.

Also, because PXC 8 is SSL by default, ensure you have copied the SSL certificates from the bootstrap node to the other nodes before joining them. All nodes must use the same SSL certs.
