# pt-toolkit tools ( like pt-show-grants , pt-archiver )

**URL:** <https://forums.percona.com/t/pt-toolkit-tools-like-pt-show-grants-pt-archiver/38561>\
**Category:** Percona Server for MySQL 8.0\
**Created:** [July 4, 2025, 9:26am UTC](https://forums.percona.com/t/pt-toolkit-tools-like-pt-show-grants-pt-archiver/38561 "2025-07-04T09:26:28Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![praghu2](https://avatars.discourse-cdn.com/v4/letter/p/b487fb/32.png) [@praghu2](https://forums.percona.com/u/praghu2)\
**Post date:** [July 4, 2025, 9:26am UTC](https://forums.percona.com/t/pt-toolkit-tools-like-pt-show-grants-pt-archiver/38561/1 "2025-07-04T09:26:28Z")

</div>

**pt-toolkit tools ( like pt-show-grants , pt-archiver ) is unable to connect to GCP MySQL instance, getting access denied**

- **pt-toolkit tools ( like pt-show-grants , pt-archiver ) is unable to connect to GCP MySQL instance, getting access denied**
- **user has required access and able to check show create user or other operations using ( mysql -h host -u user -p)**

User has following grants:

GRANT PROCESS, SHOW DATABASES ON _._ TO `test`@`%`  
GRANT SELECT, INSERT, UPDATE, DELETE, CREATE, DROP, REFERENCES, ALTER, LOCK TABLES ON _._ TO `test`@`%`

```auto

Below is the error, tried with SSL cert keys as well but still getting the same error

/usr/bin/pt-show-grants --user=test --ask-pass --host=<host-IP>Enter password: DBI connect(';host=<host-IP>;mysql_read_default_group=client','test',...) failed: Access denied for user 'test'@'ip' (using password: YES) at /usr/bin/pt-show-grants line 1367. 

```

---

<div class="post-metadata">

**Author:** ![Yunus](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/yunus/32/6430_2.png) [@Yunus](https://forums.percona.com/u/Yunus)\
**Post date:** [July 5, 2025, 1:57am UTC](https://forums.percona.com/t/pt-toolkit-tools-like-pt-show-grants-pt-archiver/38561/2 "2025-07-05T01:57:06Z")

</div>

> [@praghu2](#):
>
> user has required access and able to check show create user or other operations using ( mysql -h host -u user -p)

I hope you mean here that you tried to login with same MySQL user using MySQL client correct?  
If not then, you can try and see if you can login using MySQL client.

Also check which authentication plugin is the user using,

```auto
select user,host,plugin from mysql.user where user='test';

```

Check which version of percona toolkit are you using?  
and also the version of perl-DBD.
