# pt-table-sync with no unique index - fails with no more space left

**URL:** <https://forums.percona.com/t/pt-table-sync-with-no-unique-index-fails-with-no-more-space-left/2886>\
**Category:** Percona Toolkit\
**Created:** [August 18, 2013, 5:26pm UTC](https://forums.percona.com/t/pt-table-sync-with-no-unique-index-fails-with-no-more-space-left/2886 "2013-08-18T17:26:08Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![Tetelu](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/tetelu/32/952_2.png) [@Tetelu](https://forums.percona.com/u/Tetelu)\
**Post date:** [August 18, 2013, 5:26pm UTC](https://forums.percona.com/t/pt-table-sync-with-no-unique-index-fails-with-no-more-space-left/2886/1 "2013-08-18T17:26:08Z")

</div>

Hello,

I have a master-slave replication and I’m having trouble syncing one table that has no unique index, so I used the --no-check-slave option and when I thought it all goes well, error occurred:  
Error writing file ‘/dev/shm/MYGFvDuG’ (Errcode: 28) [for Statement “SELECT `[B]column1[/B]`, `[B]column2[/B]`, `[B]column3[/B]`, COUNT(\*) AS \_\_maatkit\_count FROM `[B]database[/B]`.`[B]table[/B]` WHERE 1=1 GROUP BY `[B]column1[/B]`, `[B]column2[/B]`, `[B]column3[/B]` ORDER BY `[B]column1[/B]`, `[B]column2[/B]`, `[B]column3[/B]` LOCK IN SHARE MODE”] at line 5301 while doing database.table on slave.server

The command I used is:  
pt-table-sync --execute --no-check-slave h=localhost,D=database,t=table h=slave.server,u=user,p=password,D=database,t=table

The dry-run looks ok, no errors, version: pt-table-sync 2.1.1

I know the problem is that the query quickly eats all the ram, then goes writing in /dev/shm/ until it fills it, then fails with no more space left…  
Mysql error log shows: [ERROR] /usr/sbin/mysqld: Sort aborted

Any solution to write it somewhere else? Or any other solution?

Any help will be really appreciated.
