# Pt-table-checksum not compatible with MySQL 8.0.28?

**URL:** <https://forums.percona.com/t/pt-table-checksum-not-compatible-with-mysql-8-0-28/14410>\
**Category:** Percona Toolkit\
**Tags:** closed-no-reply\
**Created:** [February 15, 2022, 5:00pm UTC](https://forums.percona.com/t/pt-table-checksum-not-compatible-with-mysql-8-0-28/14410 "2022-02-15T17:00:08Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![steffen](https://avatars.discourse-cdn.com/v4/letter/s/df788c/32.png) [@steffen](https://forums.percona.com/u/steffen)\
**Post date:** [February 15, 2022, 5:00pm UTC](https://forums.percona.com/t/pt-table-checksum-not-compatible-with-mysql-8-0-28/14410/1 "2022-02-15T17:00:08Z")

</div>

Hi everyone,

I tried to use pt-table-checksum (3.3.1) for checking a MySQL 8.0.28 replication. All I get is this error message:

02-15T16:39:25 Error checksumming table schemaname.tablename: Error executing checksum query: Checksum query for table schemaname.tablename caused MySQL error 1287:  
Level: Warning  
Code: 1287  
Message: Setting user variables within expressions is deprecated and will be removed in a future release. Consider alternatives: ‘SET variable=expression, …’, or ‘SELECT expression(s) INTO variables(s)’.  
Query: REPLACE INTO `percona`.`checksum6` (db, tbl, chunk, chunk\_index, lower\_boundary, upper\_boundary, this\_cnt, this\_crc) SELECT ?, ?, ?, ?, ?, ?, COUNT(\*) AS cnt, COALESCE(LOWER(CONCAT(LPAD(CONV(BIT\_XOR(CAST(CONV(SUBSTRING(@crc, 1, 16), 16, 10) AS UNSIGNED)), 10, 16), 16, ‘0’), LPAD(CONV(BIT\_XOR(CAST(CONV(SUBSTRING(@crc := MD5(CONCAT\_WS( …

Call Parameters:

/usr/bin/pt-table-checksum  
–recursion-method dsn=h=10.x.x.x,P=xxxx,D=percona,t=dsns6\_dtidbs  
–replicate=percona.checksum6  
–create-replicate-table  
–no-check-binlog-format  
–function MD5  
-h 10.x.x.x --defaults-file=/etc/mysql/…cnf  
–set-vars innodb\_lock\_wait\_timeout=50  
–tables …

Couldn’t find anything helpful in the manual or elsewhere. Is pt-table-checksum not compatible with 8.0?  
And it’s only a warning, why would the tool need to abort on that?

Also, on a Debian 9.13 the Percona repository gives me toolkit version 3.3.1, but on a Debian 11 bullseye I only get 3.2.1-1 as “the newest version”. Is it supposed to be that way?

---

<div class="post-metadata">

**Author:** ![steffen](https://avatars.discourse-cdn.com/v4/letter/s/df788c/32.png) [@steffen](https://forums.percona.com/u/steffen)\
**Post date:** [February 19, 2025, 1:58pm UTC](https://forums.percona.com/t/pt-table-checksum-not-compatible-with-mysql-8-0-28/14410/2 "2025-02-19T13:58:22Z")

</div>

Hi, I still get the same error with Toolkit V3.6.0 and MySQL 8.0.41.  
I don’t see an option that forces the tool to ignore the warning.  
So again: is pt-table-checksum not compatible with 8.0?

---

<div class="post-metadata">

**Author:** ![steffen](https://avatars.discourse-cdn.com/v4/letter/s/df788c/32.png) [@steffen](https://forums.percona.com/u/steffen)\
**Post date:** [February 19, 2025, 6:51pm UTC](https://forums.percona.com/t/pt-table-checksum-not-compatible-with-mysql-8-0-28/14410/3 "2025-02-19T18:51:05Z")

</div>

Workaround: Adding the line  
` 1287 => 1,`  
to the `%ignore_code` definition.  
Shouldn’t that be in the distributed code?
