# pt-table-checksum fails to connect to slave

**URL:** https://forums.percona.com/t/pt-table-checksum-fails-to-connect-to-slave/5703
**Category:** Percona Toolkit
**Created:** [June 28, 2017, 8:45am UTC](https://forums.percona.com/t/pt-table-checksum-fails-to-connect-to-slave/5703 "2017-06-28T08:45:51Z")
**Posts on this page:** 1
**Page:** 1

<div class="post-metadata">

### Author: ![wpirraglia](https://avatars.discourse-cdn.com/v4/letter/w/eb9ed0/32.png) [@wpirraglia](https://forums.percona.com/u/wpirraglia)
#### Post date: [June 28, 2017, 8:45am UTC](https://forums.percona.com/t/pt-table-checksum-fails-to-connect-to-slave/5703/1 "2017-06-28T08:45:51Z")

</div>

Executing pt-table-checksum on mariadb 10.1.20 with ubuntu xenial 16.04.2 gets the following error:

```auto
06-28T14:01:37 DBI connect(';host=xxxxx;mysql_read_default_group=client','xxxxx',...) failed: SSL connection error: unknown error number at /opt/scripts/pt-table-checksum line 1586.

```

The same parameters and configuration were being used with ubuntu precise 12.04.5, and was working ok.  
The mysql user for runing pt-table-checksum has the following permissions on all the server databases, besides having all privileges on the database where the checksum results are kept:

```auto
GRANT SELECT, PROCESS, SUPER, REPLICATION SLAVE, REPLICATION CLIENT ON *.*

```

Will appreciate any answer about it!
