# pt-query-digest errors report understanding

**URL:** <https://forums.percona.com/t/pt-query-digest-errors-report-understanding/5574>\
**Category:** Percona Toolkit\
**Created:** [April 27, 2017, 8:20am UTC](https://forums.percona.com/t/pt-query-digest-errors-report-understanding/5574 "2017-04-27T08:20:29Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![osa](https://avatars.discourse-cdn.com/v4/letter/o/4bbf92/32.png) [@osa](https://forums.percona.com/u/osa)\
**Post date:** [April 27, 2017, 8:20am UTC](https://forums.percona.com/t/pt-query-digest-errors-report-understanding/5574/1 "2017-04-27T08:20:29Z")

</div>

Dear Colleagues,

Could you please assist me in understanding the nature of errors in report  
and how they are critical.

Here is what I have at the moment:  
I’ve collected tcpdump

> sudo tcpdump -s 65535 -x -nn -q -tttt -i any -c 2000000 port 3306 \>/tmp/mysql\_dump\_2704\_0555.txt  
> then analyzed it  
> pt-query-digest --type tcpdump /tmp/mysql\_dump\_2704\_0555.txt \>/tmp/mysql\_dump\_digest\_2704\_0555.txt

TCP errors session were reported to /tmp/pt-query-digest-errors.qvGoT9E

There are a lot of

# reason\_for\_failure =\> ‘no server OK to previous command’,

# state =\> ‘awaiting\_reply’,

and

# reason\_for\_failure =\> ‘got server response before full buffer’,

and sometimes non-empty server\_retransmissions

I haven’t found good explanation for them.

Should I worry about them? Are they critical and affect my DB?  
Can you point me out for description and further troubleshooting steps?

Thank you.

P.S. I have 2.2.14 pt-query-digest and Percona-Server-server-56-5.6.32

---

<div class="post-metadata">

**Author:** ![carlos.salguero](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/carlos.salguero/32/20_2.png) [@carlos.salguero](https://forums.percona.com/u/carlos.salguero)\
**Post date:** [April 27, 2017, 8:56am UTC](https://forums.percona.com/t/pt-query-digest-errors-report-understanding/5574/2 "2017-04-27T08:56:45Z")

</div>

Could you please try a newer version?  
The current Percona Toolkit version is 3.0.2 and there were many changes since 2.2.14 was released (2015-04-14).  
You can download the latest version from [url][https://www.percona.com/software/database-tools/percona-toolkit[/url]](https://www.percona.com/software/database-tools/percona-toolkit%5B/url%5D)

Regards

---

<div class="post-metadata">

**Author:** ![osa](https://avatars.discourse-cdn.com/v4/letter/o/4bbf92/32.png) [@osa](https://forums.percona.com/u/osa)\
**Post date:** [April 27, 2017, 9:10am UTC](https://forums.percona.com/t/pt-query-digest-errors-report-understanding/5574/3 "2017-04-27T09:10:44Z")

</div>

oh. I’ve removed tcpdump already as it occupied too much space(  
But I’ve check diff of code briefly and seems there were no changes for these section (mentioned errors detection ones).

And also - these are not errors in code but detected errors during queries processing (as far as I understand)

So just trying to find explanation of what was detected in my case

---

<div class="post-metadata">

**Author:** ![carlos.salguero](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/carlos.salguero/32/20_2.png) [@carlos.salguero](https://forums.percona.com/u/carlos.salguero)\
**Post date:** [April 27, 2017, 9:23am UTC](https://forums.percona.com/t/pt-query-digest-errors-report-understanding/5574/4 "2017-04-27T09:23:40Z")

</div>

Please consider that for this answer, I have no examples to work with, but as far I can see, that message comes from MySQLProtocolParser: [url][percona-toolkit/MySQLProtocolParser.pm at 3.0 · percona/percona-toolkit · GitHub](https://github.com/percona/percona-toolkit/blob/3.0/lib/MySQLProtocolParser.pm#L407%5B/url%5D)  
I don’t remember all the specific updates we did in that library, but that might be the source of the problem.  
I can mention this issue that can be related: [url][https://bugs.launchpad.net/percona-toolkit/+bug/1402776[/url]](https://bugs.launchpad.net/percona-toolkit/+bug/1402776%5B/url%5D).

Regards

---

<div class="post-metadata">

**Author:** ![osa](https://avatars.discourse-cdn.com/v4/letter/o/4bbf92/32.png) [@osa](https://forums.percona.com/u/osa)\
**Post date:** [April 28, 2017, 3:08am UTC](https://forums.percona.com/t/pt-query-digest-errors-report-understanding/5574/5 "2017-04-28T03:08:03Z")

</div>

I’ll try to update  
but it is production server

will get back to you with results

just an idea - these errors were observed due to tcp packets fragmentation. weren’t they ?

---

<div class="post-metadata">

**Author:** ![carlos.salguero](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/carlos.salguero/32/20_2.png) [@carlos.salguero](https://forums.percona.com/u/carlos.salguero)\
**Post date:** [April 28, 2017, 6:36am UTC](https://forums.percona.com/t/pt-query-digest-errors-report-understanding/5574/6 "2017-04-28T06:36:13Z")

</div>

It seems like there are missing (maybe skipped for some reason) packets.  
If you could provide a tcp dump as an example, I can take a look.  
Thanks.

---

<div class="post-metadata">

**Author:** ![osa](https://avatars.discourse-cdn.com/v4/letter/o/4bbf92/32.png) [@osa](https://forums.percona.com/u/osa)\
**Post date:** [May 9, 2017, 1:05am UTC](https://forums.percona.com/t/pt-query-digest-errors-report-understanding/5574/7 "2017-05-09T01:05:51Z")

</div>

Hi Carlos,

I’ve updated toolkit to percona-toolkit-3.0.2-1.el7.x86\_64.rpm

Here is fresh grep about reasons from error report and tcpdump screenshot - [http://joxi.ru/Dr8y9ERc4Y8qxm](http://joxi.ru/Dr8y9ERc4Y8qxm)  
(can’t provide you with raw dump as it could contain customer’s private data).

Still top reasons are

# reason\_for\_failure =\> ‘no server OK to previous command’,

# state =\> ‘awaiting\_reply’,

and

# reason\_for\_failure =\> ‘got server response before full buffer’,

and some other

So once again my questions:

1. what could be a reason for

# reason\_for\_failure =\> ‘no server OK to previous command’,

# state =\> ‘awaiting\_reply’,

2.what could be a reason for

# reason\_for\_failure =\> ‘got server response before full buffer’,

3.what could be a reason for

# reason\_for\_failure =\> ‘client cmd not packet 0’,

4.what could be a reason for non-empty

# server\_retransmissions =\> [

# 1999078553,

# 1999078553

# ],

I suppose if such a common errors can be described somewhere in guides, this will be very useful.

Finally, can these issues be connected to network issues and how can I investigate/fix ?

Your help will be very appreciated.

Thank you.

 ![mysql_dump.09.05_new.pcap.jpg](https://us1.discourse-cdn.com/flex019/uploads/percona1/original/2X/2/26030ec9d547b86c7f7329dd7f6b3b4a0ed86abb.jpeg)

---

<div class="post-metadata">

**Author:** ![carlos.salguero](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/carlos.salguero/32/20_2.png) [@carlos.salguero](https://forums.percona.com/u/carlos.salguero)\
**Post date:** [May 9, 2017, 7:09am UTC](https://forums.percona.com/t/pt-query-digest-errors-report-understanding/5574/8 "2017-05-09T07:09:19Z")

</div>

Those messages come from MySQLProtocolParser.  
I see errors in the screenshot: some packets were lost (Previous segment not captured) and that could be the source of the problem.  
If there are missing packets, ProtocolParser cannot do a correct analysis.

Regards
