# Pt-online-schema-change --execute fails to connect after MySQL 8 upgrade, but --dry-run still works

**URL:** <https://forums.percona.com/t/pt-online-schema-change-execute-fails-to-connect-after-mysql-8-upgrade-but-dry-run-still-works/27897>\
**Category:** MySQL & MariaDB\
**Created:** [January 19, 2024, 7:17pm UTC](https://forums.percona.com/t/pt-online-schema-change-execute-fails-to-connect-after-mysql-8-upgrade-but-dry-run-still-works/27897 "2024-01-19T19:17:13Z")\
**Posts on this page:** 1\
**Showing post:** 7

<div class="post-metadata">

**Author:** ![Charles\_Guertin](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/charles_guertin/32/14839_2.png) [@Charles\_Guertin](https://forums.percona.com/u/Charles_Guertin)\
**Post date:** [January 24, 2024, 6:45pm UTC](https://forums.percona.com/t/pt-online-schema-change-execute-fails-to-connect-after-mysql-8-upgrade-but-dry-run-still-works/27897/7 "2024-01-24T18:45:10Z")

</div>

Similar issue: [Pt-online-schema-change changes IP of my host - #3 by Ken\_Shih](https://forums.percona.com/t/pt-online-schema-change-changes-ip-of-my-host/24499/3)  
seems like adding `--recursion-method=NONE` to your command does the trick. It fixed my issues, at least.

---

_[View the full topic](https://forums.percona.com/t/pt-online-schema-change-execute-fails-to-connect-after-mysql-8-upgrade-but-dry-run-still-works/27897)._
