# Pt-online-schema-change --execute fails to connect after MySQL 8 upgrade, but --dry-run still works

**URL:** <https://forums.percona.com/t/pt-online-schema-change-execute-fails-to-connect-after-mysql-8-upgrade-but-dry-run-still-works/27897>\
**Category:** MySQL & MariaDB\
**Created:** [January 19, 2024, 7:17pm UTC](https://forums.percona.com/t/pt-online-schema-change-execute-fails-to-connect-after-mysql-8-upgrade-but-dry-run-still-works/27897 "2024-01-19T19:17:13Z")\
**Posts on this page:** 1\
**Showing post:** 6

<div class="post-metadata">

**Author:** ![Matic\_Petek](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/matic_petek/32/13625_2.png) [@Matic\_Petek](https://forums.percona.com/u/Matic_Petek)\
**Post date:** [January 24, 2024, 6:20pm UTC](https://forums.percona.com/t/pt-online-schema-change-execute-fails-to-connect-after-mysql-8-upgrade-but-dry-run-still-works/27897/6 "2024-01-24T18:20:32Z")

</div>

Hi,  
I found around for this :

- pt-online-schema-change is PERL script and you can edit it
- see line 2340, after “my $tries = 2;”
- something is wrong with $cxn\_string - it include strange IP address. I don’t know where this is getting IP, because it is not nslookup of RDS URL (also not of RDS replica)
- first I add “print “\nConnect string before : $cxn\_string\n”;” after “my $tries = 2;” (line 2341)
- after getting this value, I tool IP address and replace it with my primary RDS hostname
- example : “$cxn\_string =~ s/10.1.1.110/mkprod.REMOVEKEY.eu-central-1.rds.amazonaws.com/;”  
And then it is working. I have successful extended 2 RDS instances with primary+replica.

---

_[View the full topic](https://forums.percona.com/t/pt-online-schema-change-execute-fails-to-connect-after-mysql-8-upgrade-but-dry-run-still-works/27897)._
