# Pt-online-schema-change error Can't connect to local MySQL server

**URL:** <https://forums.percona.com/t/pt-online-schema-change-error-cant-connect-to-local-mysql-server/37072>\
**Category:** Percona Toolkit\
**Created:** [March 6, 2025, 8:25am UTC](https://forums.percona.com/t/pt-online-schema-change-error-cant-connect-to-local-mysql-server/37072 "2025-03-06T08:25:00Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![ph\_h](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/ph_h/32/20388_2.png) [@ph\_h](https://forums.percona.com/u/ph_h)\
**Post date:** [March 6, 2025, 8:25am UTC](https://forums.percona.com/t/pt-online-schema-change-error-cant-connect-to-local-mysql-server/37072/1 "2025-03-06T08:25:00Z")

</div>

help me  
Ubuntu 24.04.2 LTS  
pt-online-schema-change 3.7.0  
pt-online-schema-change --user=qos\_dev --ask-pass --host=[rm-2ze81ryvx0k42106h239.mysql.rds.aliyuncs.com](http://rm-2ze81ryvx0k42106h239.mysql.rds.aliyuncs.com) --port=3306 --alter “ADD COLUMN t\_id int NOT NULL DEFAULT 0 COMMENT ‘测试字段’” D=qos,t=qos\_value\_tag --dry-run  
dry-run all right  
pt-online-schema-change --user=qos\_dev --ask-pass --host=[rm-2ze81ryvx0k42106h239.mysql.rds.aliyuncs.com](http://rm-2ze81ryvx0k42106h239.mysql.rds.aliyuncs.com) --port=3306 --alter “ADD COLUMN t\_id int NOT NULL DEFAULT 0 COMMENT ‘测试字段’” D=qos,t=qos\_value\_tag --execute  
execute error：  
Enter MySQL password:  
Cannot connect to P=3043,h=,p=…,u=qos\_dev: DBI connect(‘;host=;port=3043;mysql\_read\_default\_group=client’,‘qos\_dev’,…) failed: Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (2) at /usr/bin/pt-online-schema-change line 2345.  
Can’t call method “selectrow\_array” on an undefined value at /usr/bin/pt-online-schema-change line 4391, line 1.

---

<div class="post-metadata">

**Author:** ![matthewb](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/matthewb/32/34_2.png) [@matthewb](https://forums.percona.com/u/matthewb)\
**Post date:** [March 6, 2025, 1:26pm UTC](https://forums.percona.com/t/pt-online-schema-change-error-cant-connect-to-local-mysql-server/37072/2 "2025-03-06T13:26:53Z")

</div>

Please look for a ~/.my.cnf or /etc/my.cnf file that is overriding the port parameter.

---

<div class="post-metadata">

**Author:** ![ph\_h](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/ph_h/32/20388_2.png) [@ph\_h](https://forums.percona.com/u/ph_h)\
**Post date:** [March 7, 2025, 12:29am UTC](https://forums.percona.com/t/pt-online-schema-change-error-cant-connect-to-local-mysql-server/37072/3 "2025-03-07T00:29:52Z")

</div>

The current machine does not have mysql installed. Do I need to install mysql?

---

<div class="post-metadata">

**Author:** ![matthewb](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/matthewb/32/34_2.png) [@matthewb](https://forums.percona.com/u/matthewb)\
**Post date:** [March 8, 2025, 3:42pm UTC](https://forums.percona.com/t/pt-online-schema-change-error-cant-connect-to-local-mysql-server/37072/4 "2025-03-08T15:42:14Z")

</div>

No, but you clearly have some local config that is overriding the pt-osc defaults, as evidenced here:

> [@ph\_h](#):
>
> DBI connect(‘;host=;port=3043;mysql\_read\_default\_group=client’,‘qos\_dev’,…)

---

<div class="post-metadata">

**Author:** ![ph\_h](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/ph_h/32/20388_2.png) [@ph\_h](https://forums.percona.com/u/ph_h)\
**Post date:** [March 10, 2025, 3:32am UTC](https://forums.percona.com/t/pt-online-schema-change-error-cant-connect-to-local-mysql-server/37072/5 "2025-03-10T03:32:19Z")

</div>

The newly installed tool does not have any configuration files configured. There is no problem installing it on your own development machine. It’s strange.

---

<div class="post-metadata">

**Author:** ![ph\_h](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/ph_h/32/20388_2.png) [@ph\_h](https://forums.percona.com/u/ph_h)\
**Post date:** [March 10, 2025, 7:35am UTC](https://forums.percona.com/t/pt-online-schema-change-error-cant-connect-to-local-mysql-server/37072/6 "2025-03-10T07:35:38Z")

</div>

Solved, because I used Alibaba Cloud’s RDS database, and set --recursion-method=none.
