# Pt-archiver to "Azure Database for MySQL servers" does not work if SSL is enabled

**URL:** https://forums.percona.com/t/pt-archiver-to-azure-database-for-mysql-servers-does-not-work-if-ssl-is-enabled/8399
**Category:** Other MySQL® Questions
**Tags:** mysql, percona
**Created:** [December 16, 2020, 10:35am UTC](https://forums.percona.com/t/pt-archiver-to-azure-database-for-mysql-servers-does-not-work-if-ssl-is-enabled/8399 "2020-12-16T10:35:58Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![slash](https://avatars.discourse-cdn.com/v4/letter/s/a3d4f5/32.png) [@slash](https://forums.percona.com/u/slash)
#### Post date: [December 16, 2020, 10:35am UTC](https://forums.percona.com/t/pt-archiver-to-azure-database-for-mysql-servers-does-not-work-if-ssl-is-enabled/8399/1 "2020-12-16T10:35:58Z")

</div>

After enabling SSL mode on MySQL Azure PaaS the connection fails with the following error:

DBI connect(‘test\_percona;mysql\_read\_default\_file=/root/PERCONA/ssl-ptachiver.conf;host=db\*\*\*\*\*\*\*\*.mysql.database.azure.com;mysql\_read\_default\_group=client’,‘userbackup@db\*\*\*\*\*\*\*\*.mysql.database.azure.com’,…) failed: SSL connection error: Client is not configured to use SSL at ./pt-archiver line 2525.

I tried to configure the Azure CA certificate in my.cnf of the client, but I have the same error:

[client]

ssl = 1

ssl-mode = REQUIRED

user=userbackup

mysql\_ssl=1

mysql\_ssl\_ca\_file=/root/PERCONA/DigiCertGlobalRootG2.crt.pem

I can’t understand where I’m wrong, Thanks for the help…

---

<div class="post-metadata">

### Author: ![matthewb](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/matthewb/32/34_2.png) [@matthewb](https://forums.percona.com/u/matthewb)
#### Post date: [January 21, 2021, 9:25pm UTC](https://forums.percona.com/t/pt-archiver-to-azure-database-for-mysql-servers-does-not-work-if-ssl-is-enabled/8399/2 "2021-01-21T21:25:48Z")

</div>

You need to specify the CA, Client Key, and Client Certificate in most cases.  
Also, the parameters are ‘ssl\_cert’, ‘ssl\_key’, and ‘ssl\_ca’  
Check out this blog post too [Percona Toolkit for MySQL with MySQL-SSL Connections](https://www.percona.com/blog/2014/10/16/percona-toolkit-for-mysql-with-mysql-ssl-connections/)
