# Problems with starting the mysql.service

**URL:** <https://forums.percona.com/t/problems-with-starting-the-mysql-service/7703>\
**Category:** Percona Server for MySQL 8.0\
**Tags:** mysql, percona\
**Created:** [June 19, 2020, 3:48am UTC](https://forums.percona.com/t/problems-with-starting-the-mysql-service/7703 "2020-06-19T03:48:53Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![alexmnsk](https://avatars.discourse-cdn.com/v4/letter/a/9fc29f/32.png) [@alexmnsk](https://forums.percona.com/u/alexmnsk)\
**Post date:** [June 19, 2020, 3:48am UTC](https://forums.percona.com/t/problems-with-starting-the-mysql-service/7703/1 "2020-06-19T03:48:53Z")

</div>

Hi,&nbsp;  
I hope someone can help me address the issue I’m stuck with. I must create another MySQL slave instance similar to the one which has been working for a long time already. The only difference is that the old one is “mysql&nbsp; Ver 8.0.19 for Linux on x86\_64 (MySQL Community Server - GPL)”, while the new one is “mysql&nbsp; Ver 8.0.19-10 for debian-linux-gnu on x86\_64 (Percona Server (GPL), Release ‘10’, Revision ‘f446c04’)”.&nbsp;  
  
So, what’s the problem? The problem is that I can’t start MySQL service on the new Percona Server because of errors “Data Dictionary initialization failed” and “Failed to find valid data directory”. It’s no problem to start the server when the datadir is empty, but it fails when I add files there. Below the steps to reproduce:  
  
1) I use SSHFS on the server 1 with MySQL Community Server to mount a remote file system and forward dumps directly to the server 2 with Percona Server&nbsp;  
2) After that I use ‘xtrabackup --backup --target-dir=/directory/’ followed by ‘xtrabackup --prepare --target-dir=/directory/’  
3) When everything is ready, I change permissions and ownership on the server 2 and start the service.  
4) The start up fails, so I run “mysqld --initialize”, but it doesn’t help.  
  
The log:  
2020-06-19T07:35:48.460188Z 0 [ERROR] [MY-010020] [Server] Data Dictionary initialization failed.2020-06-19T07:35:48.460235Z 0 [ERROR] [MY-010119] [Server] Aborting2020-06-19T07:35:48.460675Z 0 [System] [MY-010910] [Server] /usr/sbin/mysqld: Shutdown complete (mysqld 8.0.19-10)&nbsp; Percona Server (GPL), Release ‘10’, Revision ‘f446c04’.2020-06-19T07:42:59.701013Z 0 [Warning] [MY-011070] [Server] ‘Disabling symbolic links using --skip-symbolic-links (or equivalent) is the default. Consider not using this option as it’ is deprecated and will be removed in a future release.2020-06-19T07:42:59.701032Z 0 [Warning] [MY-010915] [Server] ‘NO\_ZERO\_DATE’, ‘NO\_ZERO\_IN\_DATE’ and ‘ERROR\_FOR\_DIVISION\_BY\_ZERO’ sql modes should be used with strict mode. They will be merged with strict mode in a future release.2020-06-19T07:42:59.702003Z 0 [System] [MY-010116] [Server] /usr/sbin/mysqld (mysqld 8.0.19-10) starting as process 90222020-06-19T07:42:59.707410Z 1 [ERROR] [MY-011011] [Server] Failed to find valid data directory.2020-06-19T07:42:59.707504Z 0 [ERROR] [MY-010020] [Server] Data Dictionary initialization failed.2020-06-19T07:42:59.707546Z 0 [ERROR] [MY-010119] [Server] Aborting2020-06-19T07:42:59.708023Z 0 [System] [MY-010910] [Server] /usr/sbin/mysqld: Shutdown complete (mysqld 8.0.19-10)&nbsp; Percona Server (GPL), Release ‘10’, Revision ‘f446c04’.

---

<div class="post-metadata">

**Author:** ![vaibhav\_upadhyay40](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/vaibhav_upadhyay40/32/9_2.png) [@vaibhav\_upadhyay40](https://forums.percona.com/u/vaibhav_upadhyay40)\
**Post date:** [June 19, 2020, 12:28pm UTC](https://forums.percona.com/t/problems-with-starting-the-mysql-service/7703/2 "2020-06-19T12:28:59Z")

</div>

@alexmnsk   
&nbsp;try to start explicitly by providing datadir path and default conf path.&nbsp;  
sudo mysqld --initialize --data-dir=/x/x/&nbsp;  
  
also just cross verify the variables mentioned in the cnf file are compatible and supported by the version.&nbsp;

---

<div class="post-metadata">

**Author:** ![alexmnsk](https://avatars.discourse-cdn.com/v4/letter/a/9fc29f/32.png) [@alexmnsk](https://forums.percona.com/u/alexmnsk)\
**Post date:** [June 25, 2020, 2:32am UTC](https://forums.percona.com/t/problems-with-starting-the-mysql-service/7703/3 "2020-06-25T02:32:06Z")

</div>

@vaibhav_upadhyay40 I did this multiple times, but it doesn’t help when I have data in the datadir. I can’t remove 1.1T, it doesn’t make sense for me. Is there any way to handle it without removing data?

---

<div class="post-metadata">

**Author:** ![vaibhav\_upadhyay40](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/vaibhav_upadhyay40/32/9_2.png) [@vaibhav\_upadhyay40](https://forums.percona.com/u/vaibhav_upadhyay40)\
**Post date:** [June 25, 2020, 4:15am UTC](https://forums.percona.com/t/problems-with-starting-the-mysql-service/7703/4 "2020-06-25T04:15:58Z")

</div>

can please you share below :  
  
output for command&nbsp;:&nbsp; &nbsp;  
sudo mysqld --initialize --data-dir=/1tb/data\_dir/path/  
mysql error logs  
OS version details
